summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-emulation/stella/stella-4.0.ebuild')
-rw-r--r--games-emulation/stella/stella-4.0.ebuild68
1 files changed, 0 insertions, 68 deletions
diff --git a/games-emulation/stella/stella-4.0.ebuild b/games-emulation/stella/stella-4.0.ebuild
deleted file mode 100644
index 5cf6b70c7e9e..000000000000
--- a/games-emulation/stella/stella-4.0.ebuild
+++ /dev/null
@@ -1,68 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-inherit eutils gnome2-utils games
-
-DESCRIPTION="Stella Atari 2600 VCS Emulator"
-HOMEPAGE="http://stella.sourceforge.net/"
-SRC_URI="mirror://sourceforge/stella/${P}-src.tar.gz"
-
-LICENSE="GPL-2 BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="joystick"
-
-DEPEND="media-libs/libsdl2[joystick?,opengl,video]
- media-libs/libpng:0
- sys-libs/zlib"
-RDEPEND=${DEPEND}
-
-src_prepare() {
- sed -i \
- -e '/INSTALL/s/-s //' \
- -e '/STRIP/d' \
- -e "/icons/d" \
- -e '/INSTALL.*DOCDIR/d' \
- -e '/INSTALL.*\/applications/d' \
- -e '/CXXFLAGS+=/s/-fomit-frame-pointer//' \
- Makefile || die
-}
-
-src_configure() {
- # not an autoconf script
- ./configure \
- --prefix="/usr" \
- --bindir="${GAMES_BINDIR}" \
- --docdir="/usr/share/doc/${PF}" \
- --datadir="${GAMES_DATADIR}" \
- $(use_enable joystick) \
- || die
-}
-
-src_install() {
- local i
- for i in 16 22 24 32 48 64 128 ; do
- newicon -s ${i} src/common/stella-${i}x${i}.png stella.png
- done
-
- emake DESTDIR="${D}" install
- domenu src/unix/stella.desktop
- dohtml -r docs/*
- dodoc Announce.txt Changes.txt Copyright.txt README-SDL.txt Readme.txt Todo.txt
- prepgamesdirs
-}
-
-pkg_preinst() {
- games_pkg_preinst
- gnome2_icon_savelist
-}
-
-pkg_postinst() {
- games_pkg_postinst
- gnome2_icon_cache_update
-}
-
-pkg_postrm() {
- gnome2_icon_cache_update
-}