summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-emulation/xe')
-rw-r--r--games-emulation/xe/Manifest2
-rw-r--r--games-emulation/xe/files/xe-2.16.210
-rw-r--r--games-emulation/xe/files/xe-2.16.2-gentoo.patch16
-rw-r--r--games-emulation/xe/metadata.xml8
-rw-r--r--games-emulation/xe/xe-2.16.2.ebuild53
5 files changed, 0 insertions, 89 deletions
diff --git a/games-emulation/xe/Manifest b/games-emulation/xe/Manifest
deleted file mode 100644
index f80d4034672a..000000000000
--- a/games-emulation/xe/Manifest
+++ /dev/null
@@ -1,2 +0,0 @@
-DIST xe-x86-32-bin.2.16.2.tar.bz2 1610395 BLAKE2B 37db06d73f5d6e3e6192e69bb2786b979e5cb74554fce3f89fd752dba76ea223d2a7a3e90950cc0d64d69e132d5bbd9f55816f93481d752aba79aa72e5ab1e97 SHA512 b73f79854f860f7e7060c8b09e0a038b787762d3bd440b5b2825b5a702e4f32c788b883012728813e0a9dcee779f8b98b807c8af3f655fea21bd0ed1383e361c
-DIST xe-x86-64-bin.2.16.2.tar.bz2 2141614 BLAKE2B cfa386cd1a0614d21f7f32af44fe13eeaf0b2b8f65c605961b2768087788a9e9b950955ec1853a0d3302326199217b180aa448669a31f662f05c8e867e018bdc SHA512 cf8a4be4f169660138018631b4a2b6c1a42850c7fc08bd9bd184ab054bffc6fe00197baaf9628cce87608628bb33db0dabac97debd7c53466b086cf0805cc5d8
diff --git a/games-emulation/xe/files/xe-2.16.2 b/games-emulation/xe/files/xe-2.16.2
deleted file mode 100644
index 211d508d883e..000000000000
--- a/games-emulation/xe/files/xe-2.16.2
+++ /dev/null
@@ -1,10 +0,0 @@
-#!/bin/sh
-
-if [[ ! -d ~/.xe/modules ]] ; then
- mkdir -p ~/.xe/modules
-fi
-for f in GENTOODIR/modules/*
-do
- ln -s $f ~/.xe/modules/ 2> /dev/null
-done
-exec xe.bin "${@}"
diff --git a/games-emulation/xe/files/xe-2.16.2-gentoo.patch b/games-emulation/xe/files/xe-2.16.2-gentoo.patch
deleted file mode 100644
index caea9c8c6c2e..000000000000
--- a/games-emulation/xe/files/xe-2.16.2-gentoo.patch
+++ /dev/null
@@ -1,16 +0,0 @@
---- Makefile.old 2012-12-20 21:20:49.560756950 +0100
-+++ Makefile 2012-12-20 21:22:16.644707544 +0100
-@@ -1,11 +1,9 @@
- BIN = xe
--CC = gcc
--CFLAGS = -Wl,-export-dynamic -L. -L/usr/X11R6/lib -lxe -lasound -ldl -lz \
-+LDLIBS = -L. -L/usr/X11R6/lib -lxe -lasound -ldl -lz \
- -lX11 -lXext -lXv -lXinerama -lXxf86vm `pkg-config gtk+-2.0 --libs`
-
- $(BIN): libxe.a
-- @ $(CC) -o $(BIN) $(CFLAGS)
-- @ strip $(BIN)
-+ $(CC) -o $(BIN) $(LDFLAGS) -Wl,-export-dynamic $(LDLIBS)
-
- install:
- @ sh install.sh
diff --git a/games-emulation/xe/metadata.xml b/games-emulation/xe/metadata.xml
deleted file mode 100644
index 78274e0fa550..000000000000
--- a/games-emulation/xe/metadata.xml
+++ /dev/null
@@ -1,8 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
-<maintainer type="project">
- <email>games@gentoo.org</email>
- <name>Gentoo Games Project</name>
-</maintainer>
-</pkgmetadata>
diff --git a/games-emulation/xe/xe-2.16.2.ebuild b/games-emulation/xe/xe-2.16.2.ebuild
deleted file mode 100644
index 05e925ca9283..000000000000
--- a/games-emulation/xe/xe-2.16.2.ebuild
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-inherit games
-
-DESCRIPTION="a multi system emulator for many console and handheld video game systems"
-HOMEPAGE="http://www.xe-emulator.com/"
-SRC_URI="amd64? ( http://www.xe-emulator.com/files/${PN}-x86-64-bin.${PV}.tar.bz2 )
- x86? ( http://www.xe-emulator.com/files/${PN}-x86-32-bin.${PV}.tar.bz2 )"
-
-LICENSE="all-rights-reserved"
-SLOT="0"
-KEYWORDS="-* ~amd64 ~x86"
-IUSE=""
-RESTRICT="mirror bindist strip"
-
-RDEPEND="x11-libs/libXv
- x11-libs/libXinerama
- x11-libs/libXxf86vm
- sys-libs/zlib
- media-libs/alsa-lib
- x11-libs/gtk+:2"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
-
-dir=${games_get_libdir}/${PN}
-
-QA_PREBUILT="${dir:1}/modules/*
- ${GAMES_BINDIR:1}/xe.bin"
-
-src_unpack() {
- unpack ${A}
- mv -v * ${P} || die
-}
-
-src_prepare() {
- epatch "${FILESDIR}"/${P}-gentoo.patch
-}
-
-src_install() {
- newgamesbin xe xe.bin
- newgamesbin "${FILESDIR}"/xe-${PV} xe
- sed -i \
- -e "s:GENTOODIR:$(games_get_libdir)/${PN}:" "${D}/${GAMES_BINDIR}/xe" \
- || die "sed failed"
- insinto "$(games_get_libdir)"/${PN}
- doins -r modules/ rc/
- keepdir "$(games_get_libdir)"/${PN}/bios
- dodoc README.txt
- dohtml manual.html
- prepgamesdirs
-}