summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-engines/frobtads/frobtads-1.2.2.ebuild')
-rw-r--r--games-engines/frobtads/frobtads-1.2.2.ebuild47
1 files changed, 0 insertions, 47 deletions
diff --git a/games-engines/frobtads/frobtads-1.2.2.ebuild b/games-engines/frobtads/frobtads-1.2.2.ebuild
deleted file mode 100644
index 4238931dfa79..000000000000
--- a/games-engines/frobtads/frobtads-1.2.2.ebuild
+++ /dev/null
@@ -1,47 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-inherit eutils flag-o-matic games
-
-DESCRIPTION="Curses-based interpreter and dev tools for TADS 2 and TADS 3 text adventures"
-HOMEPAGE="http://www.tads.org/frobtads.htm"
-SRC_URI="http://www.tads.org/frobtads/${P}.tar.gz"
-
-LICENSE="TADS2 TADS3"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="debug tads2compiler tads3compiler"
-
-RESTRICT="!tads3compiler? ( test )"
-
-RDEPEND="net-misc/curl
- sys-libs/ncurses:0"
-DEPEND=${RDEPEND}
-
-DOCS=( doc/{AUTHORS,BUGS,ChangeLog.old,NEWS,README,SRC_GUIDELINES,THANKS} )
-
-src_configure() {
- append-cxxflags -fpermissive
- egamesconf \
- $(use_enable debug t3debug) \
- $(use_enable debug error-checking) \
- $(use_enable tads2compiler t2-compiler) \
- $(use_enable tads3compiler t3-compiler)
-}
-
-src_test() {
- emake -j1 sample
- ./frob -i plain -p samples/sample.t3 <<- END_FROB_TEST
- save
- testsave.sav
- restore
- testsave.sav
- END_FROB_TEST
- [[ $? -eq 0 ]] || die "Failed to run test game"
-}
-
-src_install() {
- default
- prepgamesdirs
-}