summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-engines/openmw/files/openmw-0.46.0-recastnavigation.patch')
-rw-r--r--games-engines/openmw/files/openmw-0.46.0-recastnavigation.patch24
1 files changed, 24 insertions, 0 deletions
diff --git a/games-engines/openmw/files/openmw-0.46.0-recastnavigation.patch b/games-engines/openmw/files/openmw-0.46.0-recastnavigation.patch
new file mode 100644
index 000000000000..ea3242d73ca8
--- /dev/null
+++ b/games-engines/openmw/files/openmw-0.46.0-recastnavigation.patch
@@ -0,0 +1,24 @@
+Use system recastnavigation instead of bundled one
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index d69352c94..cfb53dc5b 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -596,7 +596,16 @@ endif(WIN32)
+ # Extern
+ set(RECASTNAVIGATION_STATIC ON CACHE BOOL "Build recastnavigation static libraries")
+
+-add_subdirectory (extern/recastnavigation EXCLUDE_FROM_ALL)
++add_library(RecastNavigation::DebugUtils SHARED IMPORTED)
++add_library(RecastNavigation::Detour SHARED IMPORTED)
++add_library(RecastNavigation::Recast SHARED IMPORTED)
++set_target_properties(RecastNavigation::DebugUtils PROPERTIES
++ IMPORTED_LOCATION GENTOO_RECAST_LIBDIR/libDebugUtils.so)
++set_target_properties(RecastNavigation::Detour PROPERTIES
++ IMPORTED_LOCATION GENTOO_RECAST_LIBDIR/libDetour.so)
++set_target_properties(RecastNavigation::Recast PROPERTIES
++ IMPORTED_LOCATION GENTOO_RECAST_LIBDIR/libRecast.so)
++
+ add_subdirectory (extern/osg-ffmpeg-videoplayer)
+ add_subdirectory (extern/oics)
+ if (BUILD_OPENCS)