summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-engines')
-rw-r--r--games-engines/scummvm/Manifest1
-rw-r--r--games-engines/scummvm/scummvm-2.0.0.ebuild103
2 files changed, 104 insertions, 0 deletions
diff --git a/games-engines/scummvm/Manifest b/games-engines/scummvm/Manifest
index 8ca008d5cdd6..c19aaec35bd2 100644
--- a/games-engines/scummvm/Manifest
+++ b/games-engines/scummvm/Manifest
@@ -1,3 +1,4 @@
DIST scummvm-1.8.0.tar.xz 17385064 BLAKE2B 02298f525f38d07f89ed829585498ca3cf807b6f1aa9f7601e5f1759a3d908cd99cd19c3a21169b7df9db52eb5b38e2b56d4eac6bdca3ba01c972e5a5054827b SHA512 2fb25467854d6115cf09fd40536728e2c1943c16d8bcb29ebbc3c37fa5dc750a72258e0b0dac6244e5ddcc5f2dfc69af3d7fdff83c98a92a546f8669daa8da27
DIST scummvm-1.8.1.tar.xz 17807468 BLAKE2B c5ba8c54b96467d4362b7a41afafd5686ae817b619a2bcbc5c82f10fbc0f89af78720ec187503dd3e4ed2ffff577932cf31f84c666cdabbddf579c0f79bfeb1a SHA512 e67ee332668b14432dcd675051384bd4fee2c1a0ddf44f6f8aeaf889d5027a834187e2632d18959583fa258cf03f259a54fd2d88120fa62ef7496232b4e6bdb4
DIST scummvm-1.9.0.tar.xz 22020384 BLAKE2B 10f2c20cf1e32a60897c9e909e0bfda7827a646eb38aaf4923b76708fb5b797c66f94d92f7c095ca77570712223cd0d037fccc563c709448d4d2093299050773 SHA512 c81248e8474ad5b354a46741ab2e40b8ddfb99e196b0c837424e9ccced285d03d5f12fc41be57034be53bdb8254a61ca0c9d9cd9a2340875d32e1bffa31699c2
+DIST scummvm-2.0.0.tar.xz 21291656 BLAKE2B 303aa4254d1c940ce6d65d192f2678a033015f1b85e38c62902aa8fac05a1ff33fd7e3fe9de47825cd0cf72076027adb21c72a63a38349f9ee8f63566f3db948 SHA512 5f4c11145c5dfcc7ae95d5c0e5ac9e938912cc5060b9d5fdfcb699a745755b31412e44199e487ad388ca5e091afc3366f874610adb44d440f336e26d6cd4812c
diff --git a/games-engines/scummvm/scummvm-2.0.0.ebuild b/games-engines/scummvm/scummvm-2.0.0.ebuild
new file mode 100644
index 000000000000..4f775bc1705d
--- /dev/null
+++ b/games-engines/scummvm/scummvm-2.0.0.ebuild
@@ -0,0 +1,103 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit eutils flag-o-matic gnome2-utils toolchain-funcs xdg-utils
+
+DESCRIPTION="Reimplementation of the SCUMM game engine used in Lucasarts adventures"
+HOMEPAGE="http://scummvm.sourceforge.net/"
+SRC_URI="http://scummvm.org/frs/scummvm/${PV}/${P}.tar.xz"
+
+LICENSE="GPL-2+ LGPL-2.1 BSD GPL-3-with-font-exception"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86 ~x86-fbsd"
+IUSE="aac alsa debug flac fluidsynth jpeg mpeg2 mp3 opengl png theora truetype unsupported vorbis zlib"
+RESTRICT="test" # it only looks like there's a test there #77507
+
+RDEPEND=">=media-libs/libsdl2-2.0.0[sound,joystick,video]
+ zlib? ( sys-libs/zlib )
+ jpeg? ( virtual/jpeg:0 )
+ png? ( media-libs/libpng:0 )
+ vorbis? ( media-libs/libogg media-libs/libvorbis )
+ theora? ( media-libs/libtheora )
+ aac? ( media-libs/faad2 )
+ alsa? ( media-libs/alsa-lib )
+ mp3? ( media-libs/libmad )
+ mpeg2? ( media-libs/libmpeg2 )
+ flac? ( media-libs/flac )
+ opengl? ( virtual/opengl )
+ truetype? ( media-libs/freetype:2 )
+ fluidsynth? ( media-sound/fluidsynth )"
+DEPEND="${RDEPEND}
+ app-arch/xz-utils
+ x86? ( dev-lang/nasm )"
+
+S=${WORKDIR}/${P/_/}
+
+src_prepare() {
+ default
+
+ # -g isn't needed for nasm here
+ sed -i \
+ -e '/NASMFLAGS/ s/-g//' \
+ configure || die
+ sed -i \
+ -e '/INSTALL.*doc/d' \
+ -e '/INSTALL.*\/pixmaps/d' \
+ -e 's/-s //' \
+ ports.mk || die
+}
+
+src_configure() {
+ use x86 && append-ldflags -Wl,-z,noexecstack
+
+ # NOT AN AUTOCONF SCRIPT SO DONT CALL ECONF
+ SDL_CONFIG="sdl2-config" \
+ ./configure \
+ --backend=sdl \
+ --host=${CHOST} \
+ --enable-verbose-build \
+ --prefix=/usr \
+ --libdir="/usr/$(get_libdir)" \
+ --opengl-mode=$(usex opengl auto none) \
+ $(use_enable aac faad) \
+ $(use_enable alsa) \
+ $(use_enable debug) \
+ $(use_enable !debug release-mode) \
+ $(use_enable flac) \
+ $(usex fluidsynth '' --disable-fluidsynth) \
+ $(use_enable jpeg) \
+ $(use_enable mp3 mad) \
+ $(use_enable mpeg2) \
+ $(use_enable png) \
+ $(use_enable theora theoradec) \
+ $(use_enable truetype freetype2) \
+ $(usex unsupported --enable-all-engines '') \
+ $(use_enable vorbis) \
+ $(use_enable zlib) \
+ $(use_enable x86 nasm) \
+ ${myconf} ${EXTRA_ECONF} || die
+}
+
+src_compile() {
+ emake AR="$(tc-getAR) cru" RANLIB=$(tc-getRANLIB)
+}
+
+src_install() {
+ default
+ doicon -s scalable icons/scummvm.svg
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+ xdg_desktop_database_update
+}