summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-fps/doom3-ducttape')
-rw-r--r--games-fps/doom3-ducttape/Manifest1
-rw-r--r--games-fps/doom3-ducttape/doom3-ducttape-0006-r1.ebuild36
-rw-r--r--games-fps/doom3-ducttape/metadata.xml5
3 files changed, 42 insertions, 0 deletions
diff --git a/games-fps/doom3-ducttape/Manifest b/games-fps/doom3-ducttape/Manifest
new file mode 100644
index 000000000000..d0d642fc56e5
--- /dev/null
+++ b/games-fps/doom3-ducttape/Manifest
@@ -0,0 +1 @@
+DIST ducttape0006.zip 65641 SHA256 2bd694dddc49466defbf8ac2cf32b1778145900cec1e7c255d91c050ae6b7423
diff --git a/games-fps/doom3-ducttape/doom3-ducttape-0006-r1.ebuild b/games-fps/doom3-ducttape/doom3-ducttape-0006-r1.ebuild
new file mode 100644
index 000000000000..89f745d41aba
--- /dev/null
+++ b/games-fps/doom3-ducttape/doom3-ducttape-0006-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=2
+
+MOD_DESC="sticks flashlights to your machinegun and shotgun"
+MOD_NAME="Duct Tape"
+MOD_DIR="ducttape"
+
+inherit games games-mods
+
+HOMEPAGE="http://ducttape.glenmurphy.com/"
+SRC_URI="http://ducttape.glenmurphy.com/ducttape${PV}.zip"
+
+LICENSE="freedist"
+KEYWORDS="amd64 x86"
+IUSE="dedicated opengl"
+
+src_unpack() {
+ mkdir ${MOD_DIR}
+ cd ${MOD_DIR}
+ unpack ${A}
+}
+
+src_prepare() {
+ rm -f ${MOD_DIR}/pak002.pk4 # for doom3-roe
+}
+
+pkg_postinst() {
+ games-mods_pkg_postinst
+
+ elog "To use old saved games with this mod, run:"
+ elog " mkdir -p ~/.doom3/ducttape"
+ elog " cp -r ~/.doom3/base/savegames ~/.doom3/ducttape"
+}
diff --git a/games-fps/doom3-ducttape/metadata.xml b/games-fps/doom3-ducttape/metadata.xml
new file mode 100644
index 000000000000..d3c2cc926f0b
--- /dev/null
+++ b/games-fps/doom3-ducttape/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+</pkgmetadata>