summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-fps/legends')
-rw-r--r--games-fps/legends/Manifest2
-rw-r--r--games-fps/legends/files/legends3
-rw-r--r--games-fps/legends/files/legends-ded3
-rw-r--r--games-fps/legends/legends-0.4.1.43-r1.ebuild74
-rw-r--r--games-fps/legends/metadata.xml28
5 files changed, 110 insertions, 0 deletions
diff --git a/games-fps/legends/Manifest b/games-fps/legends/Manifest
new file mode 100644
index 000000000000..02b9fcf620ed
--- /dev/null
+++ b/games-fps/legends/Manifest
@@ -0,0 +1,2 @@
+DIST legends.png 5092 SHA256 f4ac0db949c2f0a373f331a7a7528ef17c674a226c2366a5a443b5b5a44b6ce2 SHA512 7b9f336335dc69e2fbc24286b2076a228739ab4abf1b77d977321d9dccfb453897bdbd51388e3ed54369ba39b7faa92e458700928d8bf5ccc0f3639f8737489a WHIRLPOOL 19fc961afd861b7921847dfa9e7f7159227e37ff8a50c2edae9770d1fe5967652714ab94d549551349d91326ba3da94c766c715b3182926f33a6a25029fbe1b7
+DIST legends_linux-0.4.1.43.run 123964866 SHA256 cd4852b52f6d17afb22e1ee3592af450da712d060d8315faad23cfc7cf570ea4 SHA512 17b1caa3aa6124f2389e2220ced82c41c4523897bde2f8211d219dc9ef8620583c4ae68999b0761155e3d45cb1ad9679cd65ba50c8440dd1848ef3b1a7a590d2 WHIRLPOOL 2d51695cd5fac8422b5a14d7e836f7b3abbf9358e2e7349da1a3750d4a63c961f5b6d54f38331b9e4710f95baf8e9e4f52aef122398e25f979527e52ffef1fff
diff --git a/games-fps/legends/files/legends b/games-fps/legends/files/legends
new file mode 100644
index 000000000000..da3f5f0d17b4
--- /dev/null
+++ b/games-fps/legends/files/legends
@@ -0,0 +1,3 @@
+#!/bin/sh
+cd GENTOO_DIR
+LD_PRELOAD=GENTOO_DIR/LIBSDL exec ./LinLegends "$@"
diff --git a/games-fps/legends/files/legends-ded b/games-fps/legends/files/legends-ded
new file mode 100644
index 000000000000..0eef35f2cc67
--- /dev/null
+++ b/games-fps/legends/files/legends-ded
@@ -0,0 +1,3 @@
+#!/bin/sh
+cd GENTOO_DIR
+exec ./lindedicated "$@"
diff --git a/games-fps/legends/legends-0.4.1.43-r1.ebuild b/games-fps/legends/legends-0.4.1.43-r1.ebuild
new file mode 100644
index 000000000000..d12b9c8604dd
--- /dev/null
+++ b/games-fps/legends/legends-0.4.1.43-r1.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils unpacker games
+
+MY_P=${PN}_linux-${PV}
+dir=${GAMES_PREFIX_OPT}/${PN}
+
+DESCRIPTION="Fast-paced first-person-shooter online multiplayer game, similar to Tribes"
+HOMEPAGE="http://legendsthegame.net/"
+SRC_URI="http://legendsthegame.net/files/${MY_P}.run
+ mirror://gentoo/${PN}.png"
+
+LICENSE="Legends LGPL-2.1+"
+SLOT="0"
+KEYWORDS="-* amd64 x86"
+IUSE="+dedicated"
+RESTRICT="strip"
+
+QA_TEXTRELS="${dir:1}/libSDL-1.3.so.0"
+QA_FLAGS_IGNORED="${dir:1}/libSDL-1.3.so.0 ${dir:1}/LinLegends ${dir:1}/lindedicated"
+
+DEPEND=""
+RDEPEND="sys-libs/glibc
+ amd64? ( sys-libs/glibc[multilib] )
+ media-fonts/font-adobe-75dpi
+ media-libs/libsdl[video,sound,opengl,abi_x86_32(-)]
+ x11-libs/libX11[abi_x86_32(-)]
+ x11-libs/libXext[abi_x86_32(-)]
+ media-libs/libogg[abi_x86_32(-)]
+ media-libs/libvorbis[abi_x86_32(-)]
+ media-libs/openal[abi_x86_32(-)]"
+
+S=${WORKDIR}
+
+src_unpack() {
+ unpack_makeself ${MY_P}.run
+ cd "${S}"
+
+ # keep libSDL-1.3.so because legends requires it as of 0.4.0, and
+ # 1.2.6 is highest in portage
+ # rm libSDL-*.so*
+ rm runlegends libSDL-1.2.so.0 libopenal.so libogg.so.0 libvorbis.so.0 *.DLL
+}
+
+src_install() {
+ insinto "${dir}"
+ doins -r * || die "doins * failed"
+
+ rm "${D}/${dir}/"/{lindedicated,LinLegends,*.so.0}
+ exeinto "${dir}"
+ doexe lindedicated LinLegends *.so.0 || die "doexe failed"
+
+ games_make_wrapper ${PN} "./LinLegends" "${dir}" "${dir}"
+ if use dedicated ; then
+ games_make_wrapper ${PN}-ded "./lindedicated" "${dir}" "${dir}"
+ fi
+
+ doicon "${DISTDIR}"/${PN}.png || die "doicon failed"
+ make_desktop_entry legends "Legends"
+
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+
+ ewarn "Version ${PV} of ${PN} may give problems if there are"
+ ewarn "config-files from earlier versions. Removing the ~/.legends dir"
+ ewarn "and restarting will solve this."
+ echo
+}
diff --git a/games-fps/legends/metadata.xml b/games-fps/legends/metadata.xml
new file mode 100644
index 000000000000..14fe61de7623
--- /dev/null
+++ b/games-fps/legends/metadata.xml
@@ -0,0 +1,28 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+<longdescription>
+Legends is a fast-paced first-person-perspective online multiplayer
+game. The game is designed to take advantage of the beautiful
+environments available from the Torque engine it is based on while still
+offering the breakneck pacing and variety of styles available from such
+classics as Quake and Tribes.
+
+Gameplay is not the strafe-strafe-jump-strafe-shoot-strafe-run-like-hell
+style a lot of games espouse; the addition of a jetpack adds a third
+dimension of mobility that makes skill, forethought, and restraint
+necessities to winning.
+
+Team sizes are going to be ideal between 10 and 15 on each side, and the
+network code will allow anyone with any bandwidth to play relatively
+smoothly. Game type offerings will range from the classic Capture the
+Flag to our own new type, affectionately called "Knockout".
+
+Plenty of maps will be provided by us, but the beauty of this game is
+its customization possibilities. Mission creation has never been easier,
+with a stable, full-featured editor integrated into the game engine
+itself. Skins, models, and effects can all be modified by the end-user
+with commonly available tools.
+</longdescription>
+</pkgmetadata>