summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-fps/rott')
-rw-r--r--games-fps/rott/Manifest3
-rw-r--r--games-fps/rott/files/1.0-custom-datapath.patch49
-rw-r--r--games-fps/rott/files/rott-1.0-full-version.patch11
-rw-r--r--games-fps/rott/files/rott-1.0-gcc41.patch22
-rw-r--r--games-fps/rott/metadata.xml22
-rw-r--r--games-fps/rott/rott-1.0.ebuild56
-rw-r--r--games-fps/rott/rott-1.1.2.ebuild56
7 files changed, 219 insertions, 0 deletions
diff --git a/games-fps/rott/Manifest b/games-fps/rott/Manifest
new file mode 100644
index 000000000000..6bf03efbaeed
--- /dev/null
+++ b/games-fps/rott/Manifest
@@ -0,0 +1,3 @@
+DIST rott-1.0.tar.gz 777281 SHA256 11f9cc331d0be87f0f172840e2bb6e03e27c3b8e9ecbb3eb8cffdc5b73afbd95 SHA512 f13183ed2b926e9352f9a1fe43ca87d949f642d77286e20c23c832de8c1c688c30ccab14aa09cb7589423b9c41ab16f41ae4b1d2526ae1bc75defc1395a0b899 WHIRLPOOL 67af2827f884a4057f223cd1f861be5929cdab9d4ab5b3b8f28c835ca0634696328b4b5c464da915efacdc805ad72dd05466be87037318f3a2cff111da948cda
+DIST rott-1.1.2.tar.gz 749079 SHA256 102516e8c312f6b0bbf6c623e1f01cbfbbc314ace8adfe1f201d47b15bd927ff SHA512 809a9064fe31c63afccb9a6397ac2c9d4172cdd802b055697cf3b0090ee6a78c9e40b52a4a8df25196489d9a0259304c91e2f84f95413a293bc66192502cf200 WHIRLPOOL dc7808f0da85cfd1e240cbae20ddbbc1f564b5f294e42176a9c38795d3d34d2168476c5d415cce819afe67c3fa1da15812106969d463fc505bfc503c27b76580
+DIST swdata.zip 2889672 SHA256 e226d4958ce1294886b32faf782d9db3d3e66f875d9addd62982e2c8d104fd6b SHA512 99373097356afa583021367b2e0ec6ec745941890e4f17f4e07206c66dd370dfa9e928bc0bd6ab9809d8c72646dcc609e3c19f688d2b89a886f215a153b6dd0d WHIRLPOOL 571d2a5c5f9c45def28f8950d6eaadf5110dbfb0b027951a6a56c1acefe799a7356bc2b436dbe7c9f47d868bdf6b03196fbc69591a66d11c2fb36ab1695125cd
diff --git a/games-fps/rott/files/1.0-custom-datapath.patch b/games-fps/rott/files/1.0-custom-datapath.patch
new file mode 100644
index 000000000000..102801d852e0
--- /dev/null
+++ b/games-fps/rott/files/1.0-custom-datapath.patch
@@ -0,0 +1,49 @@
+--- rt_main.c.orig 2003-06-19 23:03:34.000000000 -0400
++++ rt_main.c 2003-06-19 23:04:49.000000000 -0400
+@@ -763,9 +763,9 @@
+ // Normal ROTT wads
+
+ #if (SHAREWARE)
+- newargs [argnum++] = "huntbgin.wad";
++ newargs [argnum++] = DATADIR "huntbgin.wad";
+ #else
+- newargs [argnum++] = "darkwar.wad";
++ newargs [argnum++] = DATADIR "darkwar.wad";
+ #endif
+
+ // newargs [argnum++] = "credits.wad";
+@@ -785,7 +785,7 @@
+ }
+ else
+ {
+- newargs [argnum++] = "remote1.rts";
++ newargs [argnum++] = DATADIR "remote1.rts";
+ }
+
+ newargs [argnum++] = NULL;
+--- _rt_ted.h.orig 2003-06-19 23:15:26.000000000 -0400
++++ _rt_ted.h 2003-06-19 23:15:54.000000000 -0400
+@@ -84,17 +84,17 @@
+ #define MAXSILLYSTRINGS 32
+
+ #if (SHAREWARE==0)
+- #define STANDARDGAMELEVELS ("DARKWAR.RTL")
++ #define STANDARDGAMELEVELS (DATADIR "DARKWAR.RTL")
+ #if (SUPERROTT==1)
+- #define STANDARDBATTLELEVELS ("ROTTCD.RTC")
++ #define STANDARDBATTLELEVELS (DATADIR "ROTTCD.RTC")
+ #elif (SITELICENSE==1)
+- #define STANDARDBATTLELEVELS ("ROTTSITE.RTC")
++ #define STANDARDBATTLELEVELS (DATADIR "ROTTSITE.RTC")
+ #else
+- #define STANDARDBATTLELEVELS ("DARKWAR.RTC")
++ #define STANDARDBATTLELEVELS (DATADIR "DARKWAR.RTC")
+ #endif
+ #else
+- #define STANDARDGAMELEVELS ("HUNTBGIN.RTL")
+- #define STANDARDBATTLELEVELS ("HUNTBGIN.RTC")
++ #define STANDARDGAMELEVELS (DATADIR "HUNTBGIN.RTL")
++ #define STANDARDBATTLELEVELS (DATADIR "HUNTBGIN.RTC")
+ #endif
+
+
diff --git a/games-fps/rott/files/rott-1.0-full-version.patch b/games-fps/rott/files/rott-1.0-full-version.patch
new file mode 100644
index 000000000000..e1615e77f7fa
--- /dev/null
+++ b/games-fps/rott/files/rott-1.0-full-version.patch
@@ -0,0 +1,11 @@
+--- develop.h.orig 2007-05-13 22:42:39.000000000 +0200
++++ develop.h 2007-05-13 22:42:44.000000000 +0200
+@@ -40,7 +40,7 @@
+ #define LOWCOST 0
+
+ // Make sure only one of the following are on at one time
+-#define SHAREWARE 1
++#define SHAREWARE 0
+ #define SUPERROTT 0
+ #define SITELICENSE 0
+
diff --git a/games-fps/rott/files/rott-1.0-gcc41.patch b/games-fps/rott/files/rott-1.0-gcc41.patch
new file mode 100644
index 000000000000..c2f67b5e9e3c
--- /dev/null
+++ b/games-fps/rott/files/rott-1.0-gcc41.patch
@@ -0,0 +1,22 @@
+--- rt_actor.h.old 2006-05-07 00:54:12.000000000 +0200
++++ rt_actor.h 2006-05-07 00:54:23.000000000 +0200
+@@ -315,7 +315,6 @@
+ extern void *actorat[MAPSIZE][MAPSIZE];
+ extern int angletodir[ANGLES];
+ extern _2Dpoint SNAKEPATH[512];
+-extern int STOPSPEED;
+ extern int FRICTION;
+
+ extern int objcount;
+--- rt_in.h.old 2006-05-07 00:59:45.000000000 +0200
++++ rt_in.h 2006-05-07 01:00:07.000000000 +0200
+@@ -147,9 +147,6 @@
+
+ extern boolean Paused;
+ extern volatile int LastScan;
+-extern KeyboardDef KbdDefs;
+-extern JoystickDef JoyDefs[];
+-extern ControlType Controls[MAXPLAYERS];
+
+ extern boolean SpaceBallPresent;
+ extern boolean CybermanPresent;
diff --git a/games-fps/rott/metadata.xml b/games-fps/rott/metadata.xml
new file mode 100644
index 000000000000..06796f166e2f
--- /dev/null
+++ b/games-fps/rott/metadata.xml
@@ -0,0 +1,22 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>games</herd>
+ <longdescription>
+THE STORY
+
+You are part of an elite group of operatives called HUNT (High-risk
+United Nations Taskforce), and you must stop a maniac cult leader from
+killing millions of people. While scouting a remote island, you are
+suddenly surrounded by enemy troops with guns blaring. In the distance
+you see your boat--your only chance to escape--explode into matchsticks.
+In front of you is a huge fortress monastery, and your only chance to
+stop the madness. You are e quipped with awesome, high-tech weaponry
+like heat-seeking missiles, split missiles, and the Flamewall cannon,
+which leaves a trail of charred skeletons in its wake. You'll also find
+magical instruments and weapons so incredible they defy description.
+</longdescription>
+ <use>
+ <flag name="demo">Install the shareware version</flag>
+ </use>
+</pkgmetadata>
diff --git a/games-fps/rott/rott-1.0.ebuild b/games-fps/rott/rott-1.0.ebuild
new file mode 100644
index 000000000000..fdfaf9721e56
--- /dev/null
+++ b/games-fps/rott/rott-1.0.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils games
+
+DESCRIPTION="Rise of the Triad for Linux!"
+HOMEPAGE="http://www.icculus.org/rott/"
+SRC_URI="http://www.icculus.org/rott/releases/${P}.tar.gz
+ demo? ( http://filesingularity.timedoctor.org/swdata.zip )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~ppc x86"
+IUSE="demo"
+
+RDEPEND="media-libs/libsdl
+ media-libs/sdl-mixer"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+S=${WORKDIR}/${P}/rott
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch \
+ "${FILESDIR}"/${PV}-custom-datapath.patch \
+ "${FILESDIR}"/${P}-gcc41.patch
+ use demo || epatch "${FILESDIR}"/${P}-full-version.patch
+}
+
+src_compile() {
+ emake clean || die
+ emake -j1 EXTRACFLAGS="${CFLAGS} -DDATADIR=\\\"${GAMES_DATADIR}/${PN}/\\\"" \
+ || die "emake failed"
+}
+
+src_install() {
+ dogamesbin rott || die "dogamesbin failed"
+ dodoc *.txt ../{README,readme.txt}
+ if use demo ; then
+ cd "${WORKDIR}"
+ insinto "${GAMES_DATADIR}"/${PN}
+ doins *.dmo huntbgin.* remote1.rts || die "doins failed"
+ fi
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ if ! use demo ; then
+ elog "To play the full version, just copy the"
+ elog "data files to ${GAMES_DATADIR}/${PN}/"
+ fi
+}
diff --git a/games-fps/rott/rott-1.1.2.ebuild b/games-fps/rott/rott-1.1.2.ebuild
new file mode 100644
index 000000000000..dbf50112c886
--- /dev/null
+++ b/games-fps/rott/rott-1.1.2.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils games
+
+DESCRIPTION="Rise of the Triad for Linux!"
+HOMEPAGE="http://www.icculus.org/rott/"
+SRC_URI="http://www.icculus.org/rott/releases/${P}.tar.gz
+ demo? ( http://filesingularity.timedoctor.org/swdata.zip )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="demo"
+
+RDEPEND="media-libs/libsdl[sound,joystick,video]
+ media-libs/sdl-mixer"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+S=${WORKDIR}/${P}/rott
+
+src_prepare() {
+ sed -i \
+ -e '/^CC =/d' \
+ Makefile || die "sed failed"
+ emake clean
+}
+
+src_compile() {
+ emake -j1 \
+ EXTRACFLAGS="${CFLAGS} -DDATADIR=\\\"${GAMES_DATADIR}/${PN}/\\\"" \
+ SHAREWARE=$(usex demo "1" "0")
+}
+
+src_install() {
+ dogamesbin rott
+ dodoc ../doc/*.txt ../README
+ doman ../doc/rott.6
+ if use demo ; then
+ cd "${WORKDIR}" || die
+ insinto "${GAMES_DATADIR}"/${PN}
+ doins *.dmo huntbgin.* remote1.rts
+ fi
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ if ! use demo ; then
+ elog "To play the full version, just copy the"
+ elog "data files to ${GAMES_DATADIR}/${PN}/"
+ fi
+}