summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-fps/unreal-tournament-bonuspacks')
-rw-r--r--games-fps/unreal-tournament-bonuspacks/Manifest1
-rw-r--r--games-fps/unreal-tournament-bonuspacks/metadata.xml5
-rw-r--r--games-fps/unreal-tournament-bonuspacks/unreal-tournament-bonuspacks-436.ebuild49
3 files changed, 55 insertions, 0 deletions
diff --git a/games-fps/unreal-tournament-bonuspacks/Manifest b/games-fps/unreal-tournament-bonuspacks/Manifest
new file mode 100644
index 000000000000..301966602258
--- /dev/null
+++ b/games-fps/unreal-tournament-bonuspacks/Manifest
@@ -0,0 +1 @@
+DIST UTBonusPack4.zip 14916708 SHA256 57a107d69322b8978df2fa1a942397a16bd878d82f4cda25da22a9af7b65d2a4 SHA512 4abc29b108926aebce872a0c8257f97604265cdc837b2e46443ee8cf98adfcba69b6b7ab2bd2379723c11301ef2bf60298ab075a6befe5eeed6d8526f3f653b0 WHIRLPOOL 3eb562f3fc04a63fd1b7b7649af9324bf643d5c48d412387ad6b63c205a3b9a9b8d34dd4c3e6fd3e551f96a8410b8d671e58879a5b2a5d6597a8b41b1f8539dc
diff --git a/games-fps/unreal-tournament-bonuspacks/metadata.xml b/games-fps/unreal-tournament-bonuspacks/metadata.xml
new file mode 100644
index 000000000000..d3c2cc926f0b
--- /dev/null
+++ b/games-fps/unreal-tournament-bonuspacks/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+</pkgmetadata>
diff --git a/games-fps/unreal-tournament-bonuspacks/unreal-tournament-bonuspacks-436.ebuild b/games-fps/unreal-tournament-bonuspacks/unreal-tournament-bonuspacks-436.ebuild
new file mode 100644
index 000000000000..d9989a8af10d
--- /dev/null
+++ b/games-fps/unreal-tournament-bonuspacks/unreal-tournament-bonuspacks-436.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit games
+
+DESCRIPTION="Futuristic FPS (bonus packs)"
+HOMEPAGE="http://www.unrealtournament.com/"
+# UT has 4 official bonus packs ...
+# [UTBonusPack] -> loki put into games-fps/unreal-tournament
+# [UTBonusPack2] -> loki put into games-fps/unreal-tournament
+# [UTiNoxxPack] -> loki put into games-fps/unreal-tournament
+# [UTBonusPack4] -> none of this is in games-fps/unreal-tournament
+SRC_URI="http://fileserver.talkware.net/ut/bonuspacks/UTBonusPack4.zip
+ http://www.dices.de/dices/files/UTBonusPack4.zip"
+
+LICENSE="all-rights-reserved"
+SLOT="0"
+KEYWORDS="-* amd64 x86"
+IUSE=""
+RESTRICT="mirror bindist"
+
+DEPEND="app-arch/unzip
+ || (
+ games-fps/unreal-tournament
+ games-fps/unreal-tournament-goty )
+ games-util/umodpack"
+RDEPEND="|| (
+ games-fps/unreal-tournament
+ games-fps/unreal-tournament-goty )"
+
+S=${WORKDIR}
+
+src_install() {
+ # unpack the UTBonusPack4 umod
+ umod -v -b "$(pwd)" -x UTBonusPack4.umod || die "could not unpack UTBonusPack4.umod"
+
+ # move stuff around
+ rm UTBonusPack4.umod
+ mv system System
+ mv textures Textures
+
+ # install it all
+ local dir=${GAMES_PREFIX_OPT}/unreal-tournament
+ dodir "${dir}"
+ mv * "${D}/${dir}/"
+
+ prepgamesdirs
+}