summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-puzzle/swell-foop')
-rw-r--r--games-puzzle/swell-foop/Manifest1
-rw-r--r--games-puzzle/swell-foop/swell-foop-40.0.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/games-puzzle/swell-foop/Manifest b/games-puzzle/swell-foop/Manifest
index ad5038773428..38ba62678b38 100644
--- a/games-puzzle/swell-foop/Manifest
+++ b/games-puzzle/swell-foop/Manifest
@@ -1 +1,2 @@
DIST swell-foop-3.34.1.tar.xz 732008 BLAKE2B e41527ce485fc7d41b3b8667fba1100fc79a1683adbe7948ecb0f73b418f5e8bcd8c5eeb15c1083cfcbb0237294016ea49510ae6103e2cfc6bc93b508a61a02f SHA512 53625882a755959349f259f5527a48f926e6b8e0493eb81ac257fed6869b87d48e789e4a2141bee7aa8910fb061ca9d7541ceef7f3bdb7a5138068cc6dd16b81
+DIST swell-foop-40.0.tar.xz 821796 BLAKE2B c831a3ed4fc2f53a85793f19dee2e481970784dca4b092db7f905123073b185608fbd8c0a4d8b0c2a74fc4f48e982c4d39b88132381b2a4155609398868825fd SHA512 018a51fdc0e54d9f011a90757fad9d568df33b33241cff9281a49306b8cc236e173e251e8b7ae769a8096f0c9893d496108e4183382ac2f116128fce99774a00
diff --git a/games-puzzle/swell-foop/swell-foop-40.0.ebuild b/games-puzzle/swell-foop/swell-foop-40.0.ebuild
new file mode 100644
index 000000000000..763530ce1aca
--- /dev/null
+++ b/games-puzzle/swell-foop/swell-foop-40.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit gnome.org gnome2-utils meson vala xdg
+
+DESCRIPTION="Clear the screen by removing groups of colored and shaped tiles"
+HOMEPAGE="https://wiki.gnome.org/Apps/Swell%20Foop"
+
+LICENSE="GPL-2+ FDL-1.1+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-libs/glib-2.36:2
+ >=x11-libs/gtk+-3.24:3
+ >=media-libs/clutter-1.14.0:1.0
+ >=media-libs/clutter-gtk-1.5.0:1.0
+ >=dev-libs/libgnome-games-support-1.7.1:1=
+ >=dev-libs/libgee-0.14.0:0.8=
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-libs/appstream-glib
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+ $(vala_depend)
+"
+
+src_prepare() {
+ xdg_src_prepare
+ vala_src_prepare
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}