summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-simulation/flightgear')
-rw-r--r--games-simulation/flightgear/Manifest2
-rw-r--r--games-simulation/flightgear/files/flightgear-2020.3.8-cmake.patch (renamed from games-simulation/flightgear/files/flightgear-2020.3.5-cmake.patch)20
-rw-r--r--games-simulation/flightgear/flightgear-2020.3.8.ebuild (renamed from games-simulation/flightgear/flightgear-2020.3.6.ebuild)2
3 files changed, 12 insertions, 12 deletions
diff --git a/games-simulation/flightgear/Manifest b/games-simulation/flightgear/Manifest
index 78a719620d54..223daa3527e8 100644
--- a/games-simulation/flightgear/Manifest
+++ b/games-simulation/flightgear/Manifest
@@ -1 +1 @@
-DIST flightgear-2020.3.6.tar.bz2 8837251 BLAKE2B 28b8032bd2b6da91f72ae19d4c0c3a6d38122ec2ce7e2e8d1bc3022003551c6c5887711d67868fd9546d79eb6def6c0f0571e62361e73deb6f0edc9c3159c8fa SHA512 b0bfa6e02cf5c2e64aea85fb7433e583141471e15a7dff69dbc12c227835c6e52dcf5b2947a30847c2b291442878eee6265217311e441abb32c5f95bbf7df990
+DIST flightgear-2020.3.8.tar.bz2 8922064 BLAKE2B b345e8a5e733d48c1e061feb11ed96f130ab2d4832c478e9251092862668007eb7e39b29720c7274b91d63eff34cb21597fa6384b6837a5949feeceb6db62331 SHA512 b2c5afeae65558bf086ce20b22a2802580b3ac177f049a8df3b70437adbc6fee067673372c19c14a1c10ffac81a4a77fb13c68d342094a84605190fd3f5442e9
diff --git a/games-simulation/flightgear/files/flightgear-2020.3.5-cmake.patch b/games-simulation/flightgear/files/flightgear-2020.3.8-cmake.patch
index 0af961beacdf..d89a0df947d8 100644
--- a/games-simulation/flightgear/files/flightgear-2020.3.5-cmake.patch
+++ b/games-simulation/flightgear/files/flightgear-2020.3.8-cmake.patch
@@ -1,18 +1,18 @@
-diff -ruN flightgear-2020.3.5/CMakeLists.txt fgfs-my/CMakeLists.txt
---- flightgear-2020.3.5/CMakeLists.txt 2020-12-18 12:43:09.000000000 +0100
-+++ fgfs-my/CMakeLists.txt 2021-01-24 01:36:57.547695230 +0100
+diff -ruN flightgear-2020.3.8/CMakeLists.txt fgfs-my/CMakeLists.txt
+--- flightgear-2020.3.8/CMakeLists.txt 2021-03-24 15:35:40.000000000 +0100
++++ fgfs-my/CMakeLists.txt 2021-05-15 00:47:36.801503634 +0200
@@ -373,7 +373,7 @@
## Qt5 setup setup
if (ENABLE_QT)
message(STATUS "Qt launcher enabled, checking for Qt >= 5.4 / qmake")
- find_package(Qt5 5.4 COMPONENTS Widgets Gui Network Qml Quick Svg)
+ find_package(Qt5 5.4 COMPONENTS Widgets Gui Network Qml Quick)
- if (Qt5Widgets_FOUND)
+ if (Qt5Widgets_FOUND AND Qt5Quick_FOUND)
message(STATUS "Will enable Qt launcher GUI")
set(HAVE_QT 1)
-diff -ruN flightgear-2020.3.5/CMakeModules/SetupFGFSLibraries.cmake fgfs-my/CMakeModules/SetupFGFSLibraries.cmake
---- flightgear-2020.3.5/CMakeModules/SetupFGFSLibraries.cmake 2020-12-18 12:43:09.000000000 +0100
-+++ fgfs-my/CMakeModules/SetupFGFSLibraries.cmake 2021-01-24 01:35:31.298263659 +0100
+diff -ruN flightgear-2020.3.8/CMakeModules/SetupFGFSLibraries.cmake fgfs-my/CMakeModules/SetupFGFSLibraries.cmake
+--- flightgear-2020.3.8/CMakeModules/SetupFGFSLibraries.cmake 2021-03-24 15:35:40.000000000 +0100
++++ fgfs-my/CMakeModules/SetupFGFSLibraries.cmake 2021-05-15 00:47:36.801503634 +0200
@@ -33,15 +33,8 @@
# PkgConfig::DBUS target
@@ -31,9 +31,9 @@ diff -ruN flightgear-2020.3.5/CMakeModules/SetupFGFSLibraries.cmake fgfs-my/CMak
endif()
if(FG_HAVE_GPERFTOOLS)
-diff -ruN flightgear-2020.3.5/src/GUI/CMakeLists.txt fgfs-my/src/GUI/CMakeLists.txt
---- flightgear-2020.3.5/src/GUI/CMakeLists.txt 2020-12-18 12:43:09.000000000 +0100
-+++ fgfs-my/src/GUI/CMakeLists.txt 2021-01-24 01:40:02.008618256 +0100
+diff -ruN flightgear-2020.3.8/src/GUI/CMakeLists.txt fgfs-my/src/GUI/CMakeLists.txt
+--- flightgear-2020.3.8/src/GUI/CMakeLists.txt 2021-03-24 15:35:40.000000000 +0100
++++ fgfs-my/src/GUI/CMakeLists.txt 2021-05-15 00:47:36.801503634 +0200
@@ -142,7 +142,7 @@
set_property(TARGET fglauncher PROPERTY AUTOMOC ON)
diff --git a/games-simulation/flightgear/flightgear-2020.3.6.ebuild b/games-simulation/flightgear/flightgear-2020.3.8.ebuild
index 58c4fd7033ee..d985a68664d6 100644
--- a/games-simulation/flightgear/flightgear-2020.3.6.ebuild
+++ b/games-simulation/flightgear/flightgear-2020.3.8.ebuild
@@ -64,7 +64,7 @@ RDEPEND="${COMMON_DEPEND}
"
PATCHES=(
- "${FILESDIR}/${PN}-2020.3.5-cmake.patch"
+ "${FILESDIR}/${PN}-2020.3.8-cmake.patch"
)
DOCS=(AUTHORS ChangeLog NEWS README Thanks)