summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-sports')
-rw-r--r--games-sports/xmoto/Manifest1
-rw-r--r--games-sports/xmoto/xmoto-0.5.11.ebuild15
2 files changed, 11 insertions, 5 deletions
diff --git a/games-sports/xmoto/Manifest b/games-sports/xmoto/Manifest
index 85160782182a..45683811be3d 100644
--- a/games-sports/xmoto/Manifest
+++ b/games-sports/xmoto/Manifest
@@ -1,2 +1,3 @@
DIST inksmoto-0.7.0.tar.gz 2628941 SHA256 60bd1369d4c347e127886a5813af13daf39b56ce818c9f8b2fc7d4bba0af7e11 SHA512 af0ae49ea160a2274f6835abd82ccaa00dc9ff81875b7d4ea29789388c131b519cb77e6da42efeaf51d52b97090c67320af38145204a1d5418781c99cb23a704 WHIRLPOOL e7137f1f23815cdef1061896b8dd687af38a79be341827dcaa437c39de95a98d94b4173d973899a8422c3e77088da11869957996f21c2822d8cfddf15b6a7ea6
DIST xmoto-0.5.11-src.tar.gz 40785573 SHA256 a584a6f9292b184686b72c78f16de4b82d5c5b72ad89e41912ff50d03eca26b2 SHA512 7046745e8f7a045fa2ce1deb3fd75b73b233dc1092f5ecd6dd4e42938f70269a93a3a623a39a1f0520c90643a42dc1ce93c43ad07bf225ff6c50741cc02511f6 WHIRLPOOL 9301a6456dea420cc92706022b9003446363d90591f6c90977a1e85195419f42d168456db61077d4e757976ee7ccbb183e6337fda4a683334cea796aa65a7c3b
+DIST xmoto_0.5.11+dfsg-6.debian.tar.xz 25240 SHA256 066a62c61c026a5bb698058023db058f6192c062e48c04edcae73abc608eb0d2 SHA512 961f97a3427e77cf020d73820ff99fdc0ca81e5953a18ed9386a1b476eb2af897073adcd7141e993fbf4f8fdca9efdab8cf20b89bfc31196afdcb4f2095ab390 WHIRLPOOL d1c57655ff095d4edb81643c65a4c9530c7287cf79d7a20247b33a4f33b0e3a83afc798ac5248e8f097c9a38cb54a104fb7e125071b27e3e27ba5a9bfccd8aa3
diff --git a/games-sports/xmoto/xmoto-0.5.11.ebuild b/games-sports/xmoto/xmoto-0.5.11.ebuild
index 5ecfe3db495b..82e62ac6e60a 100644
--- a/games-sports/xmoto/xmoto-0.5.11.ebuild
+++ b/games-sports/xmoto/xmoto-0.5.11.ebuild
@@ -1,15 +1,17 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
-inherit eutils flag-o-matic games
+inherit autotools eutils flag-o-matic games
LVL_PV="0.7.0" #they unfortunately don't release both at the same time, why ~ as separator :(
LVL="inksmoto-${LVL_PV}"
+DEB_PV=6
DESCRIPTION="A challenging 2D motocross platform game"
HOMEPAGE="http://xmoto.tuxfamily.org"
SRC_URI="http://download.tuxfamily.org/xmoto/xmoto/${PV}/${P}-src.tar.gz
+ mirror://debian/pool/main/x/${PN}/${PN}_${PV}+dfsg-${DEB_PV}.debian.tar.xz
editor? ( http://download.tuxfamily.org/xmoto/svg2lvl/${LVL_PV}/${LVL}.tar.gz )"
LICENSE="GPL-2"
@@ -36,24 +38,27 @@ RDEPEND="
media-fonts/dejavu
nls? ( virtual/libintl )"
DEPEND="${RDEPEND}
+ app-arch/xz-utils
nls? ( sys-devel/gettext )"
RDEPEND="${RDEPEND}
editor? ( media-gfx/inkscape )"
src_prepare() {
+ EPATCH_SOURCE="${WORKDIR}/debian/patches" \
+ epatch $(cat ${WORKDIR}/debian/patches/series)
use editor && rm -vf "${WORKDIR}"/extensions/{bezmisc,inkex}.py
sed -i \
-e '/^gettextsrcdir/s:=.*:= @localedir@/gettext/po:' \
po/Makefile.in.in || die
-
- epatch "${FILESDIR}"/${P}-utf8.patch
+ mv configure.{in,ac} || die
+ eautoreconf
}
src_configure() {
# bug #289792
filter-flags -DdDOUBLE -DdSINGLE
# bug #569624 - ode-0.13 needs one or the other defined
- append-flags -Dd$(has_version 'dev-games/ode[double-precision]' && echo DOUBLE || echo SINGLE)
+ append-cppflags -Dd$(has_version 'dev-games/ode[double-precision]' && echo DOUBLE || echo SINGLE)
egamesconf \
--enable-threads=posix \