summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-strategy/megaglest/files')
-rw-r--r--games-strategy/megaglest/files/megaglest-3.11.1-cmake.patch28
-rw-r--r--games-strategy/megaglest/files/megaglest-3.11.1-miniupnpc-api-version-16.patch17
-rw-r--r--games-strategy/megaglest/files/megaglest-3.11.1-miniupnpc.patch21
-rw-r--r--games-strategy/megaglest/files/megaglest-3.11.1-static-build.patch63
-rw-r--r--games-strategy/megaglest/files/megaglest-3.13.0-GLEW_ERROR_NO_GLX_DISPLAY.patch12
-rw-r--r--games-strategy/megaglest/files/megaglest-3.13.0-fbd0cfb1.patch75
-rw-r--r--games-strategy/megaglest/files/megaglest-3.13.0-fix-lua-version-ordering.patch12
-rw-r--r--games-strategy/megaglest/files/megaglest-3.13.0-help2man.patch12
-rw-r--r--games-strategy/megaglest/files/megaglest-3.13.0-multiple-definitions.patch46
-rw-r--r--games-strategy/megaglest/files/megaglest-3.13.0-underlink.patch12
10 files changed, 169 insertions, 129 deletions
diff --git a/games-strategy/megaglest/files/megaglest-3.11.1-cmake.patch b/games-strategy/megaglest/files/megaglest-3.11.1-cmake.patch
deleted file mode 100644
index 527671246e98..000000000000
--- a/games-strategy/megaglest/files/megaglest-3.11.1-cmake.patch
+++ /dev/null
@@ -1,28 +0,0 @@
-From e463986ba1f40210b40eff34c4aac727c7f2e571 Mon Sep 17 00:00:00 2001
-From: Michael Palimaka <kensington@gentoo.org>
-Date: Wed, 13 May 2015 04:22:45 +1000
-Subject: [PATCH] Fix build with >=cmake-3.2.
-
-The FindOpenGL module no longer pulls in X11 libraries.
----
- source/shared_lib/CMakeLists.txt | 4 ++++
- 1 file changed, 4 insertions(+)
-
-diff --git a/source/shared_lib/CMakeLists.txt b/source/shared_lib/CMakeLists.txt
-index 3da563e..e5a06fc 100644
---- a/source/shared_lib/CMakeLists.txt
-+++ b/source/shared_lib/CMakeLists.txt
-@@ -95,6 +95,10 @@ IF(BUILD_MEGAGLEST_MODEL_VIEWER OR BUILD_MEGAGLEST_MAP_EDITOR OR BUILD_MEGAGLEST
- SET(EXTERNAL_LIBS ${EXTERNAL_LIBS} ${OPENGL_LIBRARY})
- ENDIF()
-
-+ IF(UNIX)
-+ FIND_PACKAGE(X11 REQUIRED)
-+ SET(EXTERNAL_LIBS ${EXTERNAL_LIBS} ${X11_LIBRARIES})
-+ ENDIF()
-
- IF(WANT_XERCES)
- FIND_PACKAGE(XercesC REQUIRED)
---
-2.3.6
-
diff --git a/games-strategy/megaglest/files/megaglest-3.11.1-miniupnpc-api-version-16.patch b/games-strategy/megaglest/files/megaglest-3.11.1-miniupnpc-api-version-16.patch
deleted file mode 100644
index a793c122b210..000000000000
--- a/games-strategy/megaglest/files/megaglest-3.11.1-miniupnpc-api-version-16.patch
+++ /dev/null
@@ -1,17 +0,0 @@
-https://github.com/MegaGlest/megaglest-source/commit/a85d12aed1983eb69d630b431b81ae656d83b3ac
-
---- /source/shared_lib/sources/platform/posix/socket.cpp
-+++ /source/shared_lib/sources/platform/posix/socket.cpp
-@@ -2610,8 +2610,10 @@
- if(SystemFlags::VERBOSE_MODE_ENABLED) printf("UPnP device found: %s %s\n", dev->descURL, dev->st);
-
- //printf("UPnP device found: [%s] [%s] lanaddr [%s]\n", dev->descURL, dev->st,lanaddr);
--#if (defined(MINIUPNPC_API_VERSION) && MINIUPNPC_API_VERSION >= 9) || (!defined(MINIUPNPC_VERSION_PRE1_7) && !defined(MINIUPNPC_VERSION_PRE1_6))
-- char *descXML = (char *)miniwget_getaddr(dev->descURL, &descXMLsize, lanaddr, (sizeof(lanaddr) / sizeof(lanaddr[0])),0);
-+#if (defined(MINIUPNPC_API_VERSION) && MINIUPNPC_API_VERSION >= 16)
-+ char *descXML = (char *)miniwget_getaddr(dev->descURL, &descXMLsize, lanaddr, (sizeof(lanaddr) / sizeof(lanaddr[0])), 0, NULL);
-+#elif (defined(MINIUPNPC_API_VERSION) && MINIUPNPC_API_VERSION >= 9) || (!defined(MINIUPNPC_VERSION_PRE1_7) && !defined(MINIUPNPC_VERSION_PRE1_6))
-+ char *descXML = (char *)miniwget_getaddr(dev->descURL, &descXMLsize, lanaddr, (sizeof(lanaddr) / sizeof(lanaddr[0])), 0);
- #else
- char *descXML = (char *)miniwget_getaddr(dev->descURL, &descXMLsize, lanaddr, (sizeof(lanaddr) / sizeof(lanaddr[0])));
- #endif
diff --git a/games-strategy/megaglest/files/megaglest-3.11.1-miniupnpc.patch b/games-strategy/megaglest/files/megaglest-3.11.1-miniupnpc.patch
deleted file mode 100644
index 112e734c6efb..000000000000
--- a/games-strategy/megaglest/files/megaglest-3.11.1-miniupnpc.patch
+++ /dev/null
@@ -1,21 +0,0 @@
-diff --git a/source/shared_lib/sources/platform/posix/socket.cpp b/source/shared_lib/sources/platform/posix/socket.cpp
-index a5d4b92..cb8ceb4 100644
---- a/source/shared_lib/sources/platform/posix/socket.cpp
-+++ b/source/shared_lib/sources/platform/posix/socket.cpp
-@@ -2563,9 +2563,15 @@ int UPNP_Tools::upnp_init(void *param) {
- const char *upnp_minissdpdsock = NULL;
- int upnp_sameport = 0;
- int upnp_ipv6 = 0;
-+ unsigned char upnp_ttl = 2;
- int upnp_error = 0;
-
--#ifndef MINIUPNPC_VERSION_PRE1_6
-+#if (MINIUPNPC_API_VERSION >= 14)
-+ devlist = upnpDiscover(upnp_delay, upnp_multicastif, upnp_minissdpdsock, upnp_sameport, upnp_ipv6, upnp_ttl, &upnp_error);
-+
-+ if(SystemFlags::getSystemSettingType(SystemFlags::debugNetwork).enabled) SystemFlags::OutputDebug(SystemFlags::debugNetwork,"UPnP discover returned upnp_error = %d.\n",upnp_error);
-+ if(SystemFlags::VERBOSE_MODE_ENABLED) printf("UPnP discover returned upnp_error = %d.\n",upnp_error);
-+#elif (MINIUPNPC_API_VERSION >= 8)
- devlist = upnpDiscover(upnp_delay, upnp_multicastif, upnp_minissdpdsock, upnp_sameport, upnp_ipv6, &upnp_error);
-
- if(SystemFlags::getSystemSettingType(SystemFlags::debugNetwork).enabled) SystemFlags::OutputDebug(SystemFlags::debugNetwork,"UPnP discover returned upnp_error = %d.\n",upnp_error);
diff --git a/games-strategy/megaglest/files/megaglest-3.11.1-static-build.patch b/games-strategy/megaglest/files/megaglest-3.11.1-static-build.patch
deleted file mode 100644
index 2586a561956b..000000000000
--- a/games-strategy/megaglest/files/megaglest-3.11.1-static-build.patch
+++ /dev/null
@@ -1,63 +0,0 @@
-commit 754a6eb9f81a4a40a2a0102ffe1bfdbba734b36a
-Author: hasufell <hasufell@gentoo.org>
-Date: Mon Nov 18 21:54:54 2013 +0100
-
- fix static build
-
-diff --git a/mk/cmake/Modules/FindOGG.cmake b/mk/cmake/Modules/FindOGG.cmake
-index 2a026cc..8ca8a23 100644
---- a/mk/cmake/Modules/FindOGG.cmake
-+++ b/mk/cmake/Modules/FindOGG.cmake
-@@ -19,11 +19,11 @@
-
- FIND_PATH(OGG_INCLUDE_DIR ogg/ogg.h)
-
--#IF (OGG_STATIC AND NOT OGG_LIBRARY)
--# FIND_LIBRARY(OGG_LIBRARY NAMES libogg.a ogg)
--#ELSE()
-- FIND_LIBRARY(OGG_LIBRARY NAMES ogg)
--#ENDIF()
-+IF (OGG_STATIC AND NOT OGG_LIBRARY)
-+ FIND_LIBRARY(OGG_LIBRARY NAMES libogg.a)
-+ELSE()
-+ FIND_LIBRARY(OGG_LIBRARY NAMES libogg.so)
-+ENDIF()
-
- #IF (OGG_STATIC AND NOT VORBIS_LIBRARY)
- # FIND_LIBRARY(VORBIS_LIBRARY NAMES libvorbis.a vorbis)
---- a/mk/cmake/Modules/FindXercesC.cmake
-+++ b/mk/cmake/Modules/FindXercesC.cmake
-@@ -83,6 +83,9 @@
- /usr/lib
- /usr/local/lib
- )
-+
-+ FIND_LIBRARY(ICUUC_LIBRARY NAMES libicuuc.a)
-+ FIND_LIBRARY(ICUDATA_LIBRARY NAMES libicudata.a)
-
- IF (XERCESC_INCLUDE AND XERCESC_LIBRARY)
- MESSAGE(STATUS "Found static Xerces-C lib [${XERCESC_LIBRARY}]")
-@@ -90,7 +93,7 @@
-
- IF(UNIX AND NOT APPLE)
- #SET(XERCESC_LIBRARY "-Bstatic ${XERCESC_LIBRARY} -Bdynamic -licuuc -licudata")
-- SET(XERCESC_LIBRARY "-Bstatic ${XERCESC_LIBRARY}")
-+ SET(XERCESC_LIBRARY "-Bstatic ${XERCESC_LIBRARY} ${ICUUC_LIBRARY} ${ICUDATA_LIBRARY}")
- ENDIF()
- ENDIF()
- ENDIF()
---- a/mk/cmake/Modules/FindFriBiDi.cmake
-+++ b/mk/cmake/Modules/FindFriBiDi.cmake
-@@ -28,9 +28,9 @@
- SET(FRIBIDI_NAMES ${FRIBIDI_NAMES} fribidi libfribidi)
-
- OPTION(WANT_STATIC_LIBS "builds as many static libs as possible" OFF)
--IF(WANT_STATIC_LIBS)
-- SET(FRIBIDI_NAMES fribidi.a libfribidi.a ${FRIBIDI_NAMES})
--ENDIF()
-+#IF(WANT_STATIC_LIBS)
-+# SET(FRIBIDI_NAMES fribidi.a libfribidi.a ${FRIBIDI_NAMES})
-+#ENDIF()
-
- MESSAGE(STATUS "** Searching for library names: [${FRIBIDI_NAMES}] ...")
-
diff --git a/games-strategy/megaglest/files/megaglest-3.13.0-GLEW_ERROR_NO_GLX_DISPLAY.patch b/games-strategy/megaglest/files/megaglest-3.13.0-GLEW_ERROR_NO_GLX_DISPLAY.patch
new file mode 100644
index 000000000000..7855baa2273f
--- /dev/null
+++ b/games-strategy/megaglest/files/megaglest-3.13.0-GLEW_ERROR_NO_GLX_DISPLAY.patch
@@ -0,0 +1,12 @@
+diff -up megaglest-source-3.13.0/source/shared_lib/sources/platform/sdl/gl_wrap.cpp.ignore-GLEW_ERROR_NO_GLX_DISPLAY megaglest-source-3.13.0/source/shared_lib/sources/platform/sdl/gl_wrap.cpp
+--- megaglest-source-3.13.0/source/shared_lib/sources/platform/sdl/gl_wrap.cpp.ignore-GLEW_ERROR_NO_GLX_DISPLAY 2022-10-17 09:47:51.084267697 -0400
++++ megaglest-source-3.13.0/source/shared_lib/sources/platform/sdl/gl_wrap.cpp 2022-10-17 09:48:35.079555790 -0400
+@@ -301,7 +301,7 @@ void PlatformContextGl::init(int colorBi
+
+ if(SystemFlags::VERBOSE_MODE_ENABLED) printf("In [%s::%s %d] AFTER glewInit call err = %d\n",extractFileFromDirectoryPath(__FILE__).c_str(),__FUNCTION__,__LINE__,err);
+
+- if (GLEW_OK != err) {
++ if (GLEW_OK != err && GLEW_ERROR_NO_GLX_DISPLAY != err) {
+ if(SystemFlags::VERBOSE_MODE_ENABLED) printf("In [%s::%s %d]\n",extractFileFromDirectoryPath(__FILE__).c_str(),__FUNCTION__,__LINE__);
+
+ fprintf(stderr, "Error [main]: glewInit failed: %s\n", glewGetErrorString(err));
diff --git a/games-strategy/megaglest/files/megaglest-3.13.0-fbd0cfb1.patch b/games-strategy/megaglest/files/megaglest-3.13.0-fbd0cfb1.patch
new file mode 100644
index 000000000000..6f2eb91847e2
--- /dev/null
+++ b/games-strategy/megaglest/files/megaglest-3.13.0-fbd0cfb1.patch
@@ -0,0 +1,75 @@
+From fbd0cfb17ed759d24aeb577a602b0d97f7895cc2 Mon Sep 17 00:00:00 2001
+From: titiger <titi_linux@megaglest.org>
+Date: Sat, 29 May 2021 02:41:40 +0200
+Subject: [PATCH] get rid of manual wxPaintEvent creation
+
+---
+ source/glest_map_editor/main.cpp | 19 +++++++------------
+ 1 file changed, 7 insertions(+), 12 deletions(-)
+
+diff --git a/source/glest_map_editor/main.cpp b/source/glest_map_editor/main.cpp
+index 3a799c864..889a1dea8 100644
+--- a/source/glest_map_editor/main.cpp
++++ b/source/glest_map_editor/main.cpp
+@@ -545,8 +545,7 @@ MainWindow::~MainWindow() {
+ }
+
+ void MainWindow::setDirty(bool val) {
+- wxPaintEvent ev;
+- onPaint(ev);
++ refreshThings();
+ if (fileModified && val) {
+ return;
+ }
+@@ -582,8 +581,8 @@ void MainWindow::onMouseDown(wxMouseEvent &event, int x, int y) {
+ if (!isDirty()) {
+ setDirty(true);
+ }
+- wxPaintEvent ev;
+- onPaint(ev);
++
++ refreshThings();
+ }
+ event.Skip();
+ }
+@@ -593,18 +592,16 @@ void MainWindow::onMouseWheelDown(wxMouseEvent &event) {
+ if(program == NULL) {
+ return;
+ }
+- wxPaintEvent ev;
+ program->incCellSize(1);
+- onPaint(ev);
++ refreshThings();
+ }
+
+ void MainWindow::onMouseWheelUp(wxMouseEvent &event) {
+ if(program == NULL) {
+ return;
+ }
+- wxPaintEvent ev;
+ program->incCellSize(-1);
+- onPaint(ev);
++ refreshThings();
+ }
+
+ void MainWindow::onMouseMove(wxMouseEvent &event, int x, int y) {
+@@ -651,8 +648,7 @@ void MainWindow::onMouseMove(wxMouseEvent &event, int x, int y) {
+ lastY = y;
+
+ if (repaint) {
+- wxPaintEvent ev;
+- onPaint(ev);
++ refreshThings();
+ }
+ event.Skip();
+ }
+@@ -866,8 +862,7 @@ void MainWindow::onMenuEditReset(wxCommandEvent &event) {
+ currentFile = "";
+ fileName = "New (unsaved) map";
+
+- wxPaintEvent ev;
+- onPaint(ev);
++ refreshThings();
+ }
+
+ void MainWindow::onMenuEditResetPlayers(wxCommandEvent &event) {
diff --git a/games-strategy/megaglest/files/megaglest-3.13.0-fix-lua-version-ordering.patch b/games-strategy/megaglest/files/megaglest-3.13.0-fix-lua-version-ordering.patch
new file mode 100644
index 000000000000..60ab155946f0
--- /dev/null
+++ b/games-strategy/megaglest/files/megaglest-3.13.0-fix-lua-version-ordering.patch
@@ -0,0 +1,12 @@
+diff -up megaglest-source-3.13.0/mk/cmake/Modules/ReqVersAndStaticConf.cmake.fix-lua-version-ordering megaglest-source-3.13.0/mk/cmake/Modules/ReqVersAndStaticConf.cmake
+--- megaglest-source-3.13.0/mk/cmake/Modules/ReqVersAndStaticConf.cmake.fix-lua-version-ordering 2022-10-17 09:17:11.429220699 -0400
++++ megaglest-source-3.13.0/mk/cmake/Modules/ReqVersAndStaticConf.cmake 2022-10-17 09:17:25.388312109 -0400
+@@ -57,7 +57,7 @@ IF(NOT DEFINED FORCE_LUA_VERSION)
+ SET(FORCE_LUA_VERSION "OFF" CACHE STRING "Try to force some specific lua version (for example older). On the list may be also not existing versions yet for future use." FORCE)
+ ENDIF()
+ SET_PROPERTY(CACHE FORCE_LUA_VERSION PROPERTY STRINGS OFF 5.5 5.4 5.3 5.2 5.1 5.0)
+-SET(ALL_LUA_VERSIONS_IN_ORDER 5.3 5.2 5.1 5.4 5.5 5.0)
++SET(ALL_LUA_VERSIONS_IN_ORDER 5.4 5.3 5.2 5.1 5.5 5.0)
+
+ IF(STATIC_JPEG)
+ SET(JPEG_NAMES jpeg.a libjpeg.a ${JPEG_NAMES})
diff --git a/games-strategy/megaglest/files/megaglest-3.13.0-help2man.patch b/games-strategy/megaglest/files/megaglest-3.13.0-help2man.patch
new file mode 100644
index 000000000000..efb8fcbf01d4
--- /dev/null
+++ b/games-strategy/megaglest/files/megaglest-3.13.0-help2man.patch
@@ -0,0 +1,12 @@
+diff -up megaglest-3.13.0/source/g3d_viewer/CMakeLists.txt.orig megaglest-3.13.0/source/g3d_viewer/CMakeLists.txt
+--- megaglest-3.13.0/source/g3d_viewer/CMakeLists.txt.orig 2019-09-24 15:36:04.938321806 -0300
++++ megaglest-3.13.0/source/g3d_viewer/CMakeLists.txt 2019-09-24 15:36:34.633526679 -0300
+@@ -207,7 +207,7 @@ IF(BUILD_MEGAGLEST_MODEL_VIEWER)
+ MESSAGE(STATUS "***-- Found xvfb-run: ${XVFB_EXEC} about to build manpage with it.")
+
+ add_custom_target(${TARGET_NAME_MANPAGE} ALL
+- COMMAND ${XVFB_EXEC} --auto-servernum --server-num=770 ${HELP2MAN} --no-discard-stderr --name='${MG_MANPAGE_DESCRIPTION}' --section=6 -N -o ${HELP2MAN_OUT_PATH}${TARGET_NAME_MANPAGE} ${HELP2MAN_OUT_PATH}${TARGET_NAME}
++ COMMAND ${XVFB_EXEC} --auto-servernum ${HELP2MAN} --name='${MG_MANPAGE_DESCRIPTION}' --section=6 -N -o ${HELP2MAN_OUT_PATH}${TARGET_NAME_MANPAGE} ${HELP2MAN_OUT_PATH}${TARGET_NAME}
+ DEPENDS ${TARGET_NAME})
+ ELSE()
+ add_custom_target(${TARGET_NAME_MANPAGE} ALL
diff --git a/games-strategy/megaglest/files/megaglest-3.13.0-multiple-definitions.patch b/games-strategy/megaglest/files/megaglest-3.13.0-multiple-definitions.patch
new file mode 100644
index 000000000000..657b70fe228d
--- /dev/null
+++ b/games-strategy/megaglest/files/megaglest-3.13.0-multiple-definitions.patch
@@ -0,0 +1,46 @@
+diff -up megaglest-3.13.0/source/shared_lib/include/feathery_ftp/ftpTypes.h.orig megaglest-3.13.0/source/shared_lib/include/feathery_ftp/ftpTypes.h
+--- megaglest-3.13.0/source/shared_lib/include/feathery_ftp/ftpTypes.h.orig 2020-03-30 13:56:49.360323060 -0300
++++ megaglest-3.13.0/source/shared_lib/include/feathery_ftp/ftpTypes.h 2020-03-30 13:58:21.924743049 -0300
+@@ -69,7 +69,7 @@ typedef uint16_t port_t;
+ extern "C" {
+ #endif
+
+-int VERBOSE_MODE_ENABLED;
++extern int VERBOSE_MODE_ENABLED;
+
+ typedef ip_t (*ftpFindExternalFTPServerIpType)(ip_t clientIp);
+ typedef void (*ftpAddUPNPPortForwardType)(int internalPort, int externalPort);
+@@ -77,11 +77,11 @@ typedef void (*ftpRemoveUPNPPortForwardT
+ typedef int (*ftpIsValidClientType)(ip_t clientIp);
+ typedef int (*ftpIsClientAllowedToGetFileType)(ip_t clientIp, const char *username, const char *filename);
+
+-ftpFindExternalFTPServerIpType ftpFindExternalFTPServerIp;
+-ftpAddUPNPPortForwardType ftpAddUPNPPortForward;
+-ftpRemoveUPNPPortForwardType ftpRemoveUPNPPortForward;
+-ftpIsValidClientType ftpIsValidClient;
+-ftpIsClientAllowedToGetFileType ftpIsClientAllowedToGetFile;
++extern ftpFindExternalFTPServerIpType ftpFindExternalFTPServerIp;
++extern ftpAddUPNPPortForwardType ftpAddUPNPPortForward;
++extern ftpRemoveUPNPPortForwardType ftpRemoveUPNPPortForward;
++extern ftpIsValidClientType ftpIsValidClient;
++extern ftpIsClientAllowedToGetFileType ftpIsClientAllowedToGetFile;
+
+ #ifdef __cplusplus
+ }
+diff -up megaglest-3.13.0/source/shared_lib/sources/feathery_ftp/ftpRuntime.c.orig megaglest-3.13.0/source/shared_lib/sources/feathery_ftp/ftpRuntime.c
+--- megaglest-3.13.0/source/shared_lib/sources/feathery_ftp/ftpRuntime.c.orig 2020-03-30 13:56:56.412355058 -0300
++++ megaglest-3.13.0/source/shared_lib/sources/feathery_ftp/ftpRuntime.c 2020-03-30 13:58:30.524782070 -0300
+@@ -30,6 +30,13 @@
+ #include "ftp.h"
+ #include "ftpMessages.h"
+
++int VERBOSE_MODE_ENABLED;
++
++ftpFindExternalFTPServerIpType ftpFindExternalFTPServerIp;
++ftpAddUPNPPortForwardType ftpAddUPNPPortForward;
++ftpRemoveUPNPPortForwardType ftpRemoveUPNPPortForward;
++ftpIsValidClientType ftpIsValidClient;
++ftpIsClientAllowedToGetFileType ftpIsClientAllowedToGetFile;
+
+ /**
+ * @brief server-sockets that listens for incoming connections
diff --git a/games-strategy/megaglest/files/megaglest-3.13.0-underlink.patch b/games-strategy/megaglest/files/megaglest-3.13.0-underlink.patch
new file mode 100644
index 000000000000..646132fe3c66
--- /dev/null
+++ b/games-strategy/megaglest/files/megaglest-3.13.0-underlink.patch
@@ -0,0 +1,12 @@
+diff -up megaglest-3.13.0/source/shared_lib/CMakeLists.txt.orig megaglest-3.13.0/source/shared_lib/CMakeLists.txt
+--- megaglest-3.13.0/source/shared_lib/CMakeLists.txt.orig 2019-09-24 15:38:49.867482131 -0300
++++ megaglest-3.13.0/source/shared_lib/CMakeLists.txt 2019-09-24 15:39:00.045556832 -0300
+@@ -109,7 +109,7 @@ IF(BUILD_MEGAGLEST_MODEL_VIEWER OR BUILD
+ FIND_PACKAGE(OpenGL REQUIRED)
+ INCLUDE_DIRECTORIES(${OPENGL_INCLUDE_DIR})
+ IF(UNIX)
+- SET(EXTERNAL_LIBS ${EXTERNAL_LIBS} ${OPENGL_LIBRARY})
++ SET(EXTERNAL_LIBS ${EXTERNAL_LIBS} ${OPENGL_LIBRARY} -lX11)
+ ENDIF()
+
+ FIND_PACKAGE(X11 REQUIRED)