summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-strategy/widelands')
-rw-r--r--games-strategy/widelands/files/widelands-0.20-boost-1.73.patch22
-rw-r--r--games-strategy/widelands/widelands-0.20-r1.ebuild5
2 files changed, 25 insertions, 2 deletions
diff --git a/games-strategy/widelands/files/widelands-0.20-boost-1.73.patch b/games-strategy/widelands/files/widelands-0.20-boost-1.73.patch
new file mode 100644
index 000000000000..99a8c51190b2
--- /dev/null
+++ b/games-strategy/widelands/files/widelands-0.20-boost-1.73.patch
@@ -0,0 +1,22 @@
+--- a/src/editor/ui_menus/categorized_item_selection_menu.h
++++ b/src/editor/ui_menus/categorized_item_selection_menu.h
+@@ -124,7 +124,7 @@
+
+ UI::Checkbox* cb = create_checkbox(horizontal, descriptions_.get(i));
+ cb->set_state(tool_->is_enabled(i));
+- cb->changedto.connect(boost::bind(&CategorizedItemSelectionMenu::selected, this, i, _1));
++ cb->changedto.connect(boost::bind(&CategorizedItemSelectionMenu::selected, this, i, boost::placeholders::_1));
+ checkboxes_[i] = cb;
+ horizontal->add(cb);
+ horizontal->add_space(kSpacing);
+--- a/src/ui_basic/box.cc
++++ b/src/ui_basic/box.cc
+@@ -104,7 +104,7 @@
+ int maxbreadth = mindesiredbreadth_;
+
+ for (uint32_t idx = 0; idx < items_.size(); ++idx) {
+- int depth, breadth = 0;
++ int depth = 0, breadth = 0;
+ get_item_desired_size(idx, &depth, &breadth);
+
+ totaldepth += depth;
diff --git a/games-strategy/widelands/widelands-0.20-r1.ebuild b/games-strategy/widelands/widelands-0.20-r1.ebuild
index 14a80be7f6ce..c0629174bc75 100644
--- a/games-strategy/widelands/widelands-0.20-r1.ebuild
+++ b/games-strategy/widelands/widelands-0.20-r1.ebuild
@@ -43,8 +43,9 @@ CMAKE_BUILD_TYPE="Release"
S="${WORKDIR}/${MY_P}"
PATCHES=(
- "${FILESDIR}/${PN}-0.20_rc1-cxxflags.patch"
- "${FILESDIR}/${PN}-0.20-glvnd.patch"
+ "${FILESDIR}"/${PN}-0.20_rc1-cxxflags.patch
+ "${FILESDIR}"/${PN}-0.20-glvnd.patch
+ "${FILESDIR}"/${PN}-0.20-boost-1.73.patch
)
src_prepare() {