summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-util/dfarc/dfarc-3.12-r1.ebuild')
-rw-r--r--games-util/dfarc/dfarc-3.12-r1.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/games-util/dfarc/dfarc-3.12-r1.ebuild b/games-util/dfarc/dfarc-3.12-r1.ebuild
new file mode 100644
index 000000000000..c996a7d3172d
--- /dev/null
+++ b/games-util/dfarc/dfarc-3.12-r1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+WX_GTK_VER="3.0"
+inherit eutils gnome2-utils wxwidgets xdg
+
+DESCRIPTION="Frontend and .dmod installer for GNU FreeDink"
+HOMEPAGE="http://www.freedink.org/"
+SRC_URI="mirror://gnu/freedink/${P}.tar.gz"
+
+LICENSE="GPL-3 BZIP2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="nls"
+
+RDEPEND="
+ app-arch/bzip2
+ x11-misc/xdg-utils
+ x11-libs/wxGTK:${WX_GTK_VER}[X]
+"
+DEPEND="${RDEPEND}
+ nls? ( >=dev-util/intltool-0.31 )
+"
+
+PATCHES=( "${FILESDIR}"/${P}-nowindres.patch )
+
+src_configure() {
+ econf \
+ $(use_enable nls) \
+ --disable-desktopfiles
+}
+
+src_install() {
+ default
+ dodoc TRANSLATIONS.txt
+}
+
+pkg_preinst() {
+ xdg_pkg_preinst
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_icon_cache_update
+}