summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-util/joystick')
-rw-r--r--games-util/joystick/Manifest1
-rw-r--r--games-util/joystick/files/joystick-1.4.8-build.patch39
-rw-r--r--games-util/joystick/files/joystick-1.4.8-udev.patch52
-rw-r--r--games-util/joystick/joystick-1.4.8-r1.ebuild39
-rw-r--r--games-util/joystick/joystick-1.4.8.ebuild29
-rw-r--r--games-util/joystick/metadata.xml8
6 files changed, 168 insertions, 0 deletions
diff --git a/games-util/joystick/Manifest b/games-util/joystick/Manifest
new file mode 100644
index 000000000000..2b49efbca52c
--- /dev/null
+++ b/games-util/joystick/Manifest
@@ -0,0 +1 @@
+DIST linuxconsoletools-1.4.8.tar.bz2 43964 SHA256 23c4ac595f608e25f472d947c4193233f763f37ae0cf6b48141d33443a4cee6a SHA512 ea3a0baa3f163e10a4c76f58977a96d91d91bddb1a75cea5195b0a631c11ca55e40730aaa0d1965404837595c4a7fd8b75c3dd7785fe0e47ee2c90021341f262 WHIRLPOOL c02960d5e171efef3739f440a903ae9b14bec8b6ab4de2181ea691aa78c870f81b291ac98e313d234778fb59c4be8e53242cb46db019f3dffdbd8f26ddcbb113
diff --git a/games-util/joystick/files/joystick-1.4.8-build.patch b/games-util/joystick/files/joystick-1.4.8-build.patch
new file mode 100644
index 000000000000..f888ccd18812
--- /dev/null
+++ b/games-util/joystick/files/joystick-1.4.8-build.patch
@@ -0,0 +1,39 @@
+--- linuxconsoletools-1.4.4.orig/docs/Makefile
++++ linuxconsoletools-1.4.4/docs/Makefile
+@@ -20,13 +20,17 @@
+ # 02110-1301 USA.
+
+ MANPAGES = inputattach.1 jstest.1 jscal.1 fftest.1 \
+- ffmvforce.1 ffset.1 ffcfstress.1 jscal-store.1 \
++ ffset.1 ffcfstress.1 jscal-store.1 \
+ jscal-restore.1
+
++ifneq ($(USE_SDL),no)
++MANPAGES += ffmvforce.1
++endif
++
+ PREFIX ?= /usr/local
+
+ install:
+ install -d $(DESTDIR)$(PREFIX)/share/man/man1
+- install $(MANPAGES) $(DESTDIR)$(PREFIX)/share/man/man1
++ install -m 644 $(MANPAGES) $(DESTDIR)$(PREFIX)/share/man/man1
+
+ .PHONY: install
+--- linuxconsoletools-1.4.4.orig/utils/Makefile
++++ linuxconsoletools-1.4.4/utils/Makefile
+@@ -27,9 +27,13 @@
+
+ CFLAGS ?= -g -O2 -Wall
+
+-PROGRAMS = inputattach jstest jscal fftest ffmvforce ffset \
++PROGRAMS = inputattach jstest jscal fftest ffset \
+ ffcfstress jscal-restore jscal-store
+
++ifneq ($(USE_SDL),no)
++PROGRAMS += ffmvforce
++endif
++
+ PREFIX ?= /usr/local
+
+ compile: $(PROGRAMS)
diff --git a/games-util/joystick/files/joystick-1.4.8-udev.patch b/games-util/joystick/files/joystick-1.4.8-udev.patch
new file mode 100644
index 000000000000..c0032493ebf7
--- /dev/null
+++ b/games-util/joystick/files/joystick-1.4.8-udev.patch
@@ -0,0 +1,52 @@
+diff -ru linuxconsoletools-1.4.8.orig/utils/jscal-restore.in linuxconsoletools-1.4.8/utils/jscal-restore.in
+--- linuxconsoletools-1.4.8.orig/utils/jscal-restore.in 2011-12-15 10:49:01.000000000 -0500
++++ linuxconsoletools-1.4.8/utils/jscal-restore.in 2015-05-16 01:54:00.799168225 -0400
+@@ -6,8 +6,13 @@
+ exit 1
+ fi
+
+-if [ ! -x /sbin/udevadm ]; then
+- echo Restoring joystick configuration requires udev! >&2
++for f in /sbin/udevadm /bin/udevadm ;
++do
++ [ -x $f ] && UDEVADM=$f
++done
++
++if [ -z "$UDEVADM" ] ; then
++ echo Storing joystick configuration requires udev! >&2
+ exit 1
+ fi
+
+@@ -30,7 +35,7 @@
+ # in the NAME value
+ IFS=$'\x0A'
+
+-for ATTRIBUTE in $( /sbin/udevadm info -a -n $1 | @@PREFIX@@/share/joystick/ident ); do
++for ATTRIBUTE in $( ${UDEVADM} info -a -n $1 | @@PREFIX@@/share/joystick/ident ); do
+ ID=$( echo "$ATTRIBUTE" | cut -f 1 -d = )
+ VALUE=$( echo "$ATTRIBUTE" | cut -f 2 -d \" )
+ case $ID in
+diff -ru linuxconsoletools-1.4.8.orig/utils/jscal-store.in linuxconsoletools-1.4.8/utils/jscal-store.in
+--- linuxconsoletools-1.4.8.orig/utils/jscal-store.in 2011-12-15 10:49:01.000000000 -0500
++++ linuxconsoletools-1.4.8/utils/jscal-store.in 2015-05-16 01:53:18.725607838 -0400
+@@ -11,14 +11,18 @@
+ echo "Stores the device's calibration for future use."
+ exit 1
+ fi
++for f in /sbin/udevadm /bin/udevadm ;
++do
++ [ -x $f ] && UDEVADM=$f
++done
+
+-if [ ! -x /sbin/udevadm ]; then
++if [ -z "$UDEVADM" ] ; then
+ echo Storing joystick configuration requires udev! >&2
+ exit 1
+ fi
+
+ ident=$(mktemp)
+-/sbin/udevadm info -a -n $1 | @@PREFIX@@/share/joystick/ident > $ident
++${UDEVADM} info -a -n $1 | @@PREFIX@@/share/joystick/ident > $ident
+ . $ident
+ rm $ident
+
diff --git a/games-util/joystick/joystick-1.4.8-r1.ebuild b/games-util/joystick/joystick-1.4.8-r1.ebuild
new file mode 100644
index 000000000000..387553c473da
--- /dev/null
+++ b/games-util/joystick/joystick-1.4.8-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils toolchain-funcs
+
+MY_P="linuxconsoletools-${PV}"
+DESCRIPTION="joystick testing utilities"
+HOMEPAGE="http://sourceforge.net/projects/linuxconsole/ http://atrey.karlin.mff.cuni.cz/~vojtech/input/"
+SRC_URI="mirror://sourceforge/linuxconsole/files/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~arm ~ppc x86"
+IUSE="sdl udev"
+
+DEPEND="sdl? ( media-libs/libsdl:0[video] )
+ !<x11-libs/tslib-1.0-r2"
+RDEPEND="${DEPEND}
+ udev? ( virtual/udev )"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${P}-build.patch \
+ "${FILESDIR}"/${P}-udev.patch
+ export PREFIX=/usr
+ tc-export CC PKG_CONFIG
+ export USE_SDL=$(usex sdl)
+}
+
+src_install() {
+ default
+ if use !udev ; then
+ rm -f "${D}"/usr/bin/jscal-{re,}store || die
+ fi
+}
diff --git a/games-util/joystick/joystick-1.4.8.ebuild b/games-util/joystick/joystick-1.4.8.ebuild
new file mode 100644
index 000000000000..7fd0e8a00441
--- /dev/null
+++ b/games-util/joystick/joystick-1.4.8.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils toolchain-funcs
+
+MY_P="linuxconsoletools-${PV}"
+DESCRIPTION="joystick testing utilities"
+HOMEPAGE="http://sourceforge.net/projects/linuxconsole/ http://atrey.karlin.mff.cuni.cz/~vojtech/input/"
+SRC_URI="mirror://sourceforge/linuxconsole/files/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 arm ~ppc x86"
+IUSE="sdl"
+
+DEPEND="sdl? ( media-libs/libsdl:0[video] )
+ !<x11-libs/tslib-1.0-r2"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-build.patch
+ export PREFIX=/usr
+ tc-export CC PKG_CONFIG
+ export USE_SDL=$(usex sdl)
+}
diff --git a/games-util/joystick/metadata.xml b/games-util/joystick/metadata.xml
new file mode 100644
index 000000000000..ec0c3e67096f
--- /dev/null
+++ b/games-util/joystick/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>games</herd>
+ <upstream>
+ <remote-id type="sourceforge">linuxconsole</remote-id>
+ </upstream>
+</pkgmetadata>