summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-util/lutris')
-rw-r--r--games-util/lutris/Manifest1
-rw-r--r--games-util/lutris/lutris-0.3.6.3.ebuild68
-rw-r--r--games-util/lutris/metadata.xml15
3 files changed, 84 insertions, 0 deletions
diff --git a/games-util/lutris/Manifest b/games-util/lutris/Manifest
new file mode 100644
index 000000000000..74fb1ff388f8
--- /dev/null
+++ b/games-util/lutris/Manifest
@@ -0,0 +1 @@
+DIST lutris_0.3.6.3.tar.gz 515606 SHA256 a9061403ef8844b2c1443b1c5f15fe98af224d652d66268b47ae8e215e289058 SHA512 548a3a79ffb1c378d923f404634acc3b5eb1055d087ff212cf8a35b7db56650bf616f3b7374ab9fdf996c8f10d80ab602d35d126ef3bb183b9ce55b36d270e97 WHIRLPOOL 9c6e08908a2462f639a89f05b8eea9c212dba103a9c0492d3bd8bba2d2002d718354b4410e6506c7e88c0b4a2bf930d6d05930d0b27d66de0b66b9526f2c2fac
diff --git a/games-util/lutris/lutris-0.3.6.3.ebuild b/games-util/lutris/lutris-0.3.6.3.ebuild
new file mode 100644
index 000000000000..03916a101512
--- /dev/null
+++ b/games-util/lutris/lutris-0.3.6.3.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE="sqlite,threads"
+
+inherit distutils-r1 gnome2-utils games
+
+DESCRIPTION="Gaming platform for GNU/Linux"
+HOMEPAGE="http://lutris.net/"
+SRC_URI="http://lutris.net/releases/${PN}_${PV}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND="dev-python/pygobject:3[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/pyxdg[${PYTHON_USEDEP}]
+ gnome-base/gvfs[http]
+ x11-apps/xrandr
+ x11-apps/xgamma
+ x11-misc/xdg-utils"
+
+# INSTALL contains list of optional deps
+DOCS=( AUTHORS README.rst INSTALL )
+
+S=${WORKDIR}/${PN}
+
+python_install() {
+ distutils-r1_python_install --install-scripts="${GAMES_BINDIR}"
+}
+
+src_prepare() {
+ distutils-r1_src_prepare
+}
+
+src_compile() {
+ distutils-r1_src_compile
+}
+
+src_install() {
+ distutils-r1_src_install
+ prepgamesdirs
+}
+
+pkg_preinst() {
+ games_pkg_preinst
+ gnome2_icon_savelist
+ gnome2_schemas_savelist
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ gnome2_icon_cache_update
+ gnome2_schemas_update
+
+ elog "For a list of optional deps (runners), see"
+ elog "/usr/share/doc/${PF}/INSTALL"
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+ gnome2_schemas_update
+}
diff --git a/games-util/lutris/metadata.xml b/games-util/lutris/metadata.xml
new file mode 100644
index 000000000000..633db1adc52c
--- /dev/null
+++ b/games-util/lutris/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>games</herd>
+ <longdescription lang="en">
+ Lutris is a gaming platform for GNU/Linux. Its goal is to make
+ gaming on Linux as easy as possible by taking care of installing
+ and setting up the game for the user. The only thing you have to
+ do is play the game. It aims to support every game that is playable
+ on Linux.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">lutris/lutris</remote-id>
+ </upstream>
+</pkgmetadata>