summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'gnome-base/libbonobo/libbonobo-2.24.3-r1.ebuild')
-rw-r--r--gnome-base/libbonobo/libbonobo-2.24.3-r1.ebuild66
1 files changed, 66 insertions, 0 deletions
diff --git a/gnome-base/libbonobo/libbonobo-2.24.3-r1.ebuild b/gnome-base/libbonobo/libbonobo-2.24.3-r1.ebuild
new file mode 100644
index 000000000000..a17a7ee48b6c
--- /dev/null
+++ b/gnome-base/libbonobo/libbonobo-2.24.3-r1.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="yes"
+GNOME2_LA_PUNT="yes"
+GNOME_TARBALL_SUFFIX="bz2"
+
+inherit gnome2
+
+DESCRIPTION="GNOME CORBA framework"
+HOMEPAGE="http://developer.gnome.org/libbonobo/stable/"
+
+LICENSE="LGPL-2.1 GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm ia64 ~mips ppc ppc64 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~sparc-solaris ~x86-solaris"
+IUSE="debug examples test"
+
+RDEPEND="
+ >=dev-libs/glib-2.14:2
+ >=gnome-base/orbit-2.14.0
+ >=dev-libs/libxml2-2.4.20:2
+ >=sys-apps/dbus-1.0.0
+ >=dev-libs/dbus-glib-0.74
+ >=dev-libs/popt-1.5
+ !gnome-base/bonobo-activation
+"
+DEPEND="${RDEPEND}
+ dev-util/gtk-doc-am
+ virtual/yacc
+ sys-devel/flex
+ x11-apps/xrdb
+ virtual/pkgconfig
+ >=dev-util/intltool-0.35
+"
+
+# Tests are broken in several ways as reported in bug #288689 and upstream
+# doesn't take care since libbonobo is deprecated.
+RESTRICT="test"
+
+src_prepare() {
+ # Fix intltoolize broken file, see upstream #577133
+ sed "s:'\^\$\$lang\$\$':\^\$\$lang\$\$:g" -i po/Makefile.in.in || die
+
+ if ! use test; then
+ # don't waste time building tests, bug #226223
+ sed 's/tests//' -i Makefile.am Makefile.in || die
+ fi
+
+ if ! use examples; then
+ sed 's/samples//' -i Makefile.am Makefile.in || die
+ fi
+
+ gnome2_src_prepare
+}
+
+src_configure() {
+ gnome2_src_configure $(use_enable debug bonobo-activation-debug)
+}
+
+src_test() {
+ # Pass tests with FEATURES userpriv, see bug #288689
+ unset ORBIT_SOCKETDIR
+ emake check
+}