summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'gnome-extra/cinnamon-menus/cinnamon-menus-3.4.0.ebuild')
-rw-r--r--gnome-extra/cinnamon-menus/cinnamon-menus-3.4.0.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/gnome-extra/cinnamon-menus/cinnamon-menus-3.4.0.ebuild b/gnome-extra/cinnamon-menus/cinnamon-menus-3.4.0.ebuild
new file mode 100644
index 000000000000..2dece04e2b33
--- /dev/null
+++ b/gnome-extra/cinnamon-menus/cinnamon-menus-3.4.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit autotools gnome2
+
+DESCRIPTION="Cinnamon's library for the Desktop Menu fd.o specification"
+HOMEPAGE="http://cinnamon.linuxmint.com/"
+SRC_URI="https://github.com/linuxmint/cinnamon-menus/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+ LGPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug +introspection"
+
+RDEPEND="
+ >=dev-libs/glib-2.29.15:2
+ introspection? ( >=dev-libs/gobject-introspection-0.9.5:= )
+"
+DEPEND="${RDEPEND}
+ dev-libs/gobject-introspection-common
+ >=dev-util/intltool-0.40
+ gnome-base/gnome-common
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ eautoreconf
+ gnome2_src_prepare
+}
+
+src_configure() {
+ gnome2_src_configure \
+ $(usex debug --enable-debug=yes ' ') \
+ $(use_enable introspection) \
+ --disable-static
+}