summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'gnome-extra/gnome-commander/gnome-commander-1.4.8.ebuild')
-rw-r--r--gnome-extra/gnome-commander/gnome-commander-1.4.8.ebuild12
1 files changed, 10 insertions, 2 deletions
diff --git a/gnome-extra/gnome-commander/gnome-commander-1.4.8.ebuild b/gnome-extra/gnome-commander/gnome-commander-1.4.8.ebuild
index 2e2b2fa59300..c812765380d9 100644
--- a/gnome-extra/gnome-commander/gnome-commander-1.4.8.ebuild
+++ b/gnome-extra/gnome-commander/gnome-commander-1.4.8.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -14,6 +14,7 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 x86"
IUSE="chm doc exif gsf pdf python taglib"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
RDEPEND="app-text/gnome-doc-utils
>=dev-libs/glib-2.6.0:2
@@ -28,7 +29,10 @@ RDEPEND="app-text/gnome-doc-utils
exif? ( >=media-gfx/exiv2-0.14 )
gsf? ( >=gnome-extra/libgsf-1.12.0 )
pdf? ( >=app-text/poppler-0.18 )
- python? ( >=dev-python/gnome-vfs-python-2.0.0 )
+ python? (
+ ${PYTHON_DEPS}
+ >=dev-python/gnome-vfs-python-2.0.0
+ )
taglib? ( >=media-libs/taglib-1.4 )"
DEPEND="${RDEPEND}
>=dev-util/intltool-0.35.0
@@ -37,6 +41,10 @@ DEPEND="${RDEPEND}
DOCS="AUTHORS BUGS ChangeLog NEWS README TODO"
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
src_configure() {
G2CONF="$(use_enable doc scrollkeeper)
$(use_enable python)