summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'gnome-extra/gnome-commander/gnome-commander-1.6.1.ebuild')
-rw-r--r--gnome-extra/gnome-commander/gnome-commander-1.6.1.ebuild10
1 files changed, 9 insertions, 1 deletions
diff --git a/gnome-extra/gnome-commander/gnome-commander-1.6.1.ebuild b/gnome-extra/gnome-commander/gnome-commander-1.6.1.ebuild
index 75cd40645707..f5d9510947ec 100644
--- a/gnome-extra/gnome-commander/gnome-commander-1.6.1.ebuild
+++ b/gnome-extra/gnome-commander/gnome-commander-1.6.1.ebuild
@@ -15,6 +15,7 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 x86"
IUSE="chm exif gsf pdf python taglib samba test"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
RDEPEND="
app-text/gnome-doc-utils
@@ -30,7 +31,10 @@ RDEPEND="
gsf? ( >=gnome-extra/libgsf-1.12.0 )
samba? ( >=gnome-base/gnome-vfs-2.0.0[samba] )
pdf? ( >=app-text/poppler-0.18 )
- python? ( >=dev-python/gnome-vfs-python-2.0.0 )
+ python? (
+ ${PYTHON_DEPS}
+ >=dev-python/gnome-vfs-python-2.0.0
+ )
taglib? ( >=media-libs/taglib-1.4 )
"
DEPEND="
@@ -42,6 +46,10 @@ DEPEND="
test? ( >=dev-util/cppunit-1.13.2 )
"
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
src_configure() {
gnome2_src_configure \
--disable-static \