summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'gnome-extra/gnome-user-share/gnome-user-share-3.14.2.ebuild')
-rw-r--r--gnome-extra/gnome-user-share/gnome-user-share-3.14.2.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/gnome-extra/gnome-user-share/gnome-user-share-3.14.2.ebuild b/gnome-extra/gnome-user-share/gnome-user-share-3.14.2.ebuild
new file mode 100644
index 000000000000..76200e169599
--- /dev/null
+++ b/gnome-extra/gnome-user-share/gnome-user-share-3.14.2.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+
+inherit gnome2 multilib
+
+DESCRIPTION="Personal file sharing for the GNOME desktop"
+HOMEPAGE="https://git.gnome.org/browse/gnome-user-share"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="bluetooth"
+
+# FIXME: could libnotify be made optional ?
+# FIXME: selinux automagic support
+RDEPEND="
+ >=dev-libs/glib-2.28:2
+ >=x11-libs/gtk+-3:3
+ >=gnome-base/nautilus-2.91.7
+ media-libs/libcanberra[gtk3]
+ >=www-apache/mod_dnssd-0.6
+ >=www-servers/apache-2.2[apache2_modules_dav,apache2_modules_dav_fs,apache2_modules_authn_file,apache2_modules_auth_digest,apache2_modules_authz_groupfile,apache2_mpms_prefork]
+ >=x11-libs/libnotify-0.7:=
+ bluetooth? (
+ >=net-wireless/gnome-bluetooth-3.9.3:2=
+ >=net-wireless/bluez-5[obex] )
+"
+DEPEND="${RDEPEND}
+ !<gnome-base/gnome-control-center-3.9
+ app-text/yelp-tools
+ app-text/docbook-xml-dtd:4.1.2
+ >=dev-util/intltool-0.35
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+src_configure() {
+ gnome2_src_configure \
+ $(use_enable bluetooth) \
+ --with-httpd=apache2 \
+ --with-modules-path=/usr/$(get_libdir)/apache2/modules/
+}