summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'gnustep-libs/renaissance')
-rw-r--r--gnustep-libs/renaissance/Manifest1
-rw-r--r--gnustep-libs/renaissance/files/renaissance-0.8.1_pre20070522-docpath.patch21
-rw-r--r--gnustep-libs/renaissance/metadata.xml26
-rw-r--r--gnustep-libs/renaissance/renaissance-0.9.0.ebuild23
4 files changed, 71 insertions, 0 deletions
diff --git a/gnustep-libs/renaissance/Manifest b/gnustep-libs/renaissance/Manifest
new file mode 100644
index 000000000000..793c021f15f4
--- /dev/null
+++ b/gnustep-libs/renaissance/Manifest
@@ -0,0 +1 @@
+DIST Renaissance-0.9.0.tar.gz 404888 RMD160 039ca153a1a4de7dbd584cde4528979759dcc427 SHA1 e40a2b67024d5444ae31ccc1fdb24f2325f2981f SHA256 5c2078d211dd9d9de48c8d26d3dde3f7fae18fadeac1ff4049e5996a29ce342b
diff --git a/gnustep-libs/renaissance/files/renaissance-0.8.1_pre20070522-docpath.patch b/gnustep-libs/renaissance/files/renaissance-0.8.1_pre20070522-docpath.patch
new file mode 100644
index 000000000000..df4f8c43ca1e
--- /dev/null
+++ b/gnustep-libs/renaissance/files/renaissance-0.8.1_pre20070522-docpath.patch
@@ -0,0 +1,21 @@
+diff -Naur renaissance-0.8.1_pre20070522.orig/Documentation/GNUmakefile renaissance-0.8.1_pre20070522/Documentation/GNUmakefile
+--- renaissance-0.8.1_pre20070522.orig/Documentation/GNUmakefile 2007-10-17 14:32:41.000000000 +0200
++++ renaissance-0.8.1_pre20070522/Documentation/GNUmakefile 2007-10-17 14:33:18.000000000 +0200
+@@ -8,6 +8,7 @@
+ macros.tex \
+ autolayout.tex \
+ gsmarkup.tex
++manual_DOC_INSTALL_DIR = Developer/Renaissance
+
+ SUBPROJECTS = Tutorials
+
+diff -Naur renaissance-0.8.1_pre20070522.orig/Documentation/Tutorials/Renaissance/GNUmakefile renaissance-0.8.1_pre20070522/Documentation/Tutorials/Renaissance/GNUmakefile
+--- renaissance-0.8.1_pre20070522.orig/Documentation/Tutorials/Renaissance/GNUmakefile 2007-10-17 14:32:41.000000000 +0200
++++ renaissance-0.8.1_pre20070522/Documentation/Tutorials/Renaissance/GNUmakefile 2007-10-17 14:33:07.000000000 +0200
+@@ -3,5 +3,6 @@
+ DOCUMENT_NAME = Renaissance
+
+ Renaissance_LATEX_FILES = Renaissance.tex
++Renaissance_DOC_INSTALL_DIR = Developer/Renaissance
+
+ include $(GNUSTEP_MAKEFILES)/documentation.make
diff --git a/gnustep-libs/renaissance/metadata.xml b/gnustep-libs/renaissance/metadata.xml
new file mode 100644
index 000000000000..ff7f03c8ed9a
--- /dev/null
+++ b/gnustep-libs/renaissance/metadata.xml
@@ -0,0 +1,26 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>gnustep</herd>
+<longdescription>
+Welcome to GNUstep Renaissance!
+
+GNUstep Renaissance is free software (GNU LGPL), and part of the
+GNUstep project. It is a development framework which runs on top of
+the GNUstep libraries. It also works on top of the Apple Mac OS X
+Cocoa libraries, providing an opaque layer to write portable
+applications.
+
+In short, GNUstep Renaissance allows you to describe your user
+interfaces (that is, the windows in your application, and the buttons,
+boxes, textfields, etc in the windows) in simple and intuitive XML
+files, using an open, standard format describing the logic of the
+interface. GNUstep Renaissance can then, at run time, generate the
+user interfaces (using the native host OpenStep-like libraries) by
+reading the XML files. The connections between the objects created
+from the XML files, and the other objects in the application are done
+via outlets (as traditionally in OpenStep); a new quick and intuitive
+syntax has been developed to make creating outlets as easy as
+possible.
+</longdescription>
+</pkgmetadata>
diff --git a/gnustep-libs/renaissance/renaissance-0.9.0.ebuild b/gnustep-libs/renaissance/renaissance-0.9.0.ebuild
new file mode 100644
index 000000000000..262b639af860
--- /dev/null
+++ b/gnustep-libs/renaissance/renaissance-0.9.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit gnustep-2
+
+DESCRIPTION="GNUstep Renaissance allows to describe user interfaces XML files"
+HOMEPAGE="http://www.gnustep.it/Renaissance/index.html"
+SRC_URI="http://www.gnustep.it/Renaissance/Download/${P/r/R}.tar.gz"
+
+KEYWORDS="amd64 ppc x86"
+LICENSE="LGPL-2.1"
+SLOT="0"
+IUSE=""
+
+S=${WORKDIR}/${P/r/R}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}"/${PN}-0.8.1_pre20070522-docpath.patch
+}