summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'gui-apps/wayland-logout/wayland-logout-9999.ebuild')
-rw-r--r--gui-apps/wayland-logout/wayland-logout-9999.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/gui-apps/wayland-logout/wayland-logout-9999.ebuild b/gui-apps/wayland-logout/wayland-logout-9999.ebuild
new file mode 100644
index 000000000000..edb385b32abf
--- /dev/null
+++ b/gui-apps/wayland-logout/wayland-logout-9999.ebuild
@@ -0,0 +1,26 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="general logout scripts for wayland compositors"
+
+HOMEPAGE="https://github.com/soreau/wayland-logout"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/soreau/wayland-logout"
+else
+ SRC_URI="https://github.com/soreau/wayland-logout/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+
+RDEPEND="sys-process/lsof"
+
+src_install() {
+ newbin wayland-logout.sh wayland-logout
+ dosym wayland-logout /usr/bin/wlogout
+}