summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'gui-apps/wcm/wcm-0.5.0.ebuild')
-rw-r--r--gui-apps/wcm/wcm-0.5.0.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/gui-apps/wcm/wcm-0.5.0.ebuild b/gui-apps/wcm/wcm-0.5.0.ebuild
new file mode 100644
index 000000000000..375772702783
--- /dev/null
+++ b/gui-apps/wcm/wcm-0.5.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2019-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson
+
+DESCRIPTION="Wayfire Config Manager"
+HOMEPAGE="https://github.com/WayfireWM/wcm"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/WayfireWM/wcm.git"
+else
+ SRC_URI="https://github.com/WayfireWM/wcm/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+
+DEPEND="
+ dev-libs/libevdev
+ dev-libs/libxml2
+ dev-cpp/gtkmm:3.0[wayland]
+ >=gui-wm/wayfire-${PV}
+"
+
+RDEPEND="${DEPEND}"
+
+BDEPEND="
+ dev-libs/wayland-protocols
+ virtual/pkgconfig
+"