summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'gui-libs')
-rw-r--r--gui-libs/wf-config/Manifest1
-rw-r--r--gui-libs/wf-config/metadata.xml18
-rw-r--r--gui-libs/wf-config/wf-config-0.4.0.ebuild46
-rw-r--r--gui-libs/wf-config/wf-config-9999.ebuild46
4 files changed, 111 insertions, 0 deletions
diff --git a/gui-libs/wf-config/Manifest b/gui-libs/wf-config/Manifest
new file mode 100644
index 000000000000..d96518e9b6b4
--- /dev/null
+++ b/gui-libs/wf-config/Manifest
@@ -0,0 +1 @@
+DIST wf-config-0.4.0.tar.xz 64108 BLAKE2B 83999dd246e6b7a6c54bbbcdf7abf08767b31bd29e75cd41d9844c4b98c66fbe787b7d87ec433e2c5e860e476f4f621116aac16c7f3f56903ee1689c5d1bc6c9 SHA512 30358ada695012b9f4be835f2b2d032e0d8d52c3e9d49d39ae975c74bc0cac188341e507124a088d8cdb3d62c77645a7d435262d15a6cc604b4738861362a299
diff --git a/gui-libs/wf-config/metadata.xml b/gui-libs/wf-config/metadata.xml
new file mode 100644
index 000000000000..cf54d732b433
--- /dev/null
+++ b/gui-libs/wf-config/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <longdescription>
+ Library for creating and parsing the configuration
+ file for the WayfireWM while also allowing you to
+ make changes in the configuration and reload them on
+ the fly.
+ </longdescription>
+ <maintainer type="person">
+ <email>gentoo@aisha.cc</email>
+ <name>Aisha Tammy</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/gui-libs/wf-config/wf-config-0.4.0.ebuild b/gui-libs/wf-config/wf-config-0.4.0.ebuild
new file mode 100644
index 000000000000..328ec1807428
--- /dev/null
+++ b/gui-libs/wf-config/wf-config-0.4.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 2019-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson
+
+DESCRIPTION="library for managing wayfire configuration files"
+HOMEPAGE="https://github.com/WayfireWM/wf-config"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/WayfireWM/${PN}.git"
+else
+ SRC_URI="https://github.com/WayfireWM/${PN}/releases/download/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="debug"
+
+DEPEND="
+ dev-libs/libevdev
+ dev-libs/libxml2
+ gui-libs/wlroots
+ media-libs/glm
+"
+
+RDEPEND="${DEPEND}"
+
+BDEPEND="
+ ${DEPEND}
+ dev-libs/wayland-protocols
+ virtual/pkgconfig
+"
+
+src_compile () {
+ local emesonargs=""
+ if use debug; then
+ emesonargs+=(
+ "-Db_sanitize=address,undefined"
+ )
+ fi
+ meson_src_compile
+}
diff --git a/gui-libs/wf-config/wf-config-9999.ebuild b/gui-libs/wf-config/wf-config-9999.ebuild
new file mode 100644
index 000000000000..328ec1807428
--- /dev/null
+++ b/gui-libs/wf-config/wf-config-9999.ebuild
@@ -0,0 +1,46 @@
+# Copyright 2019-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson
+
+DESCRIPTION="library for managing wayfire configuration files"
+HOMEPAGE="https://github.com/WayfireWM/wf-config"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/WayfireWM/${PN}.git"
+else
+ SRC_URI="https://github.com/WayfireWM/${PN}/releases/download/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="debug"
+
+DEPEND="
+ dev-libs/libevdev
+ dev-libs/libxml2
+ gui-libs/wlroots
+ media-libs/glm
+"
+
+RDEPEND="${DEPEND}"
+
+BDEPEND="
+ ${DEPEND}
+ dev-libs/wayland-protocols
+ virtual/pkgconfig
+"
+
+src_compile () {
+ local emesonargs=""
+ if use debug; then
+ emesonargs+=(
+ "-Db_sanitize=address,undefined"
+ )
+ fi
+ meson_src_compile
+}