summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-apps/ark')
-rw-r--r--kde-apps/ark/Manifest1
-rw-r--r--kde-apps/ark/ark-19.08.2.ebuild79
2 files changed, 80 insertions, 0 deletions
diff --git a/kde-apps/ark/Manifest b/kde-apps/ark/Manifest
index 5e6a24dc6b5a..b23d1c248310 100644
--- a/kde-apps/ark/Manifest
+++ b/kde-apps/ark/Manifest
@@ -1,2 +1,3 @@
DIST ark-19.04.3.tar.xz 2579920 BLAKE2B a8637d4f564fe20aa28035e5c1a09ca8c6803bf6acb9fc82074a8219368f1ff9b45dd88dc1439823e73eb627d2f13269b4cd776480d991c1499e8de1510de14c SHA512 dc41f8daea7c63f93725cd1dada978fde68c7e7c659840014fe3ccc32a8e9e7013f495590cd5344d68001cbba81f527ec368829b4ff1577f71d5de268cd0b459
DIST ark-19.08.1.tar.xz 2585216 BLAKE2B de644156e7951b37b54ceeed05f1b8712bc267f788c04fa4647a2842434bd46e0fa623c3cf5574199eb8fbda57c0d8523387d6c7caa836cb03f03a82c1050ee0 SHA512 438cffcacc628af6ff9d086819d0572fbe9afea5ce81a31d1cb34bffc46c1bbbcb4b271fb951d4a19ed5beb9f57c1cfa95f8d4a5543702ba090ce9e25095a6fc
+DIST ark-19.08.2.tar.xz 2584864 BLAKE2B eb234a882a1249be3665754925d9041d59760d05803beb87bf497bc90912b0101ec2247b9b1f773bd99691b2df875dd9b551ff8db8711d30224dc7f89153b314 SHA512 c4ae42a68a9f00238de4dcfef066c3e20f9a896fe00473b4db4ca4aadc8db1f63c876a98833799c533962283fe3f64be36e563e5624e0dae1978452438392788
diff --git a/kde-apps/ark/ark-19.08.2.ebuild b/kde-apps/ark/ark-19.08.2.ebuild
new file mode 100644
index 000000000000..bba063801ed4
--- /dev/null
+++ b/kde-apps/ark/ark-19.08.2.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+KDE_HANDBOOK="forceoptional"
+KDE_TEST="optional"
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+DESCRIPTION="KDE Archiving tool"
+HOMEPAGE="https://kde.org/applications/utilities/ark
+https://utils.kde.org/projects/ark/"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="bzip2 lzma zip"
+
+BDEPEND="
+ sys-devel/gettext
+"
+RDEPEND="
+ $(add_frameworks_dep karchive)
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kcrash)
+ $(add_frameworks_dep kdbusaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kitemmodels)
+ $(add_frameworks_dep kjobwidgets)
+ $(add_frameworks_dep kparts)
+ $(add_frameworks_dep kpty)
+ $(add_frameworks_dep kservice)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kxmlgui)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtwidgets)
+ app-arch/libarchive:=[bzip2?,lzma?,zlib]
+ sys-libs/zlib
+ zip? ( >=dev-libs/libzip-1.2.0:= )
+"
+DEPEND="${RDEPEND}
+ $(add_qt_dep qtconcurrent)
+"
+
+# bug #560548, last checked with 16.04.1
+RESTRICT+=" test"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package bzip2 BZip2)
+ $(cmake-utils_use_find_package lzma LibLZMA)
+ $(cmake-utils_use_find_package zip LibZip)
+ )
+
+ kde5_src_configure
+}
+
+pkg_postinst() {
+ kde5_pkg_postinst
+
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ if ! has_version app-arch/rar; then
+ elog "For creating/extracting rar archives, installing app-arch/rar is required."
+ if ! has_version app-arch/unar && ! has_version app-arch/unrar; then
+ elog "Alternatively, for only extracting rar archives, install app-arch/unar (free) or app-arch/unrar (non-free)."
+ fi
+ fi
+
+ has_version app-arch/p7zip || \
+ elog "For handling 7-Zip archives, install app-arch/p7zip."
+
+ has_version app-arch/lrzip || \
+ elog "For handling lrz archives, install app-arch/lrzip."
+ fi
+}