summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-apps/dolphin')
-rw-r--r--kde-apps/dolphin/Manifest5
-rw-r--r--kde-apps/dolphin/dolphin-23.04.3.ebuild (renamed from kde-apps/dolphin/dolphin-22.08.3.ebuild)19
-rw-r--r--kde-apps/dolphin/dolphin-23.08.5.ebuild (renamed from kde-apps/dolphin/dolphin-22.12.3.ebuild)23
-rw-r--r--kde-apps/dolphin/dolphin-24.02.2.ebuild91
-rw-r--r--kde-apps/dolphin/files/dolphin-23.08.5-musl.patch64
5 files changed, 183 insertions, 19 deletions
diff --git a/kde-apps/dolphin/Manifest b/kde-apps/dolphin/Manifest
index 0facd5db5124..c5b33ae9c79d 100644
--- a/kde-apps/dolphin/Manifest
+++ b/kde-apps/dolphin/Manifest
@@ -1,2 +1,3 @@
-DIST dolphin-22.08.3.tar.xz 5369436 BLAKE2B c1d60aa79603a40ad559f1bcac8d9211e0032c58374d2268ec7530c8a3e38233271b990e24eabaa258085942f5c0dfa9a9c6a91da92caee45dd165670d62918c SHA512 1abb4f3fe47c61eef93378e069b11c894812892b5a3aec84a2ee2007a235b37aec02d2a9680581d2092596c680427e8eabbac2a0b5b64e48c7d7ea1da8f0c5b5
-DIST dolphin-22.12.3.tar.xz 5693220 BLAKE2B cf156536d18fe6f8fb9d563be4e7cd96ad012b32e23a367e061beb5b3567039d1c7e42a6e32b348d493f16b59def3423f3c66bbea00c14017cac6383ded391c3 SHA512 2683d02831ac75b311fc0ef3610f1086cf2a00860fb9495c2049b86dee5deb4deeee81d8dbb1c6647e33afc7323b2f4a620e0c6512fa1a499e4b830a9bf6e0e1
+DIST dolphin-23.04.3.tar.xz 5737968 BLAKE2B 5942d5894c2d51cc3f0c5ab599bb82c2e324203f26a6b7a65dca2198cf046011c37d809ca71c2ef36db1687d8159bdbe97f33eb99d550eada982555d903c381e SHA512 6078947b3dd6c1c62ba2306109c9dcc4be6ebb64bb69699f0457aaa1e0b6b0168d8767d73f0f8731984f5b412200c5463df7237c65990ee073f2d35946ad7b9e
+DIST dolphin-23.08.5.tar.xz 5770048 BLAKE2B d46cbd81d2f6e020998fe560affa45916fdcf53e7acbb62503221d4a53cd582d692c025b7c9c16f6285a5d97fda696ff75198b479b7316c95e6b782c39bbb570 SHA512 0b25cc8ec1222fcd6eba971aa701a2ddcf5297c4d78b1cd63fde7ecf8e267f1af76ca1bf544ea4a4f98309b40c41aba441cfda1a9c3fb0e4df2a426e4402cb4b
+DIST dolphin-24.02.2.tar.xz 5808200 BLAKE2B 278461bc445883242a4085c3fb5911549002217b6f19eb88d435a98c85ee237d6c2882880096571f145a87ca4f2595e9ec2d6d6e9bdf21bfc7c9693d55c833e6 SHA512 951aa3a29003f3d14cfed4b3b8da000e4c8cb4b71172f32b145d36cde99713f08475d782225743fd7f27a25976b5136f241e6cad5f5c4b0eeffd4345f1b3d7df
diff --git a/kde-apps/dolphin/dolphin-22.08.3.ebuild b/kde-apps/dolphin/dolphin-23.04.3.ebuild
index dac899f762df..be2063e8e87b 100644
--- a/kde-apps/dolphin/dolphin-22.08.3.ebuild
+++ b/kde-apps/dolphin/dolphin-23.04.3.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -6,9 +6,8 @@ EAPI=8
ECM_HANDBOOK="optional"
ECM_TEST="true"
PVCUT=$(ver_cut 1-3)
-KFMIN=5.96.0
-QTMIN=5.15.5
-VIRTUALX_REQUIRED="test"
+KFMIN=5.106.0
+QTMIN=5.15.9
inherit ecm gear.kde.org optfeature
DESCRIPTION="Plasma filemanager focusing on usability"
@@ -24,6 +23,7 @@ DEPEND="
>=dev-qt/qtdbus-${QTMIN}:5
>=dev-qt/qtgui-${QTMIN}:5
>=dev-qt/qtwidgets-${QTMIN}:5
+ >=dev-qt/qtx11extras-${QTMIN}:5
>=dev-qt/qtxml-${QTMIN}:5
>=kde-frameworks/kbookmarks-${KFMIN}:5
>=kde-frameworks/kcmutils-${KFMIN}:5
@@ -48,17 +48,20 @@ DEPEND="
>=kde-frameworks/kwindowsystem-${KFMIN}:5
>=kde-frameworks/kxmlgui-${KFMIN}:5
>=kde-frameworks/solid-${KFMIN}:5
- >=media-libs/phonon-4.11.0
- activities? ( >=kde-frameworks/kactivities-${KFMIN}:5 )
+ >=media-libs/phonon-4.11.0[qt5(+)]
+ activities? ( >=kde-plasma/plasma-activities-${KFMIN}:5 )
semantic-desktop? (
>=kde-apps/baloo-widgets-${PVCUT}:5
>=kde-frameworks/baloo-${KFMIN}:5
>=kde-frameworks/kfilemetadata-${KFMIN}:5
)
- telemetry? ( dev-libs/kuserfeedback:5 )
+ telemetry? ( kde-frameworks/kuserfeedback:5 )
"
RDEPEND="${DEPEND}
- >=kde-apps/kio-extras-${PVCUT}:5
+ || (
+ kde-apps/kio-extras-kf5:5
+ >=kde-apps/kio-extras-${PVCUT}:5
+ )
"
src_configure() {
diff --git a/kde-apps/dolphin/dolphin-22.12.3.ebuild b/kde-apps/dolphin/dolphin-23.08.5.ebuild
index f4970af42075..e0543a379707 100644
--- a/kde-apps/dolphin/dolphin-22.12.3.ebuild
+++ b/kde-apps/dolphin/dolphin-23.08.5.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -6,9 +6,8 @@ EAPI=8
ECM_HANDBOOK="optional"
ECM_TEST="true"
PVCUT=$(ver_cut 1-3)
-KFMIN=5.101.0
-QTMIN=5.15.5
-VIRTUALX_REQUIRED="test"
+KFMIN=5.106.0
+QTMIN=5.15.9
inherit ecm gear.kde.org optfeature
DESCRIPTION="Plasma filemanager focusing on usability"
@@ -16,7 +15,7 @@ HOMEPAGE="https://apps.kde.org/dolphin/ https://userbase.kde.org/Dolphin"
LICENSE="GPL-2" # TODO: CHECK
SLOT="5"
-KEYWORDS="~amd64 ~arm64 ~loong ~ppc64 ~riscv ~x86"
+KEYWORDS="amd64 arm64 ~loong ~ppc64 ~riscv x86"
IUSE="activities semantic-desktop telemetry"
DEPEND="
@@ -24,6 +23,7 @@ DEPEND="
>=dev-qt/qtdbus-${QTMIN}:5
>=dev-qt/qtgui-${QTMIN}:5
>=dev-qt/qtwidgets-${QTMIN}:5
+ >=dev-qt/qtx11extras-${QTMIN}:5
>=dev-qt/qtxml-${QTMIN}:5
>=kde-frameworks/kbookmarks-${KFMIN}:5
>=kde-frameworks/kcmutils-${KFMIN}:5
@@ -48,19 +48,24 @@ DEPEND="
>=kde-frameworks/kwindowsystem-${KFMIN}:5
>=kde-frameworks/kxmlgui-${KFMIN}:5
>=kde-frameworks/solid-${KFMIN}:5
- >=media-libs/phonon-4.11.0
- activities? ( >=kde-frameworks/kactivities-${KFMIN}:5 )
+ >=media-libs/phonon-4.11.0[qt5(+)]
+ activities? ( >=kde-plasma/plasma-activities-${KFMIN}:5 )
semantic-desktop? (
>=kde-apps/baloo-widgets-${PVCUT}:5
>=kde-frameworks/baloo-${KFMIN}:5
>=kde-frameworks/kfilemetadata-${KFMIN}:5
)
- telemetry? ( dev-libs/kuserfeedback:5 )
+ telemetry? ( kde-frameworks/kuserfeedback:5 )
"
RDEPEND="${DEPEND}
- >=kde-apps/kio-extras-${PVCUT}:5
+ || (
+ kde-apps/kio-extras-kf5:5
+ >=kde-apps/kio-extras-${PVCUT}:5
+ )
"
+PATCHES=( "${FILESDIR}/${P}-musl.patch" )
+
src_configure() {
local mycmakeargs=(
-DCMAKE_DISABLE_FIND_PACKAGE_PackageKitQt5=ON
diff --git a/kde-apps/dolphin/dolphin-24.02.2.ebuild b/kde-apps/dolphin/dolphin-24.02.2.ebuild
new file mode 100644
index 000000000000..c69ad4d6aaa8
--- /dev/null
+++ b/kde-apps/dolphin/dolphin-24.02.2.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_HANDBOOK="optional"
+ECM_TEST="true"
+PVCUT=$(ver_cut 1-3)
+KFMIN=6.0.0
+QTMIN=6.6.2
+inherit ecm gear.kde.org optfeature
+
+DESCRIPTION="Plasma filemanager focusing on usability"
+HOMEPAGE="https://apps.kde.org/dolphin/ https://userbase.kde.org/Dolphin"
+
+LICENSE="GPL-2" # TODO: CHECK
+SLOT="6"
+KEYWORDS="~amd64"
+IUSE="activities semantic-desktop telemetry"
+
+# slot op: Uses Qt::GuiPrivate for qtx11extras_p.h
+DEPEND="
+ >=dev-qt/qtbase-${QTMIN}:6=[concurrent,dbus,gui,widgets,xml]
+ >=kde-frameworks/kbookmarks-${KFMIN}:6
+ >=kde-frameworks/kcmutils-${KFMIN}:6
+ >=kde-frameworks/kcodecs-${KFMIN}:6
+ >=kde-frameworks/kcompletion-${KFMIN}:6
+ >=kde-frameworks/kconfig-${KFMIN}:6
+ >=kde-frameworks/kconfigwidgets-${KFMIN}:6
+ >=kde-frameworks/kcoreaddons-${KFMIN}:6
+ >=kde-frameworks/kcrash-${KFMIN}:6
+ >=kde-frameworks/kdbusaddons-${KFMIN}:6
+ >=kde-frameworks/ki18n-${KFMIN}:6
+ >=kde-frameworks/kiconthemes-${KFMIN}:6
+ >=kde-frameworks/kio-${KFMIN}:6=
+ >=kde-frameworks/kitemviews-${KFMIN}:6
+ >=kde-frameworks/kjobwidgets-${KFMIN}:6
+ >=kde-frameworks/knewstuff-${KFMIN}:6
+ >=kde-frameworks/knotifications-${KFMIN}:6
+ >=kde-frameworks/kparts-${KFMIN}:6
+ >=kde-frameworks/kservice-${KFMIN}:6
+ >=kde-frameworks/ktextwidgets-${KFMIN}:6
+ >=kde-frameworks/kwidgetsaddons-${KFMIN}:6
+ >=kde-frameworks/kwindowsystem-${KFMIN}:6
+ >=kde-frameworks/kxmlgui-${KFMIN}:6
+ >=kde-frameworks/solid-${KFMIN}:6
+ >=media-libs/phonon-4.12.0[qt6]
+ activities? ( kde-plasma/plasma-activities:6 )
+ semantic-desktop? (
+ >=kde-apps/baloo-widgets-${PVCUT}:6
+ >=kde-frameworks/baloo-${KFMIN}:6
+ >=kde-frameworks/kfilemetadata-${KFMIN}:6
+ )
+ telemetry? ( >=kde-frameworks/kuserfeedback-${KFMIN}:6 )
+"
+RDEPEND="${DEPEND}
+ >=kde-apps/kio-extras-${PVCUT}:6
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_DISABLE_FIND_PACKAGE_PackageKitQt6=ON
+ $(cmake_use_find_package activities PlasmaActivities)
+ $(cmake_use_find_package semantic-desktop KF6Baloo)
+ $(cmake_use_find_package semantic-desktop KF6BalooWidgets)
+ $(cmake_use_find_package semantic-desktop KF6FileMetaData)
+ $(cmake_use_find_package telemetry KF6UserFeedback)
+ )
+ ecm_src_configure
+}
+
+src_test() {
+ local myctestargs=(
+ # servicemenuinstaller requires ruby, no thanks
+ # dolphinmainwindowtest, kitemlistcontrollertest, kfileitemlistviewtest, kfileitemmodeltest hang forever
+ # placesitemmodeltest requires DBus
+ -E "(servicemenuinstaller|dolphinmainwindowtest|kfileitemlistviewtest|kfileitemmodeltest|kitemlistcontrollertest|placesitemmodeltest)"
+ )
+ ecm_src_test
+}
+
+pkg_postinst() {
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ optfeature "compress/extract and other actions" "kde-apps/ark:${SLOT}"
+ optfeature "crypto actions" "kde-apps/kleopatra:${SLOT}"
+ optfeature "video file thumbnails" "kde-apps/ffmpegthumbs:${SLOT}"
+ optfeature "graphics file thumbnails" "kde-apps/thumbnailers:${SLOT}"
+ optfeature "'Share' context menu actions" "kde-frameworks/purpose:${SLOT}"
+ fi
+ ecm_pkg_postinst
+}
diff --git a/kde-apps/dolphin/files/dolphin-23.08.5-musl.patch b/kde-apps/dolphin/files/dolphin-23.08.5-musl.patch
new file mode 100644
index 000000000000..044a0caef830
--- /dev/null
+++ b/kde-apps/dolphin/files/dolphin-23.08.5-musl.patch
@@ -0,0 +1,64 @@
+From 32a5f1c041d00cdd0246cf7e764a447588f30f3a Mon Sep 17 00:00:00 2001
+From: Bart Ribbers <bribbers@disroot.org>
+Date: Wed, 9 Aug 2023 14:07:46 +0200
+Subject: [PATCH] Fix musl build by using fts_* from external library
+
+musl does not support fts. There is however a standalone package that
+can be used, but it must be linked against. This commit adds a check
+that makes sure to link to the external library if it is required.
+---
+ CMakeLists.txt | 17 +++++++++++++++++
+ src/CMakeLists.txt | 2 ++
+ 2 files changed, 19 insertions(+)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 8a0b97c635..0a655babb3 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -27,6 +27,8 @@ include(GenerateExportHeader)
+ include(FeatureSummary)
+ include(ECMQtDeclareLoggingCategory)
+ include(ECMDeprecationSettings)
++include(CheckIncludeFiles)
++include(CheckLibraryExists)
+
+ ecm_setup_version(${RELEASE_SERVICE_VERSION} VARIABLE_PREFIX DOLPHIN
+ VERSION_HEADER "${CMAKE_CURRENT_BINARY_DIR}/src/dolphin_version.h"
+@@ -150,6 +152,21 @@ else()
+ set(HAVE_TERMINAL TRUE)
+ endif()
+
++# Compatibility with platforms without native fts (e.g. musl)
++check_include_files("sys/types.h;sys/stat.h;fts.h" HAVE_FTS_H)
++if(HAVE_FTS_H)
++ check_function_exists(fts_open HAVE_FTS_OPEN)
++ if(NOT HAVE_FTS_OPEN)
++ check_library_exists(fts fts_open "" HAVE_LIB_FTS)
++ endif()
++endif()
++
++if(HAVE_LIB_FTS)
++ set(FTS_LIB fts)
++else()
++ set(FTS_LIB "")
++endif()
++
+ add_subdirectory(src)
+ add_subdirectory(doc)
+
+diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
+index 5a481e39ff..fa7de5cc23 100644
+--- a/src/CMakeLists.txt
++++ b/src/CMakeLists.txt
+@@ -213,6 +213,8 @@ target_link_libraries(
+ KF5::WindowSystem
+ KF5::WidgetsAddons
+ KF5::Codecs
++
++ ${FTS_LIB}
+ )
+
+ if(HAVE_BALOO)
+--
+GitLab
+