summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-apps/kdepim-common-libs/files/kdepim-common-libs-install-headers.patch')
-rw-r--r--kde-apps/kdepim-common-libs/files/kdepim-common-libs-install-headers.patch86
1 files changed, 86 insertions, 0 deletions
diff --git a/kde-apps/kdepim-common-libs/files/kdepim-common-libs-install-headers.patch b/kde-apps/kdepim-common-libs/files/kdepim-common-libs-install-headers.patch
new file mode 100644
index 000000000000..f0037beac4cd
--- /dev/null
+++ b/kde-apps/kdepim-common-libs/files/kdepim-common-libs-install-headers.patch
@@ -0,0 +1,86 @@
+Install headers needed by Kopete's cryptography plugin.
+
+Patch borrowed from Fedora.
+
+diff --git a/libkleo/CMakeLists.txt b/libkleo/CMakeLists.txt
+index 84e660f..bfb92f8 100644
+--- a/libkleo/CMakeLists.txt
++++ b/libkleo/CMakeLists.txt
+@@ -124,3 +124,61 @@ install ( FILES libkleopatrarc-win32.desktop DESTINATION ${CONFIG_INSTALL_DIR} R
+ else ()
+ install ( FILES libkleopatrarc.desktop DESTINATION ${CONFIG_INSTALL_DIR} RENAME libkleopatrarc )
+ endif ()
++
++install( FILES
++ kleo/kleo_export.h
++ kleo/enum.h
++ kleo/oidmap.h
++ kleo/cryptobackend.h
++ kleo/cryptobackendfactory.h
++ kleo/cryptoconfig.h
++ kleo/dn.h
++ kleo/job.h
++ kleo/keylistjob.h
++ kleo/keygenerationjob.h
++ kleo/abstractimportjob.h
++ kleo/importjob.h
++ kleo/importfromkeyserverjob.h
++ kleo/exportjob.h
++ kleo/changeexpiryjob.h
++ kleo/changeownertrustjob.h
++ kleo/downloadjob.h
++ kleo/deletejob.h
++ kleo/encryptjob.h
++ kleo/decryptjob.h
++ kleo/signjob.h
++ kleo/specialjob.h
++ kleo/verifydetachedjob.h
++ kleo/verifyopaquejob.h
++ kleo/decryptverifyjob.h
++ kleo/signencryptjob.h
++ kleo/signkeyjob.h
++ kleo/adduseridjob.h
++ kleo/refreshkeysjob.h
++ kleo/multideletejob.h
++ kleo/hierarchicalkeylistjob.h
++ kleo/keyfilter.h
++ kleo/keyfiltermanager.h
++ kleo/changepasswdjob.h
++ kleo/checksumdefinition.h
++ kleo/exception.h
++ kleo/kconfigbasedkeyfilter.h
++ kleo/listallkeysjob.h
++ kleo/stl_util.h
++ DESTINATION ${INCLUDE_INSTALL_DIR}/kleo COMPONENT Devel)
++
++install ( FILES
++ ui/kdhorizontalline.h
++ ui/messagebox.h
++ ui/progressbar.h
++ ui/progressdialog.h
++ ui/keylistview.h
++ ui/keyselectiondialog.h
++ ui/keyrequester.h
++ ui/keyapprovaldialog.h
++ ui/dnattributeorderconfigwidget.h
++ ui/cryptoconfigmodule.h
++ ui/cryptoconfigdialog.h
++ ui/directoryserviceswidget.h
++ ui/filenamerequester.h
++ DESTINATION ${INCLUDE_INSTALL_DIR}/kleo/ui COMPONENT Devel)
+diff --git a/libkpgp/CMakeLists.txt b/libkpgp/CMakeLists.txt
+index 4be58ba..de868ad 100644
+--- a/libkpgp/CMakeLists.txt
++++ b/libkpgp/CMakeLists.txt
+@@ -35,3 +35,11 @@ add_subdirectory( tests )
+ install(FILES kconf_update/kpgp.upd DESTINATION ${KCONF_UPDATE_INSTALL_DIR})
+ install(PROGRAMS kconf_update/kpgp-3.1-upgrade-address-data.pl DESTINATION ${KCONF_UPDATE_INSTALL_DIR})
+
++install(FILES
++ kpgp.h
++ kpgpbase.h
++ kpgpblock.h
++ kpgpkey.h
++ kpgpui.h
++ libkpgp_export.h
++ DESTINATION ${INCLUDE_INSTALL_DIR}/kpgp COMPONENT Devel )