summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-apps/kmailtransport')
-rw-r--r--kde-apps/kmailtransport/Manifest1
-rw-r--r--kde-apps/kmailtransport/kmailtransport-18.04.0.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/kde-apps/kmailtransport/Manifest b/kde-apps/kmailtransport/Manifest
index 2adbdda15da6..53748533097d 100644
--- a/kde-apps/kmailtransport/Manifest
+++ b/kde-apps/kmailtransport/Manifest
@@ -1 +1,2 @@
DIST kmailtransport-17.12.3.tar.xz 164804 BLAKE2B 79b2e5d28429c777f1b6f205a950109bf8f16310eb8e6700079a9e28c4876398e813406376aefbecef5565caf0d75262bef700f1a69ee59dff393ce93d10d18f SHA512 a90d305a0ca9e938c0629ac602862307f1561280cd8f90159e0d9eab48bc8e3ad67208a04db724bae5e8b5edb08ff7901843c86f3d6ab3b5a2d7092de127d513
+DIST kmailtransport-18.04.0.tar.xz 164516 BLAKE2B 39b12ab209f6bae09c49cd9f679c54e6f6a5b95daf7ad471c1aea04cc3508273cc9e248a164ec4a5143426d9dce7db3ba29a1e700c7ecf2a024e27937b83df30 SHA512 7f3195ade7c958071e35a992a26fcec2d308c59d0005bf5e56faff91411b725f42b919639a4f6c9f3029a7435fdf43f2251289ddcccb52a6778206124adce91c
diff --git a/kde-apps/kmailtransport/kmailtransport-18.04.0.ebuild b/kde-apps/kmailtransport/kmailtransport-18.04.0.ebuild
new file mode 100644
index 000000000000..5814e89ef59e
--- /dev/null
+++ b/kde-apps/kmailtransport/kmailtransport-18.04.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+KDE_TEST="true"
+inherit kde5
+
+DESCRIPTION="Mail transport service"
+LICENSE="LGPL-2.1+"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+COMMON_DEPEND="
+ $(add_frameworks_dep kcmutils)
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kwallet)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_kdeapps_dep akonadi)
+ $(add_kdeapps_dep akonadi-mime)
+ $(add_kdeapps_dep kmime)
+ $(add_kdeapps_dep ksmtp)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtnetwork)
+ $(add_qt_dep qtwidgets)
+"
+DEPEND="${COMMON_DEPEND}
+ test? ( $(add_frameworks_dep ktextwidgets) )
+"
+RDEPEND="${COMMON_DEPEND}
+ !kde-apps/kdepim-l10n
+ !kde-apps/kdepimlibs:4
+"
+
+RESTRICT+=" test"