summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-apps/kopete')
-rw-r--r--kde-apps/kopete/Manifest1
-rw-r--r--kde-apps/kopete/kopete-17.08.2.ebuild159
2 files changed, 160 insertions, 0 deletions
diff --git a/kde-apps/kopete/Manifest b/kde-apps/kopete/Manifest
index 151629498a27..7afcad2bf8d1 100644
--- a/kde-apps/kopete/Manifest
+++ b/kde-apps/kopete/Manifest
@@ -1,2 +1,3 @@
DIST kopete-17.04.3.tar.xz 6343664 SHA256 ec48462a464ce9ab724f503813311d9dd3aafc0124972410ac2afe14133be43f SHA512 d9c2ccec7f72e68090cd72632884b86f6b5a9cdd7fd3d23c1dedf3fe0331296d0b750c48050b80f36a58b92815e240983ab2c96eebb18997235c2a22bc4d2b26 WHIRLPOOL 2dffbb43e2eb63aa008ede23322d223436310fc85df4d8d38eec12e6ee7fe3549689beffde4e66ab2a3892ce0433e677f8d913c5ba9d9498264ec2b525815dd3
DIST kopete-17.08.1.tar.xz 6343868 SHA256 56a1ef3078238d4becf8ec6fe6f8f850144ab402168bd0a2608e57a100e2cbc6 SHA512 0c853e65a86076cd7dfa3b7a6bbd09e7b2199998ed617c9c57902c877f733b0b4df0fa2ab5b40e31b9e2345200d770fbd2a9721abd30c4e887da86cca018aabc WHIRLPOOL ad5f3cf83c8db9ddac59de2a1512408701b7d995788fc3fa046803ed1e14067cdbdd56645eef0b69f8c66913ab1813af242df12aa92085ee436698a1d43ff935
+DIST kopete-17.08.2.tar.xz 6343636 SHA256 ab2ab319cf7806e7336e4964889da6f0aa1fd3b3a4a1b7f4d2e88be034167506 SHA512 dbf26d3a5ea7c6ace6b10fed7d77e980d9c916198c70c95bc23970838a576d42c0bc14aa6c8d4386b360211e296aa0f9d3b508491c64c1a7253d9eb709981b8c WHIRLPOOL 2eb2733f58da4dfbfa4b14328387e81c9eea4a3589a7f2aee700516c9fdc85e86d8799caef788afc1d63adcd7848e904af3e698ff852d7c10f7b5de3685eac92
diff --git a/kde-apps/kopete/kopete-17.08.2.ebuild b/kde-apps/kopete/kopete-17.08.2.ebuild
new file mode 100644
index 000000000000..1caf66440ded
--- /dev/null
+++ b/kde-apps/kopete/kopete-17.08.2.ebuild
@@ -0,0 +1,159 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+KDE_HANDBOOK="optional"
+QT3SUPPORT_REQUIRED="true"
+inherit kde4-base
+
+DESCRIPTION="KDE multi-protocol IM client"
+HOMEPAGE="https://kopete.kde.org https://www.kde.org/applications/internet/kopete"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug ssl v4l"
+
+# tests hang, last checked for 4.2.96
+RESTRICT+=" test"
+
+# Available plugins
+#
+# addbookmarks: NO DEPS
+# alias: NO DEPS (disabled upstream)
+# autoreplace: NO DEPS
+# contactnotes: NO DEPS
+# cryptography: kde-apps/libkleo:4
+# highlight: NO DEPS
+# history: NO DEPS
+# latex: virtual/latex as RDEPEND
+# nowlistening: NO DEPS
+# otr: libotr
+# pipes: NO DEPS
+# privacy: NO DEPS
+# statistics: dev-db/sqlite:3
+# texteffect: NO DEPS
+# translator: NO DEPS
+# urlpicpreview: NO DEPS
+# webpresence: libxml2 libxslt
+# NOTE: By default we enable all plugins that don't have any dependencies
+PLUGINS="+addbookmarks +autoreplace +contactnotes cryptography +highlight
++history latex +nowlistening otr +pipes +privacy +statistics +texteffect
++translator +urlpicpreview webpresence"
+
+# Available protocols
+#
+# gadu: net-libs/libgadu @since 4.3
+# groupwise: app-crypt/qca:2
+# irc: NO DEPS, probably will fail so inform user about it
+# xmpp: net-dns/libidn app-crypt/qca:2 ENABLED BY DEFAULT NETWORK
+# jingle: media-libs/speex net-libs/ortp DISABLED BY UPSTREAM
+# meanwhile: net-libs/meanwhile
+# oscar: NO DEPS
+# telepathy: net-libs/decibel
+# testbed: NO DEPS
+# winpopup: NO DEPS (we're adding samba as RDEPEND so it works)
+# yahoo: media-libs/jasper
+# zeroconf (bonjour): NO DEPS
+PROTOCOLS="gadu groupwise jingle meanwhile oscar skype
+testbed winpopup +xmpp yahoo zeroconf"
+
+# disabled protocols
+# telepathy: net-libs/decibel
+# irc: NO DEPS
+# msn: net-libs/libmsn
+# qq: NO DEPS
+
+IUSE="${IUSE} ${PLUGINS} ${PROTOCOLS}"
+
+COMMONDEPEND="
+ $(add_kdeapps_dep kdepimlibs '' 4.14.10_p20160611)
+ dev-libs/libpcre
+ >=dev-qt/qtgui-4.4.0:4[mng]
+ kde-frameworks/kdelibs:4[zeroconf?]
+ media-libs/phonon[qt4]
+ media-libs/qimageblitz[-qt5(-)]
+ x11-libs/libX11
+ x11-libs/libXScrnSaver
+ cryptography? ( $(add_kdeapps_dep libkleo '' 4.4.2016.01-r1) )
+ gadu? ( >=net-libs/libgadu-1.8.0[threads] )
+ groupwise? ( app-crypt/qca:2[qt4(+)] )
+ jingle? (
+ dev-libs/expat
+ dev-libs/openssl:0
+ >=media-libs/mediastreamer-2.3.0
+ net-libs/libsrtp:=
+ net-libs/ortp:=
+ )
+ meanwhile? ( net-libs/meanwhile )
+ otr? ( >=net-libs/libotr-4.0.0 )
+ statistics? ( dev-db/sqlite:3 )
+ v4l? ( media-libs/libv4l )
+ webpresence? (
+ dev-libs/libxml2
+ dev-libs/libxslt
+ )
+ xmpp? (
+ app-crypt/qca:2[qt4(+)]
+ dev-libs/qjson
+ net-dns/libidn
+ sys-libs/zlib
+ )
+ yahoo? ( media-libs/jasper )
+"
+RDEPEND="${COMMONDEPEND}
+ !=kde-apps/kdepimlibs-4.14.11_pre20160211*
+ jingle? ( media-libs/speex )
+ latex? (
+ virtual/imagemagick-tools
+ virtual/latex-base
+ )
+ ssl? ( app-crypt/qca:2[ssl] )
+ winpopup? ( net-fs/samba )
+"
+DEPEND="${COMMONDEPEND}
+ x11-proto/scrnsaverproto
+ jingle? ( dev-libs/jsoncpp )
+"
+
+PATCHES=( "${FILESDIR}/${PN}-17.04.0-kde4qgpgme.patch" )
+
+src_configure() {
+ local x x2
+ # Handle common stuff
+ local mycmakeargs=(
+ -DWITH_LiboRTP=$(usex jingle)
+ -DWITH_Mediastreamer=$(usex jingle)
+ -DDISABLE_VIDEOSUPPORT=$(usex !v4l)
+ )
+ # enable protocols
+ for x in ${PROTOCOLS}; do
+ case ${x/+/} in
+ jingle) x2=libjingle ;;
+ xmpp) x2=jabber ;;
+ zeroconf) x2=bonjour ;;
+ *) x2=${x/+/} ;;
+ esac
+ mycmakeargs+=( -DWITH_${x2}=$(usex ${x/+/}) )
+ done
+
+ mycmakeargs+=( -DWITH_Libmsn=OFF -DWITH_qq=OFF -DWITH_sms=OFF )
+
+ # enable plugins
+ for x in ${PLUGINS}; do
+ mycmakeargs+=( -DWITH_${x/+/}=$(usex ${x/+/}) )
+ done
+
+ kde4-base_src_configure
+}
+
+pkg_postinst() {
+ kde4-base_pkg_postinst
+
+ if ! use ssl; then
+ if use xmpp ; then # || use irc; then
+ if ! has_version "app-crypt/qca:2[ssl]" ; then
+ elog "In order to use ssl in xmpp you'll need to"
+ elog "install app-crypt/qca package with USE=ssl."
+ fi
+ fi
+ fi
+}