summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-frameworks/extra-cmake-modules')
-rw-r--r--kde-frameworks/extra-cmake-modules/Manifest4
-rw-r--r--kde-frameworks/extra-cmake-modules/extra-cmake-modules-5.115.0.ebuild70
-rw-r--r--kde-frameworks/extra-cmake-modules/extra-cmake-modules-5.77.0.ebuild78
-rw-r--r--kde-frameworks/extra-cmake-modules/extra-cmake-modules-5.79.0.ebuild78
-rw-r--r--kde-frameworks/extra-cmake-modules/extra-cmake-modules-6.1.0.ebuild70
-rw-r--r--kde-frameworks/extra-cmake-modules/files/extra-cmake-modules-5.112.0-disable-tests-requiring-PyQt5.patch27
-rw-r--r--kde-frameworks/extra-cmake-modules/files/extra-cmake-modules-5.245.0-disable-qmlplugindump.patch43
-rw-r--r--kde-frameworks/extra-cmake-modules/files/extra-cmake-modules-5.93.0-disable-qmlplugindump.patch (renamed from kde-frameworks/extra-cmake-modules/files/extra-cmake-modules-5.74.0-disable-qmlplugindump.patch)55
-rw-r--r--kde-frameworks/extra-cmake-modules/files/extra-cmake-modules-5.93.0-skip-ecm_add_test-early.patch (renamed from kde-frameworks/extra-cmake-modules/files/extra-cmake-modules-5.72.0-skip-ecm_add_test-early.patch)28
-rw-r--r--kde-frameworks/extra-cmake-modules/metadata.xml11
10 files changed, 271 insertions, 193 deletions
diff --git a/kde-frameworks/extra-cmake-modules/Manifest b/kde-frameworks/extra-cmake-modules/Manifest
index aa9db8b3a38e..29ab50ec462d 100644
--- a/kde-frameworks/extra-cmake-modules/Manifest
+++ b/kde-frameworks/extra-cmake-modules/Manifest
@@ -1,2 +1,2 @@
-DIST extra-cmake-modules-5.77.0.tar.xz 353784 BLAKE2B 08f70ab68fa1de0a8014fffb5a5f638fc49ea4d17a68de4a2061746bc95218235e18066d865ed12c746deb2212f61299675fefc4c89b2ed9d48e675925904f5e SHA512 0581b3f8f17ad452140a68e9d1b14014235523ecc2df2b6a8e6a6b3cac99a1b58470b8d31ae2eb695c1e5357d4c5ff26d656bf2f4ede7aba824eaed1e38a3a95
-DIST extra-cmake-modules-5.79.0.tar.xz 356596 BLAKE2B eb74d5be7b19831f26158a86c050952282276e0e0b75156ca81efc82adfc3472bdad9c011deda126b9d5f488671386caf87b4f243484b8ce768cdceca701ee4c SHA512 755d6a52d648fa471f18356f2efdb380397c66e69023da5859bec5d5c66f66d22636550bf3e99cbc5f2b2ab9274ac28219bf4f71a8a464a0b9761024181ea3f1
+DIST extra-cmake-modules-5.115.0.tar.xz 332504 BLAKE2B e76e2dcd990f95cb96f9ae049c0a22e05d3eb9d87e419ff80b4e5f2f2adb06f6fc9f09c69101f1e9155d6c31c4062eafe5d3c90ac94f3cc95f80ea889f0965c8 SHA512 53c44d8ccb58266bdf72014467cd57de86acb89ba272f1fb09f80af1c858a442cb59347fbff95cb3188c14a5cc520f9e952d1b396f2c5f2ed99aa070beacac22
+DIST extra-cmake-modules-6.1.0.tar.xz 341972 BLAKE2B 95a39b94d1e16bb78e6f6ce290baf2801d3eee7eaafa2f2c45ec6276cfa83916a5894aab7ea3bf7e96c5fb270e1b8b35562bcbfdd4228b8677d080b093e1d650 SHA512 8e31c576e461de927b5f9ff7a0f6c368f95b66c721ef1fb810ae2f2e6ea486e0fe23766023c223c65c2a3cacc62466f0e38d6353c65cfa1db5a7f55f4e3a5820
diff --git a/kde-frameworks/extra-cmake-modules/extra-cmake-modules-5.115.0.ebuild b/kde-frameworks/extra-cmake-modules/extra-cmake-modules-5.115.0.ebuild
new file mode 100644
index 000000000000..b3f9beee0ee6
--- /dev/null
+++ b/kde-frameworks/extra-cmake-modules/extra-cmake-modules-5.115.0.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+QTMIN=5.15.9
+inherit cmake frameworks.kde.org python-any-r1
+
+DESCRIPTION="Extra modules and scripts for CMake"
+HOMEPAGE="https://invent.kde.org/frameworks/extra-cmake-modules"
+
+LICENSE="BSD"
+KEYWORDS="amd64 arm arm64 ~hppa ~loong ppc ppc64 ~riscv x86"
+IUSE="doc test"
+
+RESTRICT="!test? ( test )"
+
+RDEPEND="app-arch/libarchive[bzip2]"
+BDEPEND="
+ doc? (
+ ${PYTHON_DEPS}
+ $(python_gen_any_dep 'dev-python/sphinx[${PYTHON_USEDEP}]')
+ >=dev-qt/qthelp-${QTMIN}:5
+ )
+ test? (
+ >=dev-qt/linguist-tools-${QTMIN}:5
+ >=dev-qt/qtcore-${QTMIN}:5
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-5.49.0-no-fatal-warnings.patch"
+ "${FILESDIR}/${PN}-5.93.0-skip-ecm_add_test-early.patch"
+ "${FILESDIR}/${PN}-5.93.0-disable-qmlplugindump.patch"
+ "${FILESDIR}/${PN}-5.112.0-disable-tests-requiring-PyQt5.patch" # bug 680256
+)
+
+python_check_deps() {
+ python_has_version "dev-python/sphinx[${PYTHON_USEDEP}]"
+}
+
+pkg_setup() {
+ use doc && python-any-r1_pkg_setup
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DDOC_INSTALL_DIR=/usr/share/doc/"${PF}"
+ -DBUILD_QTHELP_DOCS=$(usex doc)
+ -DBUILD_HTML_DOCS=$(usex doc)
+ -DBUILD_MAN_DOCS=$(usex doc)
+ -DBUILD_TESTING=$(usex test)
+ )
+
+ cmake_src_configure
+}
+
+src_test() {
+ local CMAKE_SKIP_TESTS=(
+ # passes, but then breaks src_install
+ ECMToolchainAndroidTest
+ # broken, bug #627806
+ ECMPoQmToolsTest
+ # can not possibly succeed in releases, bug #764953
+ KDEFetchTranslations
+ )
+ # possible race condition with multiple jobs, bug #701854
+ cmake_src_test -j1
+}
diff --git a/kde-frameworks/extra-cmake-modules/extra-cmake-modules-5.77.0.ebuild b/kde-frameworks/extra-cmake-modules/extra-cmake-modules-5.77.0.ebuild
deleted file mode 100644
index 1f1a776db327..000000000000
--- a/kde-frameworks/extra-cmake-modules/extra-cmake-modules-5.77.0.ebuild
+++ /dev/null
@@ -1,78 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7,8,9} )
-QTMIN=5.15.1
-inherit cmake kde.org python-any-r1
-
-DESCRIPTION="Extra modules and scripts for CMake"
-HOMEPAGE="https://invent.kde.org/frameworks/extra-cmake-modules"
-
-LICENSE="BSD"
-KEYWORDS="amd64 ~arm arm64 ~hppa ppc ppc64 x86"
-IUSE="doc test"
-
-BDEPEND="
- doc? (
- ${PYTHON_DEPS}
- $(python_gen_any_dep 'dev-python/sphinx[${PYTHON_USEDEP}]')
- >=dev-qt/qthelp-${QTMIN}:5
- )
- test? (
- >=dev-qt/linguist-tools-${QTMIN}:5
- >=dev-qt/qtcore-${QTMIN}:5
- )
-"
-RDEPEND="
- app-arch/libarchive[bzip2]
-"
-
-RESTRICT+=" !test? ( test )"
-
-PATCHES=(
- "${FILESDIR}/${PN}-5.49.0-no-fatal-warnings.patch"
- "${FILESDIR}/${PN}-5.72.0-skip-ecm_add_test-early.patch"
- "${FILESDIR}/${PN}-5.74.0-disable-qmlplugindump.patch"
-)
-
-python_check_deps() {
- has_version "dev-python/sphinx[${PYTHON_USEDEP}]"
-}
-
-pkg_setup() {
- use doc && python-any-r1_pkg_setup
-}
-
-src_prepare() {
- cmake_src_prepare
- # Requires PyQt5, bug #680256
- sed -i -e "/^if(NOT SIP_Qt5Core_Mod_FILE)/s/NOT SIP_Qt5Core_Mod_FILE/TRUE/" \
- tests/CMakeLists.txt || die "failed to disable GenerateSipBindings tests"
-}
-
-src_configure() {
- local mycmakeargs=(
- -DDOC_INSTALL_DIR=/usr/share/doc/"${PF}"
- -DBUILD_QTHELP_DOCS=$(usex doc)
- -DBUILD_HTML_DOCS=$(usex doc)
- -DBUILD_MAN_DOCS=$(usex doc)
- -DBUILD_TESTING=$(usex test)
- )
-
- cmake_src_configure
-}
-
-src_test() {
- # ECMToolchainAndroidTest passes but then breaks src_install
- # ECMPoQmToolsTest is broken, bug #627806
- # KDEFetchTranslations can not possibly succeed in releases, bug #764953
- # possible race condition with multiple jobs, bug #701854
- local myctestargs=(
- -j1
- -E "(ECMToolchainAndroidTest|ECMPoQmToolsTest|KDEFetchTranslations)"
- )
-
- cmake_src_test
-}
diff --git a/kde-frameworks/extra-cmake-modules/extra-cmake-modules-5.79.0.ebuild b/kde-frameworks/extra-cmake-modules/extra-cmake-modules-5.79.0.ebuild
deleted file mode 100644
index 6bd09789c613..000000000000
--- a/kde-frameworks/extra-cmake-modules/extra-cmake-modules-5.79.0.ebuild
+++ /dev/null
@@ -1,78 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7,8,9} )
-QTMIN=5.15.2
-inherit cmake kde.org python-any-r1
-
-DESCRIPTION="Extra modules and scripts for CMake"
-HOMEPAGE="https://invent.kde.org/frameworks/extra-cmake-modules"
-
-LICENSE="BSD"
-KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86"
-IUSE="doc test"
-
-RESTRICT+=" !test? ( test )"
-
-BDEPEND="
- doc? (
- ${PYTHON_DEPS}
- $(python_gen_any_dep 'dev-python/sphinx[${PYTHON_USEDEP}]')
- >=dev-qt/qthelp-${QTMIN}:5
- )
- test? (
- >=dev-qt/linguist-tools-${QTMIN}:5
- >=dev-qt/qtcore-${QTMIN}:5
- )
-"
-RDEPEND="
- app-arch/libarchive[bzip2]
-"
-
-PATCHES=(
- "${FILESDIR}/${PN}-5.49.0-no-fatal-warnings.patch"
- "${FILESDIR}/${PN}-5.72.0-skip-ecm_add_test-early.patch"
- "${FILESDIR}/${PN}-5.74.0-disable-qmlplugindump.patch"
-)
-
-python_check_deps() {
- has_version "dev-python/sphinx[${PYTHON_USEDEP}]"
-}
-
-pkg_setup() {
- use doc && python-any-r1_pkg_setup
-}
-
-src_prepare() {
- cmake_src_prepare
- # Requires PyQt5, bug #680256
- sed -i -e "/^if(NOT SIP_Qt5Core_Mod_FILE)/s/NOT SIP_Qt5Core_Mod_FILE/TRUE/" \
- tests/CMakeLists.txt || die "failed to disable GenerateSipBindings tests"
-}
-
-src_configure() {
- local mycmakeargs=(
- -DDOC_INSTALL_DIR=/usr/share/doc/"${PF}"
- -DBUILD_QTHELP_DOCS=$(usex doc)
- -DBUILD_HTML_DOCS=$(usex doc)
- -DBUILD_MAN_DOCS=$(usex doc)
- -DBUILD_TESTING=$(usex test)
- )
-
- cmake_src_configure
-}
-
-src_test() {
- # ECMToolchainAndroidTest passes but then breaks src_install
- # ECMPoQmToolsTest is broken, bug #627806
- # KDEFetchTranslations can not possibly succeed in releases, bug #764953
- # possible race condition with multiple jobs, bug #701854
- local myctestargs=(
- -j1
- -E "(ECMToolchainAndroidTest|ECMPoQmToolsTest|KDEFetchTranslations)"
- )
-
- cmake_src_test
-}
diff --git a/kde-frameworks/extra-cmake-modules/extra-cmake-modules-6.1.0.ebuild b/kde-frameworks/extra-cmake-modules/extra-cmake-modules-6.1.0.ebuild
new file mode 100644
index 000000000000..ecb22352a8b3
--- /dev/null
+++ b/kde-frameworks/extra-cmake-modules/extra-cmake-modules-6.1.0.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+QTMIN=6.6.2
+inherit cmake frameworks.kde.org python-any-r1
+
+DESCRIPTION="Extra modules and scripts for CMake"
+HOMEPAGE="https://invent.kde.org/frameworks/extra-cmake-modules"
+
+LICENSE="BSD"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~loong ~ppc ~ppc64 ~riscv ~x86"
+IUSE="doc test"
+
+RESTRICT="!test? ( test )"
+
+RDEPEND="app-arch/libarchive[bzip2]"
+BDEPEND="
+ doc? (
+ ${PYTHON_DEPS}
+ $(python_gen_any_dep 'dev-python/sphinx[${PYTHON_USEDEP}]')
+ >=dev-qt/qttools-${QTMIN}:6[assistant]
+ )
+ test? (
+ >=dev-qt/qttools-${QTMIN}:6[linguist]
+ >=dev-qt/qtbase-${QTMIN}:6
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-5.49.0-no-fatal-warnings.patch"
+ "${FILESDIR}/${PN}-5.93.0-skip-ecm_add_test-early.patch"
+ "${FILESDIR}/${PN}-5.112.0-disable-tests-requiring-PyQt5.patch" # bug 680256
+ "${FILESDIR}/${PN}-5.245.0-disable-qmlplugindump.patch"
+)
+
+python_check_deps() {
+ python_has_version "dev-python/sphinx[${PYTHON_USEDEP}]"
+}
+
+pkg_setup() {
+ use doc && python-any-r1_pkg_setup
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DDOC_INSTALL_DIR=/usr/share/doc/"${PF}"
+ -DBUILD_QTHELP_DOCS=$(usex doc)
+ -DBUILD_HTML_DOCS=$(usex doc)
+ -DBUILD_MAN_DOCS=$(usex doc)
+ -DBUILD_TESTING=$(usex test)
+ )
+
+ cmake_src_configure
+}
+
+src_test() {
+ local CMAKE_SKIP_TESTS=(
+ # passes, but then breaks src_install
+ ECMToolchainAndroidTest
+ # broken, bug #627806
+ ECMPoQmToolsTest
+ # can not possibly succeed in releases, bug #764953
+ KDEFetchTranslations
+ )
+ # possible race condition with multiple jobs, bug #701854
+ cmake_src_test -j1
+}
diff --git a/kde-frameworks/extra-cmake-modules/files/extra-cmake-modules-5.112.0-disable-tests-requiring-PyQt5.patch b/kde-frameworks/extra-cmake-modules/files/extra-cmake-modules-5.112.0-disable-tests-requiring-PyQt5.patch
new file mode 100644
index 000000000000..17d60448056f
--- /dev/null
+++ b/kde-frameworks/extra-cmake-modules/files/extra-cmake-modules-5.112.0-disable-tests-requiring-PyQt5.patch
@@ -0,0 +1,27 @@
+From 35d209b5662e468aa2f613ffdb9b91bc2e7f7e26 Mon Sep 17 00:00:00 2001
+From: Andreas Sturmlechner <asturm@gentoo.org>
+Date: Sat, 18 Nov 2023 17:58:36 +0100
+Subject: [PATCH] Disable tests requiring PyQt5
+
+Gentoo-bug: https://bugs.gentoo.org/680256
+Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
+---
+ tests/CMakeLists.txt | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
+index 1415bb91..09d998e4 100644
+--- a/tests/CMakeLists.txt
++++ b/tests/CMakeLists.txt
+@@ -79,7 +79,7 @@ find_file(SIP_Qt5Core_Mod_FILE
+ PATH_SUFFIXES share/sip/PyQt5/QtCore
+ )
+
+-if(NOT SIP_Qt5Core_Mod_FILE)
++if(TRUE)
+ message(STATUS "WARNING: skipping tests that require PyQt")
+ else()
+ find_package(PythonModuleGeneration)
+--
+2.42.1
+
diff --git a/kde-frameworks/extra-cmake-modules/files/extra-cmake-modules-5.245.0-disable-qmlplugindump.patch b/kde-frameworks/extra-cmake-modules/files/extra-cmake-modules-5.245.0-disable-qmlplugindump.patch
new file mode 100644
index 000000000000..a684745d3965
--- /dev/null
+++ b/kde-frameworks/extra-cmake-modules/files/extra-cmake-modules-5.245.0-disable-qmlplugindump.patch
@@ -0,0 +1,43 @@
+From 528cdf38261239d8475e2a3e82dd1b5cb73c770b Mon Sep 17 00:00:00 2001
+From: Andreas Sturmlechner <asturm@gentoo.org>
+Date: Sun, 8 Dec 2019 15:01:33 +0100
+Subject: [PATCH] ECMFindQMLModule.cmake.in: Add ECM_DISABLE_QMLPLUGINDUMP to
+ avoid sandbox violations
+
+See also: https://phabricator.kde.org/D25812
+
+Backstory: https://bugzilla.gnome.org/show_bug.cgi?id=744135
+BUG: 387753
+---
+ modules/ECMFindQmlModule.cmake.in | 8 ++++++++
+ 1 file changed, 8 insertions(+)
+
+diff --git a/modules/ECMFindQmlModule.cmake.in b/modules/ECMFindQmlModule.cmake.in
+index 3da55ced..46e8b0ce 100644
+--- a/modules/ECMFindQmlModule.cmake.in
++++ b/modules/ECMFindQmlModule.cmake.in
+@@ -9,6 +9,13 @@ include(FindPackageHandleStandardArgs)
+ include("${ECM_MODULE_DIR}/QtVersionOption.cmake")
+ include("${ECM_MODULE_DIR}/ECMQueryQt.cmake")
+
++option (ECM_DISABLE_QMLPLUGINDUMP "Do not use qmlplugindump which may segfault in some sandboxed environments" OFF)
++
++if(ECM_DISABLE_QMLPLUGINDUMP)
++ message(NOTICE "@GENMODULE@: qmlplugindump disabled - assuming dependency is available as >= @VERSION@.")
++ set(@GENMODULE@_FOUND TRUE)
++ set(@GENMODULE@_VERSION @VERSION@)
++else()
+ if (QT_MAJOR_VERSION EQUAL "6")
+ include(${ECM_MODULE_DIR}/ECMQmlModule.cmake)
+ # Get the qmldir file
+@@ -68,6 +75,7 @@ if (NOT CMAKE_CROSSCOMPILING AND NOT MODULE_NOTFOUND AND NOT @GENMODULE@_FOUND)
+ set(@GENMODULE@_FOUND FALSE)
+ endif()
+ endif()
++endif()
+
+ set(@GENMODULE@_FOUND ${@GENMODULE@_FOUND} PARENT_SCOPE)
+ set(@GENMODULE@_VERSION ${@GENMODULE@_VERSION} PARENT_SCOPE)
+--
+2.42.1
+
diff --git a/kde-frameworks/extra-cmake-modules/files/extra-cmake-modules-5.74.0-disable-qmlplugindump.patch b/kde-frameworks/extra-cmake-modules/files/extra-cmake-modules-5.93.0-disable-qmlplugindump.patch
index 08fcf32338b6..06406a7eaf6d 100644
--- a/kde-frameworks/extra-cmake-modules/files/extra-cmake-modules-5.74.0-disable-qmlplugindump.patch
+++ b/kde-frameworks/extra-cmake-modules/files/extra-cmake-modules-5.93.0-disable-qmlplugindump.patch
@@ -1,33 +1,39 @@
-From 8d30a7dd4517130bf1f6904b0969aaa78e44e16b Mon Sep 17 00:00:00 2001
+From 1c79ef2189dc156bbe0f182411bcc136f140a21d Mon Sep 17 00:00:00 2001
From: Andreas Sturmlechner <asturm@gentoo.org>
Date: Sun, 8 Dec 2019 15:01:33 +0100
Subject: [PATCH] ECMFindQMLModule.cmake.in: Add ECM_DISABLE_QMLPLUGINDUMP to
avoid sandbox violations
-Back story: https://bugzilla.gnome.org/show_bug.cgi?id=744135
+See also: https://phabricator.kde.org/D25812
+
+Backstory: https://bugzilla.gnome.org/show_bug.cgi?id=744136
BUG: 387753
---
- modules/ECMFindQMLModule.cmake.in | 35 +++++++++++++++++++------------
- 1 file changed, 22 insertions(+), 13 deletions(-)
+ modules/ECMFindQmlModule.cmake.in | 45 ++++++++++++++++++-------------
+ 1 file changed, 27 insertions(+), 18 deletions(-)
-diff --git a/modules/ECMFindQMLModule.cmake.in b/modules/ECMFindQMLModule.cmake.in
-index 8109ab8..1edc01d 100644
---- a/modules/ECMFindQMLModule.cmake.in
-+++ b/modules/ECMFindQMLModule.cmake.in
-@@ -26,23 +26,32 @@
- #=============================================================================
-
+diff --git a/modules/ECMFindQmlModule.cmake.in b/modules/ECMFindQmlModule.cmake.in
+index 0ee5665e..d6e1f14c 100644
+--- a/modules/ECMFindQmlModule.cmake.in
++++ b/modules/ECMFindQmlModule.cmake.in
+@@ -7,27 +7,36 @@
include(FindPackageHandleStandardArgs)
--include("${ECM_MODULE_DIR}/ECMQueryQmake.cmake")
+ include("${ECM_MODULE_DIR}/QtVersionOption.cmake")
--query_qmake(qt_binaries_dir QT_INSTALL_BINS)
-+option (ECM_DISABLE_QMLPLUGINDUMP "Do not use qmlplugindump which may segfault in some sandboxed environments" OFF)
-
--find_program(QMLPLUGINDUMP_PROGRAM NAMES qmlplugindump HINTS ${qt_binaries_dir})
+-if (QT_MAJOR_VERSION EQUAL "5")
+- include("${ECM_MODULE_DIR}/ECMQueryQt.cmake")
+- ecm_query_qt(qt_binaries_dir QT_HOST_BINS)
+- find_program(QMLPLUGINDUMP_PROGRAM NAMES qmlplugindump HINTS ${qt_binaries_dir})
+-elseif (QT_MAJOR_VERSION EQUAL "6")
+- find_package(Qt6 COMPONENTS QmlTools REQUIRED)
+- get_target_property(QMLPLUGINDUMP_PROGRAM Qt6::qmlplugindump LOCATION)
+-endif()
+-
-if(NOT QMLPLUGINDUMP_PROGRAM)
- message(WARNING "Could not find qmlplugindump. It is necessary to look up qml module dependencies.")
-endif()
--
++option (ECM_DISABLE_QMLPLUGINDUMP "Do not use qmlplugindump which may segfault in some sandboxed environments" OFF)
+
-execute_process(COMMAND "${QMLPLUGINDUMP_PROGRAM}" "@MODULE_NAME@" "@VERSION@" ERROR_VARIABLE ERRORS_OUTPUT OUTPUT_VARIABLE DISREGARD_VARIABLE RESULT_VARIABLE ExitCode TIMEOUT 30)
-
-if(ExitCode EQUAL 0)
@@ -39,16 +45,21 @@ index 8109ab8..1edc01d 100644
else()
- message(STATUS "qmlplugindump failed for @MODULE_NAME@.")
- set(@GENMODULE@_FOUND FALSE)
-+ include("${ECM_MODULE_DIR}/ECMQueryQmake.cmake")
+
-+ query_qmake(qt_binaries_dir QT_INSTALL_BINS)
++ if (QT_MAJOR_VERSION EQUAL "5")
++ include("${ECM_MODULE_DIR}/ECMQueryQt.cmake")
++ ecm_query_qt(qt_binaries_dir QT_HOST_BINS)
++ find_program(QMLPLUGINDUMP_PROGRAM NAMES qmlplugindump HINTS ${qt_binaries_dir})
++ elseif (QT_MAJOR_VERSION EQUAL "6")
++ find_package(Qt6 COMPONENTS QmlTools REQUIRED)
++ get_target_property(QMLPLUGINDUMP_PROGRAM Qt6::qmlplugindump LOCATION)
++ endif()
+
-+ find_program(QMLPLUGINDUMP_PROGRAM NAMES qmlplugindump HINTS ${qt_binaries_dir})
+ if(NOT QMLPLUGINDUMP_PROGRAM)
+ message(WARNING "Could not find qmlplugindump. It is necessary to look up qml module dependencies.")
+ endif()
+
-+ execute_process(COMMAND "${QMLPLUGINDUMP_PROGRAM}" "@MODULE_NAME@" "@VERSION@" ERROR_VARIABLE ERRORS_OUTPUT OUTPUT_VARIABLE DISREGARD_VARIABLE RESULT_VARIABLE ExitCode)
++ execute_process(COMMAND "${QMLPLUGINDUMP_PROGRAM}" "@MODULE_NAME@" "@VERSION@" ERROR_VARIABLE ERRORS_OUTPUT OUTPUT_VARIABLE DISREGARD_VARIABLE RESULT_VARIABLE ExitCode TIMEOUT 30)
+
+ if(ExitCode EQUAL 0)
+ set(@GENMODULE@_FOUND TRUE)
@@ -61,5 +72,5 @@ index 8109ab8..1edc01d 100644
find_package_handle_standard_args(@GENMODULE@
--
-2.24.0
+2.35.1
diff --git a/kde-frameworks/extra-cmake-modules/files/extra-cmake-modules-5.72.0-skip-ecm_add_test-early.patch b/kde-frameworks/extra-cmake-modules/files/extra-cmake-modules-5.93.0-skip-ecm_add_test-early.patch
index 72541d73e72e..84e192919c78 100644
--- a/kde-frameworks/extra-cmake-modules/files/extra-cmake-modules-5.72.0-skip-ecm_add_test-early.patch
+++ b/kde-frameworks/extra-cmake-modules/files/extra-cmake-modules-5.93.0-skip-ecm_add_test-early.patch
@@ -1,7 +1,8 @@
-From ad3aec71ed7f8820e69fe55489368a19d0735ab5 Mon Sep 17 00:00:00 2001
+From 36e435f059ee44da78e6900fded348709ea865df Mon Sep 17 00:00:00 2001
From: Andreas Sturmlechner <asturm@gentoo.org>
Date: Sat, 11 Jul 2020 23:04:16 +0200
-Subject: [PATCH] ECMAddTests.cmake: Skip ecm_add_test early if Qt5::Test is not available
+Subject: [PATCH] ECMAddTests.cmake: Skip ecm_add_test early if Qt::Test is not
+ available
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
---
@@ -10,26 +11,26 @@ Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
2 files changed, 14 insertions(+)
diff --git a/modules/ECMAddTests.cmake b/modules/ECMAddTests.cmake
-index 4bc7fb8..12825aa 100644
+index 58c78d05..994ed1e4 100644
--- a/modules/ECMAddTests.cmake
+++ b/modules/ECMAddTests.cmake
-@@ -81,6 +81,10 @@ function(ecm_add_test)
+@@ -84,6 +84,10 @@ function(ecm_add_test)
message(FATAL_ERROR "ecm_add_test() called with multiple source files but without setting \"TEST_NAME\"")
endif()
-+ if(NOT TARGET Qt5::Test)
++ if(NOT TARGET Qt::Test)
+ return()
+ endif()
+
set(_testname ${ARG_NAME_PREFIX}${_targetname})
set(gui_args)
if(ARG_GUI)
-@@ -122,6 +126,11 @@ function(ecm_add_tests)
+@@ -127,6 +131,11 @@ function(ecm_add_tests)
endif()
set(test_names)
set(target_names)
+
-+ if(NOT TARGET Qt5::Test)
++ if(NOT TARGET Qt::Test)
+ return()
+ endif()
+
@@ -37,12 +38,15 @@ index 4bc7fb8..12825aa 100644
ecm_add_test(${_test_source}
NAME_PREFIX ${ARG_NAME_PREFIX}
diff --git a/tests/ECMAddTests/CMakeLists.txt b/tests/ECMAddTests/CMakeLists.txt
-index e77b33f..4e191fe 100644
+index aa7e73a1..f9fb10cb 100644
--- a/tests/ECMAddTests/CMakeLists.txt
+++ b/tests/ECMAddTests/CMakeLists.txt
-@@ -1,3 +1,8 @@
-+if(NOT TARGET Qt5::Test)
-+ message(STATUS "WARNING: skipping tests that require Qt5::Test")
+@@ -4,6 +4,11 @@ else()
+ set(QT_VERSION_OPT "-DBUILD_WITH_QT6=OFF")
+ endif()
+
++if(NOT TARGET Qt::Test)
++ message(STATUS "WARNING: skipping tests that require Qt::Test")
+ return()
+endif()
+
@@ -50,5 +54,5 @@ index e77b33f..4e191fe 100644
string(REPLACE "." "/" dir "${NAME}")
string(REGEX REPLACE "[^.]*\\." "" proj "${NAME}")
--
-2.27.0
+2.35.1
diff --git a/kde-frameworks/extra-cmake-modules/metadata.xml b/kde-frameworks/extra-cmake-modules/metadata.xml
index ce744e04eafa..465dd12c5a8d 100644
--- a/kde-frameworks/extra-cmake-modules/metadata.xml
+++ b/kde-frameworks/extra-cmake-modules/metadata.xml
@@ -1,9 +1,18 @@
<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="project">
<email>kde@gentoo.org</email>
<name>Gentoo KDE Project</name>
</maintainer>
+ <upstream>
+ <bugs-to>https://bugs.kde.org/</bugs-to>
+ <remote-id type="kde-invent">frameworks/extra-cmake-modules</remote-id>
+ </upstream>
+ <slots>
+ <subslots>
+ Must only be used by packages that are known to use private parts of the Frameworks API.
+ </subslots>
+ </slots>
<stabilize-allarches/>
</pkgmetadata>