summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-frameworks/purpose')
-rw-r--r--kde-frameworks/purpose/Manifest1
-rw-r--r--kde-frameworks/purpose/purpose-5.58.0.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/kde-frameworks/purpose/Manifest b/kde-frameworks/purpose/Manifest
index 1a7aa6d1f9fa..1e5b0342246b 100644
--- a/kde-frameworks/purpose/Manifest
+++ b/kde-frameworks/purpose/Manifest
@@ -1,2 +1,3 @@
DIST purpose-5.54.0.tar.xz 142684 BLAKE2B 51dd914668d05513bc325305ac6c23e083b3a18f070681db04149732362a81199fdae89f9e5b00d711a68465ba32fd0c0e41e75f2c175db266a1b07ef2be749d SHA512 548b42fee675f112dfa1d6fd8ab1c8944190417f3d27d7ebbce6826bb50bdc9c560b02c665a51d0ac5e37fcbf0778318a03bad31cae076dc6c53f2139786edbb
DIST purpose-5.57.0.tar.xz 145332 BLAKE2B 82b7afbc83e662c398f9e06bd79060ed28d71d67f0a74546385a230076d17e2d6e0b929929e1ca3ad1322952eb6b15ccf04fb07c0bafd873a1cbaf182a52f1ac SHA512 6a9bb0e19b4e147730fd8b0fb5116f51e9dd2d8bf74fa1b93e9758f3b776c4c1da9e7ff75d8871e28db52b016dbb3d6d1b8c3c046adbdc9c85c1cc1df74188e4
+DIST purpose-5.58.0.tar.xz 146024 BLAKE2B 3f42a33ca64378f34b173411074660ae8a094bad7d4c68a0287da8443a210743692b5e6393e763468ea7caaee512e8475096b0dcf5d8b356b1ad1e79cf023b2b SHA512 41a7c99b012c892680d786ce8f0aa982b79e814763847f86884e4c5a5f36bd925dd8f916b92f5786deafb6f22a5aa5af5bc39c1b73efdc9c58a6b9aab16ae026
diff --git a/kde-frameworks/purpose/purpose-5.58.0.ebuild b/kde-frameworks/purpose/purpose-5.58.0.ebuild
new file mode 100644
index 000000000000..37030099e575
--- /dev/null
+++ b/kde-frameworks/purpose/purpose-5.58.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+KDE_QTHELP="false"
+KDE_TEST="forceoptional"
+inherit kde5
+
+DESCRIPTION="Library for providing abstractions to get the developer's purposes fulfilled"
+LICENSE="LGPL-2.1+"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="+kaccounts"
+
+DEPEND="
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kio)
+ $(add_qt_dep qtdeclarative)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtnetwork)
+ $(add_qt_dep qtwidgets)
+ kaccounts? (
+ $(add_kdeapps_dep kaccounts-integration)
+ net-libs/accounts-qt
+ )
+"
+RDEPEND="${DEPEND}"
+
+# requires running environment
+RESTRICT+=" test"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package kaccounts KAccounts)
+ )
+
+ kde5_src_configure
+}
+
+pkg_postinst(){
+ kde5_pkg_postinst
+
+ if ! has_version "kde-misc/kdeconnect[app]" ; then
+ elog "Optional runtime dependency:"
+ elog "kde-misc/kdeconnect[app] (send through KDE Connect)"
+ fi
+}