summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-misc/about-distro/about-distro-1.1.0.ebuild')
-rw-r--r--kde-misc/about-distro/about-distro-1.1.0.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/kde-misc/about-distro/about-distro-1.1.0.ebuild b/kde-misc/about-distro/about-distro-1.1.0.ebuild
new file mode 100644
index 000000000000..bb66b8695723
--- /dev/null
+++ b/kde-misc/about-distro/about-distro-1.1.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+KDE_LINGUAS="bg bs ca cs da de el es fi fr gl hu ja ko lt nl pl pt pt_BR ro ru
+sk sl sv tr ug uk"
+inherit kde4-base
+
+DESCRIPTION="KCM displaying distribution and system information"
+HOMEPAGE="https://projects.kde.org/projects/playground/base/about-distro"
+SRC_URI="http://www.gentoo.org/images/glogo-small.png"
+
+if [[ ${KDE_BUILD_TYPE} != live ]]; then
+ SRC_URI+=" mirror://kde/stable/${PN}/${PV}/src/${P}.tar.xz"
+ KEYWORDS="~amd64 ~x86"
+else
+ EGIT_REPO_URI="git://anongit.kde.org/${PN}"
+ KEYWORDS=""
+fi
+
+LICENSE="GPL-3"
+SLOT="4"
+IUSE="debug"
+
+RDEPEND="${DEPEND}
+ sys-apps/lsb-release
+"
+
+src_install() {
+ kde4-base_src_install
+
+ insinto /usr/share/config
+ doins "${FILESDIR}"/kcm-about-distrorc
+
+ insinto /usr/share/${PN}
+ doins "${DISTDIR}"/glogo-small.png
+}