summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-misc/homerun/homerun-1.2.5.ebuild')
-rw-r--r--kde-misc/homerun/homerun-1.2.5.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/kde-misc/homerun/homerun-1.2.5.ebuild b/kde-misc/homerun/homerun-1.2.5.ebuild
new file mode 100644
index 000000000000..6208921e0cdc
--- /dev/null
+++ b/kde-misc/homerun/homerun-1.2.5.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+DECLARATIVE_REQUIRED="always"
+VIRTUALX_REQUIRED="test"
+VIRTUALDBUS_TEST="true"
+KDE_LINGUAS="ca ca@valencia cs da de el es fi fr gl hu it nl pl pt pt_BR ro sk
+sl sv tr uk zh_CN"
+KDE_MINIMAL="4.10"
+inherit kde4-base
+
+DESCRIPTION="Application launcher for KDE Plasma desktop"
+HOMEPAGE="https://projects.kde.org/projects/playground/base/homerun"
+[[ ${PV} == *9999 ]] || SRC_URI="mirror://kde/stable/${PN}/src/${P}.tar.xz"
+
+LICENSE="GPL-2 LGPL-2.1 BSD"
+KEYWORDS="~amd64 ~x86"
+SLOT="4"
+IUSE="debug"
+
+DEPEND="
+ $(add_kdeapps_dep libkonq)
+ $(add_kdebase_dep libkworkspace)
+"
+RDEPEND="
+ ${DEPEND}
+ $(add_kdebase_dep plasma-workspace)
+"
+
+# Fails 2 out of 6, check later again.
+# With virtualx/virtualdbus it hangs
+RESTRICT="test"