summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-misc/kio-gdrive/kio-gdrive-1.2.0.ebuild')
-rw-r--r--kde-misc/kio-gdrive/kio-gdrive-1.2.0.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/kde-misc/kio-gdrive/kio-gdrive-1.2.0.ebuild b/kde-misc/kio-gdrive/kio-gdrive-1.2.0.ebuild
new file mode 100644
index 000000000000..7842a1f824b8
--- /dev/null
+++ b/kde-misc/kio-gdrive/kio-gdrive-1.2.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+KDE_APPS_MINIMAL="17.04.0"
+KDE_HANDBOOK="true"
+KDE_TEST="optional"
+inherit kde5
+
+DESCRIPTION="KIO Slave for Google Drive service"
+HOMEPAGE="https://phabricator.kde.org/project/profile/72/"
+
+if [[ ${KDE_BUILD_TYPE} != live ]] ; then
+ SRC_URI="mirror://kde/stable/${PN}/${PV}/src/${P}.tar.xz"
+ KEYWORDS="~amd64"
+fi
+
+IUSE="+kaccounts"
+
+RDEPEND="
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep knotifications)
+ $(add_kdeapps_dep libkgapi)
+ $(add_qt_dep qtwidgets)
+ kaccounts? ( $(add_kdeapps_dep kaccounts-integration) )
+ !kaccounts? ( dev-libs/qtkeychain:=[qt5] )
+"
+DEPEND="${RDEPEND}
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtnetwork)
+"
+
+DOCS=( README.md )
+
+PATCHES=( "${FILESDIR}/${P}-tests-optional.patch" )
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package kaccounts KAccounts)
+ )
+ kde5_src_configure
+}