summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-misc/ktoshiba/ktoshiba-5.3.1.ebuild')
-rw-r--r--kde-misc/ktoshiba/ktoshiba-5.3.1.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/kde-misc/ktoshiba/ktoshiba-5.3.1.ebuild b/kde-misc/ktoshiba/ktoshiba-5.3.1.ebuild
new file mode 100644
index 000000000000..b9226a147640
--- /dev/null
+++ b/kde-misc/ktoshiba/ktoshiba-5.3.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit kde5
+
+DESCRIPTION="Function key (FN) monitoring for Toshiba laptops"
+HOMEPAGE="http://ktoshiba.sourceforge.net/"
+SRC_URI="http://prdownloads.sourceforge.net/${PN}/${P}.tar.xz"
+LICENSE="GPL-2"
+
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="
+ $(add_frameworks_dep kauth)
+ $(add_frameworks_dep kcmutils)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kdbusaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep knotifications)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtwidgets)
+ net-libs/libmnl
+"
+
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DLIBMNL_INCLUDE_DIRS=/usr/include/libmnl
+ )
+ kde5_src_configure
+}