summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-plasma/kscreenlocker')
-rw-r--r--kde-plasma/kscreenlocker/Manifest1
-rw-r--r--kde-plasma/kscreenlocker/kscreenlocker-5.12.2.ebuild96
-rw-r--r--kde-plasma/kscreenlocker/metadata.xml3
3 files changed, 100 insertions, 0 deletions
diff --git a/kde-plasma/kscreenlocker/Manifest b/kde-plasma/kscreenlocker/Manifest
index fcc34df4e7d2..d758c48f5e34 100644
--- a/kde-plasma/kscreenlocker/Manifest
+++ b/kde-plasma/kscreenlocker/Manifest
@@ -1,2 +1,3 @@
DIST kscreenlocker-5.11.5.tar.xz 125528 BLAKE2B 32bad30682da09245cc567f3cb79c0e0fd4ffdba26b47ef0c49c3094374503640cab7718033cb9c366ef7acddb6180995f4121b61ed1d04bbd867e1361e9d7ea SHA512 20eefbb4f970b2476d3df2e36bf74021d854f0ba61cba4946b3fc7190cff9edc9fef753d3bdde24ab135cc0dc5ad826cb22063db7b12ce817007355a98a3011a
DIST kscreenlocker-5.12.1.tar.xz 118452 BLAKE2B 1a8eb4742f026af8ce9ab81b63adc37df192cb1c6f66a014d807641e8d40b126664f7e1a0a0c3812975730398ab4aa634ff186a1aab34d13b8086ffdd358a2eb SHA512 e3895c1792f630fe0c8b73910629c0b141c179557eb8da7216564fadbfead659a4eb0b4fdc872054def8e5a6a9c68c27a19e65ec5256cb871b33b7c08d384e46
+DIST kscreenlocker-5.12.2.tar.xz 118448 BLAKE2B 4c70334369d1f2fbf39a3b6e5c02e7fc71f922b0a18985d3e7598aca7f1209d735993412b1b2aad85ba2b622260896498a198c57e49d9aa4deecc5f82b7dba0d SHA512 cb293d69bc56fc3b2cde20b4088277a8d578896429dae2f66a8496ebb8750c23a32d56dcecad047d5a9a9180fa1c3a1a42ad12943fc937a009dcd8be4e7e08c3
diff --git a/kde-plasma/kscreenlocker/kscreenlocker-5.12.2.ebuild b/kde-plasma/kscreenlocker/kscreenlocker-5.12.2.ebuild
new file mode 100644
index 000000000000..000589de4b14
--- /dev/null
+++ b/kde-plasma/kscreenlocker/kscreenlocker-5.12.2.ebuild
@@ -0,0 +1,96 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+KDE_TEST="forceoptional"
+VIRTUALX_REQUIRED="test"
+inherit kde5 pam
+
+DESCRIPTION="Library and components for secure lock screen architecture"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="consolekit +pam seccomp"
+
+REQUIRED_USE="seccomp? ( pam )"
+
+COMMON_DEPEND="
+ $(add_frameworks_dep kcmutils)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kcrash)
+ $(add_frameworks_dep kdeclarative)
+ $(add_frameworks_dep kglobalaccel)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kidletime)
+ $(add_frameworks_dep knotifications)
+ $(add_frameworks_dep kpackage)
+ $(add_frameworks_dep ktextwidgets)
+ $(add_frameworks_dep kwayland)
+ $(add_frameworks_dep kwindowsystem)
+ $(add_frameworks_dep kxmlgui)
+ $(add_frameworks_dep solid)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtdeclarative 'widgets')
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtnetwork)
+ $(add_qt_dep qtwidgets)
+ $(add_qt_dep qtx11extras)
+ dev-libs/wayland
+ x11-libs/libX11
+ x11-libs/libXi
+ x11-libs/libxcb
+ x11-libs/xcb-util-keysyms
+ pam? ( virtual/pam )
+ seccomp? ( sys-libs/libseccomp )
+"
+DEPEND="${COMMON_DEPEND}
+ x11-proto/xproto
+"
+RDEPEND="${COMMON_DEPEND}
+ $(add_plasma_dep kde-cli-tools)
+ !<kde-plasma/kcheckpass-4.11.22-r1:4
+ !kde-plasma/kdebase-pam:0
+"
+
+RESTRICT+=" test"
+
+src_prepare() {
+ kde5_src_prepare
+
+ use consolekit && eapply "${FILESDIR}"/${PN}-consolekit-unlock.patch
+
+ use test || sed -i \
+ -e "/add_subdirectory(autotests)/ s/^/#/" greeter/CMakeLists.txt || die
+}
+
+src_test() {
+ # requires running environment
+ local myctestargs=(
+ -E x11LockerTest
+ )
+ kde5_src_test
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DPAM_REQUIRED=$(usex pam)
+ $(cmake-utils_use_find_package pam PAM)
+ $(cmake-utils_use_find_package seccomp Seccomp)
+ )
+ kde5_src_configure
+}
+
+src_install() {
+ kde5_src_install
+
+ newpamd "${FILESDIR}/kde.pam" kde
+ newpamd "${FILESDIR}/kde-np.pam" kde-np
+
+ use consolekit && dobin "${FILESDIR}"/ck-unlock-session
+
+ if ! use pam; then
+ chown root "${ED}"usr/$(get_libdir)/libexec/kcheckpass || die
+ chmod +s "${ED}"usr/$(get_libdir)/libexec/kcheckpass || die
+ fi
+}
diff --git a/kde-plasma/kscreenlocker/metadata.xml b/kde-plasma/kscreenlocker/metadata.xml
index 2fdbf33d963d..099a76f8dd86 100644
--- a/kde-plasma/kscreenlocker/metadata.xml
+++ b/kde-plasma/kscreenlocker/metadata.xml
@@ -5,4 +5,7 @@
<email>kde@gentoo.org</email>
<name>Gentoo KDE Project</name>
</maintainer>
+ <use>
+ <flag name="consolekit">Add support for killing the screenlocker when <pkg>sys-auth/consolekit</pkg> is the session tracker</flag>
+ </use>
</pkgmetadata>