summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-plasma/kwayland-server/kwayland-server-5.19.2.ebuild')
-rw-r--r--kde-plasma/kwayland-server/kwayland-server-5.19.2.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/kde-plasma/kwayland-server/kwayland-server-5.19.2.ebuild b/kde-plasma/kwayland-server/kwayland-server-5.19.2.ebuild
new file mode 100644
index 000000000000..47988e2d21dc
--- /dev/null
+++ b/kde-plasma/kwayland-server/kwayland-server-5.19.2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ECM_QTHELP="true"
+ECM_TEST="true"
+KFMIN=5.71.0
+PVCUT=$(ver_cut 1-2)
+QTMIN=5.14.2
+inherit ecm kde.org
+
+DESCRIPTION="Wayland Server Components built on KDE Frameworks"
+HOMEPAGE="https://invent.kde.org/plasma/kwayland-server"
+
+LICENSE="LGPL-2.1"
+SLOT="5"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+IUSE=""
+
+RDEPEND="
+ >=dev-libs/wayland-1.15.0
+ >=dev-qt/qtconcurrent-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5[egl]
+ >=dev-qt/qtwayland-${QTMIN}:5
+ >=kde-frameworks/kwayland-${KFMIN}:5
+ media-libs/mesa[egl]
+"
+DEPEND="${RDEPEND}
+ dev-libs/plasma-wayland-protocols
+ >=dev-libs/wayland-protocols-1.15
+"
+
+# All failing, I guess we need a virtual wayland server
+RESTRICT+=" test"