summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-plasma/plasma-integration')
-rw-r--r--kde-plasma/plasma-integration/Manifest1
-rw-r--r--kde-plasma/plasma-integration/plasma-integration-5.6.3.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/kde-plasma/plasma-integration/Manifest b/kde-plasma/plasma-integration/Manifest
index 32e7f6d0911b..078d0983a2a4 100644
--- a/kde-plasma/plasma-integration/Manifest
+++ b/kde-plasma/plasma-integration/Manifest
@@ -1 +1,2 @@
DIST plasma-integration-5.6.2.tar.xz 51188 SHA256 429ddc48da319652323bca842d8350248ce6dfd6eb4d4bad5c4b97289754f347 SHA512 da444d5645c30633728946b1c1977b2720887c8487200ff52cdb8855558d52195383f09257b4b28a45cbd7063d6b678e875047836402fb285c87950458d9bbf0 WHIRLPOOL bcdf5027b74e1c563a5c4efcf6a9b00fa602002606d40671eef4f4cef6f2c3326617951fea460034b070f2139ee5895142a24ede3cb2198f2f2223ec031e6b45
+DIST plasma-integration-5.6.3.tar.xz 51548 SHA256 1c87482631e489ca1d16450b7a7c62f43eac9a4f517e8458d6104f448d16a673 SHA512 9e6585e2e688ae1d67b846a90d001735e7afa04723066a944aa7827a661c4bc7c1c7c2b648e2ab126702b387cde5ac530870403f8b3139313431fb690b5f908c WHIRLPOOL c3179f426f0086561cbce3aa26af3db3e8c0381b8e37d97d5449849a0b6a2359219da42b2e725364ac8365351969dab0bfef4fed30cf9543ec71c1a091146834
diff --git a/kde-plasma/plasma-integration/plasma-integration-5.6.3.ebuild b/kde-plasma/plasma-integration/plasma-integration-5.6.3.ebuild
new file mode 100644
index 000000000000..e124da2aaa23
--- /dev/null
+++ b/kde-plasma/plasma-integration/plasma-integration-5.6.3.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+DESCRIPTION="Qt Platform Theme integration plugins for the Plasma workspaces"
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+DEPEND="
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kjobwidgets)
+ $(add_frameworks_dep knotifications)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kxmlgui)
+ $(add_plasma_dep kwayland)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtgui '' '' '5=')
+ $(add_qt_dep qtwidgets)
+ $(add_qt_dep qtx11extras)
+ x11-libs/libXcursor
+"
+RDEPEND="${DEPEND}
+ $(add_plasma_dep oxygen-fonts '' 5.4.3)
+ media-fonts/noto
+"
+
+# requires running kde environment
+RESTRICT="test"