summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'lxde-base/lxlauncher/lxlauncher-0.2.5-r1.ebuild')
-rw-r--r--lxde-base/lxlauncher/lxlauncher-0.2.5-r1.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/lxde-base/lxlauncher/lxlauncher-0.2.5-r1.ebuild b/lxde-base/lxlauncher/lxlauncher-0.2.5-r1.ebuild
new file mode 100644
index 000000000000..e472c53f384c
--- /dev/null
+++ b/lxde-base/lxlauncher/lxlauncher-0.2.5-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Open source clone of the Asus launcher for EeePC"
+HOMEPAGE="https://wiki.lxde.org/en/LXLauncher"
+SRC_URI="mirror://sourceforge/lxde/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="
+ dev-libs/glib:2
+ gnome-base/gnome-menus
+ lxde-base/menu-cache
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf:2
+ x11-libs/gtk+:3
+ x11-libs/libX11
+ x11-libs/startup-notification
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+src_configure() {
+ econf \
+ --enable-gtk3
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc AUTHORS ChangeLog README
+}