summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'lxde-base/lxtask/lxtask-0.1.4.ebuild')
-rw-r--r--lxde-base/lxtask/lxtask-0.1.4.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/lxde-base/lxtask/lxtask-0.1.4.ebuild b/lxde-base/lxtask/lxtask-0.1.4.ebuild
new file mode 100644
index 000000000000..d2e806714bf2
--- /dev/null
+++ b/lxde-base/lxtask/lxtask-0.1.4.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+inherit eutils autotools
+
+DESCRIPTION="LXDE Task manager"
+HOMEPAGE="http://lxde.sf.net/"
+SRC_URI="mirror://sourceforge/lxde/${P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~alpha amd64 arm ppc x86 ~arm-linux ~x86-linux"
+SLOT="0"
+IUSE=""
+
+RDEPEND="x11-libs/gtk+:2
+ dev-libs/glib:2"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ sys-devel/gettext
+ >=dev-util/intltool-0.40.0"
+
+src_prepare() {
+ # use new patch to remove broken linguas
+ epatch "${FILESDIR}"/${P}-remove-broken-linguas.patch
+ sed -e "s/AM_CONFIG_HEADER/AC_CONFIG_HEADERS/" -i configure.ac || die
+ eautoreconf
+}
+
+src_install () {
+ emake DESTDIR="${D}" install
+ dodoc AUTHORS README
+}