summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'lxqt-base/liblxqt-mount/liblxqt-mount-0.8.0.ebuild')
-rw-r--r--lxqt-base/liblxqt-mount/liblxqt-mount-0.8.0.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/lxqt-base/liblxqt-mount/liblxqt-mount-0.8.0.ebuild b/lxqt-base/liblxqt-mount/liblxqt-mount-0.8.0.ebuild
new file mode 100644
index 000000000000..eb1451d5baf9
--- /dev/null
+++ b/lxqt-base/liblxqt-mount/liblxqt-mount-0.8.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit cmake-utils
+
+DESCRIPTION="LXQt library for removable media and devices"
+HOMEPAGE="http://lxqt.org/"
+
+if [[ ${PV} = *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="git://git.lxde.org/git/lxde/${PN}.git"
+else
+ SRC_URI="http://downloads.lxqt.org/lxqt/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-2 LGPL-2.1+"
+SLOT="0"
+IUSE="+udisks"
+
+DEPEND="dev-qt/qtcore:5
+ dev-qt/qtdbus:5
+ dev-qt/qtgui:5
+ dev-qt/linguist-tools:5
+ ~lxqt-base/liblxqt-${PV}
+ x11-libs/libX11
+ virtual/udev"
+RDEPEND="${DEPEND}
+ udisks? ( sys-fs/udisks )"
+
+src_configure() {
+ local mycmakeargs=(
+ -DUSE_QT5=ON
+ )
+ cmake-utils_src_configure
+}