summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'lxqt-base/lxqt-notificationd')
-rw-r--r--lxqt-base/lxqt-notificationd/Manifest3
-rw-r--r--lxqt-base/lxqt-notificationd/lxqt-notificationd-0.7.0.ebuild31
-rw-r--r--lxqt-base/lxqt-notificationd/lxqt-notificationd-0.8.0.ebuild42
-rw-r--r--lxqt-base/lxqt-notificationd/lxqt-notificationd-0.9.0-r1.ebuild35
-rw-r--r--lxqt-base/lxqt-notificationd/lxqt-notificationd-0.9.0.ebuild35
-rw-r--r--lxqt-base/lxqt-notificationd/metadata.xml9
6 files changed, 155 insertions, 0 deletions
diff --git a/lxqt-base/lxqt-notificationd/Manifest b/lxqt-base/lxqt-notificationd/Manifest
new file mode 100644
index 000000000000..92c03de264b2
--- /dev/null
+++ b/lxqt-base/lxqt-notificationd/Manifest
@@ -0,0 +1,3 @@
+DIST lxqt-notificationd-0.7.0.tar.xz 38064 SHA256 bda7c841df4c4e340840877f83dc36188c52ffaff060c45b9e7f5b6f4075f11c SHA512 341a167fe7e5413d5e925cdfe7303efe255303c68f75bfa5a73808f566aee7cdfcc19bd52f4d623c7bf97c45020ffaa3fc9f65ae99c12a3199acfa8b287c1940 WHIRLPOOL 7f3ba04ac5c97224bf7a6193855245c6f879b0397a843a3f64d4de3dc3de8eb0546f92aa2ff8c0a28f4aaa87630ab3b42b6f8dec9e7468052c747018decd1c4a
+DIST lxqt-notificationd-0.8.0.tar.xz 38336 SHA256 720b6cca74ff5c0433b39feb3040cc25cd6fdcbdfe51186cefac7a42e157999b SHA512 83c32ea51fada6a0d9dadf8474942ad3896063e7b30ba68a663b5f568039bbd0c7ab6e4feaacc1dfa883cc4af431546003e00e6e632fefe34ac6b359e3bc2efd WHIRLPOOL eb4b38e6f7f5af652e612a78388dd37afedb569cc00b00279689642b3ebb888c174a244cf7fecf24afe0be35dadecf0755496006030cc4dbe690ae39db76f306
+DIST lxqt-notificationd-0.9.0.tar.xz 37052 SHA256 f33f8086319ed9d4cffddaed76925db5d79716e90d1112e5b124c95594a74b24 SHA512 b1280aef773fabc305d000def73dd7c8769992a80d9ef45bc87d3a2d805ba6caca30b9f50bd11eb4fb2e199fecb800133b8070f0313f54612b0691c5605825bf WHIRLPOOL ccd7a97447991f833aaf45a6ba1274711efe0d5ac6a03ed37e0a362b2c38ab97ac7f17e75dc395a48dfc0dff6389f7de7196dbcc9f56b43a6ddd746237e40562
diff --git a/lxqt-base/lxqt-notificationd/lxqt-notificationd-0.7.0.ebuild b/lxqt-base/lxqt-notificationd/lxqt-notificationd-0.7.0.ebuild
new file mode 100644
index 000000000000..964d531b304c
--- /dev/null
+++ b/lxqt-base/lxqt-notificationd/lxqt-notificationd-0.7.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit cmake-utils
+
+DESCRIPTION="LXQt notification daemon and library"
+HOMEPAGE="http://lxqt.org/"
+
+if [[ ${PV} = *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="git://git.lxde.org/git/lxde/${PN}.git"
+else
+ SRC_URI="http://downloads.lxqt.org/lxqt/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~x86"
+ S=${WORKDIR}
+fi
+
+LICENSE="GPL-2 LGPL-2.1+"
+SLOT="0"
+
+DEPEND="
+ ~dev-libs/libqtxdg-0.5.3
+ dev-qt/qtcore:4
+ dev-qt/qtdbus:4
+ dev-qt/qtgui:4
+ ~lxqt-base/liblxqt-${PV}
+ ~lxqt-base/lxqt-common-${PV}
+"
+RDEPEND="${DEPEND}"
diff --git a/lxqt-base/lxqt-notificationd/lxqt-notificationd-0.8.0.ebuild b/lxqt-base/lxqt-notificationd/lxqt-notificationd-0.8.0.ebuild
new file mode 100644
index 000000000000..ba4602b23777
--- /dev/null
+++ b/lxqt-base/lxqt-notificationd/lxqt-notificationd-0.8.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit cmake-utils
+
+DESCRIPTION="LXQt notification daemon and library"
+HOMEPAGE="http://lxqt.org/"
+
+if [[ ${PV} = *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="git://git.lxde.org/git/lxde/${PN}.git"
+else
+ SRC_URI="http://downloads.lxqt.org/lxqt/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-2 LGPL-2.1+"
+SLOT="0"
+
+DEPEND="
+ >=dev-libs/libqtxdg-1.0.0
+ dev-qt/linguist-tools:5
+ dev-qt/qtcore:5
+ dev-qt/qtdbus:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtx11extras:5
+ dev-qt/qtxml:5
+ ~lxqt-base/liblxqt-${PV}
+ ~lxqt-base/lxqt-common-${PV}
+ x11-libs/libX11
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DUSE_QT5=ON
+ )
+ cmake-utils_src_configure
+}
diff --git a/lxqt-base/lxqt-notificationd/lxqt-notificationd-0.9.0-r1.ebuild b/lxqt-base/lxqt-notificationd/lxqt-notificationd-0.9.0-r1.ebuild
new file mode 100644
index 000000000000..9ba7668dbeb6
--- /dev/null
+++ b/lxqt-base/lxqt-notificationd/lxqt-notificationd-0.9.0-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit cmake-utils
+
+DESCRIPTION="LXQt notification daemon and library"
+HOMEPAGE="http://lxqt.org/"
+
+if [[ ${PV} = *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="git://git.lxde.org/git/lxde/${PN}.git"
+else
+ SRC_URI="http://downloads.lxqt.org/lxqt/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+fi
+
+LICENSE="GPL-2 LGPL-2.1+"
+SLOT="0"
+
+DEPEND="
+ >=dev-libs/libqtxdg-1.0.0
+ dev-qt/linguist-tools:5
+ dev-qt/qtcore:5
+ dev-qt/qtdbus:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtx11extras:5
+ dev-qt/qtxml:5
+ kde-frameworks/kwindowsystem:5
+ ~lxqt-base/liblxqt-${PV}
+ =lxqt-base/lxqt-common-0.9*
+"
+RDEPEND="${DEPEND}"
diff --git a/lxqt-base/lxqt-notificationd/lxqt-notificationd-0.9.0.ebuild b/lxqt-base/lxqt-notificationd/lxqt-notificationd-0.9.0.ebuild
new file mode 100644
index 000000000000..990e0a7fe020
--- /dev/null
+++ b/lxqt-base/lxqt-notificationd/lxqt-notificationd-0.9.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit cmake-utils
+
+DESCRIPTION="LXQt notification daemon and library"
+HOMEPAGE="http://lxqt.org/"
+
+if [[ ${PV} = *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="git://git.lxde.org/git/lxde/${PN}.git"
+else
+ SRC_URI="http://downloads.lxqt.org/lxqt/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-2 LGPL-2.1+"
+SLOT="0"
+
+DEPEND="
+ >=dev-libs/libqtxdg-1.0.0
+ dev-qt/linguist-tools:5
+ dev-qt/qtcore:5
+ dev-qt/qtdbus:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtx11extras:5
+ dev-qt/qtxml:5
+ kde-frameworks/kwindowsystem:5
+ ~lxqt-base/liblxqt-${PV}
+ ~lxqt-base/lxqt-common-${PV}
+"
+RDEPEND="${DEPEND}"
diff --git a/lxqt-base/lxqt-notificationd/metadata.xml b/lxqt-base/lxqt-notificationd/metadata.xml
new file mode 100644
index 000000000000..d89dead0ed86
--- /dev/null
+++ b/lxqt-base/lxqt-notificationd/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>lxqt</herd>
+ <maintainer>
+ <email>jauhien@gentoo.org</email>
+ <name>Jauhien Piatlicki</name>
+ </maintainer>
+</pkgmetadata>