summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'lxqt-base/lxqt-runner/lxqt-runner-0.14.1.ebuild')
-rw-r--r--lxqt-base/lxqt-runner/lxqt-runner-0.14.1.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/lxqt-base/lxqt-runner/lxqt-runner-0.14.1.ebuild b/lxqt-base/lxqt-runner/lxqt-runner-0.14.1.ebuild
new file mode 100644
index 000000000000..ef371efaa311
--- /dev/null
+++ b/lxqt-base/lxqt-runner/lxqt-runner-0.14.1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake-utils
+
+DESCRIPTION="LXQt quick launcher"
+HOMEPAGE="https://lxqt.org/"
+
+MY_PV="$(ver_cut 1-2)*"
+
+if [[ ${PV} = *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/lxqt/${PN}.git"
+else
+ SRC_URI="https://downloads.lxqt.org/downloads/${PN}/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+fi
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+
+BDEPEND="
+ dev-qt/linguist-tools:5
+ >=dev-util/lxqt-build-tools-0.6.0
+ virtual/pkgconfig
+"
+DEPEND="
+ >=dev-cpp/muParser-2.2.3:=
+ >=dev-libs/libqtxdg-3.3.1
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtxml:5
+ kde-frameworks/kwindowsystem:5
+ >=lxde-base/menu-cache-0.5.1
+ =lxqt-base/liblxqt-${MY_PV}
+ =lxqt-base/lxqt-globalkeys-${MY_PV}
+"
+RDEPEND="${DEPEND}
+ !lxqt-base/lxqt-l10n
+"
+
+src_install(){
+ cmake-utils_src_install
+ doman man/*.1
+}