summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'lxqt-base/lxqt-runner/lxqt-runner-0.8.0.ebuild')
-rw-r--r--lxqt-base/lxqt-runner/lxqt-runner-0.8.0.ebuild50
1 files changed, 0 insertions, 50 deletions
diff --git a/lxqt-base/lxqt-runner/lxqt-runner-0.8.0.ebuild b/lxqt-base/lxqt-runner/lxqt-runner-0.8.0.ebuild
deleted file mode 100644
index 1be03f9faf3d..000000000000
--- a/lxqt-base/lxqt-runner/lxqt-runner-0.8.0.ebuild
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-inherit cmake-utils
-
-DESCRIPTION="LXQt quick launcher"
-HOMEPAGE="http://lxqt.org/"
-
-if [[ ${PV} = *9999* ]]; then
- inherit git-r3
- EGIT_REPO_URI="git://git.lxde.org/git/lxde/${PN}.git"
-else
- SRC_URI="http://downloads.lxqt.org/lxqt/${PV}/${P}.tar.xz"
- KEYWORDS="~amd64 ~x86"
-fi
-
-LICENSE="GPL-2 LGPL-2.1+"
-SLOT="0"
-
-RDEPEND="
- dev-libs/glib:2
- dev-qt/qtcore:5
- dev-qt/qtdbus:5
- dev-qt/qtscript:5
- dev-qt/qtgui:5
- dev-qt/qtwidgets:5
- dev-qt/qtx11extras:5
- dev-qt/qtxml:5
- ~lxqt-base/liblxqt-${PV}
- ~lxqt-base/lxqt-globalkeys-${PV}
- >=lxde-base/menu-cache-0.5.1
- >=dev-libs/libqtxdg-1.0.0
- x11-libs/libX11"
-DEPEND="${RDEPEND}
- dev-qt/linguist-tools:5
- virtual/pkgconfig"
-
-src_configure() {
- local mycmakeargs=(
- -DUSE_QT5=ON
- )
- cmake-utils_src_configure
-}
-
-src_install(){
- cmake-utils_src_install
- doman man/*.1
-}