summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'mail-client/balsa/balsa-2.5.3.ebuild')
-rw-r--r--mail-client/balsa/balsa-2.5.3.ebuild26
1 files changed, 3 insertions, 23 deletions
diff --git a/mail-client/balsa/balsa-2.5.3.ebuild b/mail-client/balsa/balsa-2.5.3.ebuild
index 73686addcb0e..901d051a0d70 100644
--- a/mail-client/balsa/balsa-2.5.3.ebuild
+++ b/mail-client/balsa/balsa-2.5.3.ebuild
@@ -13,9 +13,7 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="crypt gnome gtkhtml gnome-keyring kerberos ldap libnotify libressl rubrica
-spell sqlite webkit xface"
-REQUIRED_USE="gtkhtml? ( !webkit )"
+IUSE="crypt gnome gnome-keyring kerberos ldap libnotify libressl rubrica spell sqlite webkit xface"
# TODO: esmtp can be optional, do we want it?
RDEPEND="
@@ -30,7 +28,6 @@ RDEPEND="
crypt? ( >=app-crypt/gpgme-1.2.0:= )
gnome? ( >=x11-libs/gtksourceview-3.2.0:3.0 )
gnome-keyring? ( app-crypt/libsecret )
- gtkhtml? ( gnome-extra/gtkhtml:4.0 )
sqlite? ( >=dev-db/sqlite-2.8:= )
libnotify? ( >=x11-libs/libnotify-0.7:= )
!libressl? ( dev-libs/openssl:0= )
@@ -63,26 +60,9 @@ src_prepare() {
}
src_configure() {
- local myconf
-
- if use crypt ; then
- myconf+=" --with-gpgme=gpgme-config"
- else
- myconf+=" --without-gpgme"
- fi
-
- if use webkit || use gtkhtml; then
- if use gtkhtml ; then
- myconf+=" --with-html-widget=gtkhtml4"
- else
- myconf+=" --with-html-widget=webkit2"
- fi
- else
- myconf+=" --with-html-widget=no"
- fi
-
gnome2_src_configure \
--with-canberra \
+ $(usex crypt --with-gpgme=gpgme-config --without-gpgme) \
$(use_with gnome) \
$(use_with gnome gtksourceview) \
$(use_with gnome-keyring libsecret) \
@@ -93,5 +73,5 @@ src_configure() {
$(usex spell --with-spell-checker=gspell --with-spell-checker=no) \
$(use_with sqlite) \
$(use_with xface compface) \
- ${myconf}
+ $(usex webkit --with-html-widget=webkit2 --with-html-widget=no)
}