summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'mail-client/cone')
-rw-r--r--mail-client/cone/Manifest2
-rw-r--r--mail-client/cone/cone-0.89.ebuild61
-rw-r--r--mail-client/cone/cone-0.90-r1.ebuild66
-rw-r--r--mail-client/cone/cone-0.90.ebuild62
-rw-r--r--mail-client/cone/files/cone-0.84.20100819-aspell-automagic.patch84
-rw-r--r--mail-client/cone/files/cone-0.86-skip-rfc2045-test.patch11
-rw-r--r--mail-client/cone/files/cone-0.90-gnutls3.patch72
-rw-r--r--mail-client/cone/metadata.xml8
8 files changed, 366 insertions, 0 deletions
diff --git a/mail-client/cone/Manifest b/mail-client/cone/Manifest
new file mode 100644
index 000000000000..1e5d0e2df154
--- /dev/null
+++ b/mail-client/cone/Manifest
@@ -0,0 +1,2 @@
+DIST cone-0.89.tar.bz2 3794802 SHA256 71678cb2a95cd02ce2c734549dee9c542e29c3a29c376b64884022febb0d3fba SHA512 86f9842381702b05446e62f5933bd080b931018f2a7136169fc7a5da1d601f108e83cc6509bc0f0ad53f374df25a45ab68bac38274e4df1f5e40ee04124ada3b WHIRLPOOL de8b3fda5f2eda359260153310364e160f22f26da5feee183370bf0f55ad67ceb587a6d1075bbe72488c84e199b86612d4157f0cbeae5309a4fb3d85096170be
+DIST cone-0.90.tar.bz2 3906323 SHA256 b03edfbf3392fb7b8d93574dad2bc4c7cbfca8890afabac8b99b21a9f46d8733 SHA512 6446f868e07a54bda074e403ce48d590a55e97cf25b7e6172ba02df1242a232ade52840a837dd92e70253159cc637c17876876db01445c60374152262329ae27 WHIRLPOOL 30f07794b712650bf2b5715aca912b34471f89cd812ce2a45c7b352c8bca392625c91a74d65917506a8f80e6255534f5ae4ebaa05b269745f1b2bc16c593d838
diff --git a/mail-client/cone/cone-0.89.ebuild b/mail-client/cone/cone-0.89.ebuild
new file mode 100644
index 000000000000..affd6167c36f
--- /dev/null
+++ b/mail-client/cone/cone-0.89.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit eutils autotools
+
+DESCRIPTION="CONE: COnsole News reader and Emailer"
+HOMEPAGE="http://www.courier-mta.org/cone/"
+SRC_URI="mirror://sourceforge/courier/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 ppc ~sparc x86"
+IUSE="crypt fam gnutls idn ipv6 ldap spell"
+
+RDEPEND=">=dev-libs/openssl-0.9.6
+ dev-libs/libxml2
+ sys-libs/ncurses
+ crypt? ( >=app-crypt/gnupg-1.0.4 )
+ fam? ( virtual/fam )
+ gnutls? ( net-libs/gnutls )
+ idn? ( net-dns/libidn )
+ ipv6? ( net-dns/libidn )
+ ldap? ( net-nds/openldap )
+ spell? ( app-text/aspell )"
+DEPEND="${RDEPEND}
+ dev-lang/perl"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-0.84.20100819-aspell-automagic.patch \
+ "${FILESDIR}"/${PN}-0.86-skip-rfc2045-test.patch
+
+ cd "${S}"/cone
+ LIBTOOLIZE="true" eautoreconf
+
+ cd "${S}"/rfc2045
+ eautomake
+}
+
+src_configure() {
+ local myconf
+ if use spell ; then
+ myconf="--with-spellcheck=aspell"
+ else
+ myconf="--with-spellcheck=none"
+ fi
+
+ econf \
+ ${myconf} \
+ $(use_with ldap ldapaddressbook) \
+ $(use_with gnutls) \
+ $(use_with idn libidn) \
+ $(use_with ipv6)
+}
+
+src_install() {
+ default
+ emake DESTDIR="${D}" install-configure
+}
diff --git a/mail-client/cone/cone-0.90-r1.ebuild b/mail-client/cone/cone-0.90-r1.ebuild
new file mode 100644
index 000000000000..d07d54e85933
--- /dev/null
+++ b/mail-client/cone/cone-0.90-r1.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit eutils autotools
+
+DESCRIPTION="CONE: COnsole News reader and Emailer"
+HOMEPAGE="http://www.courier-mta.org/cone/"
+SRC_URI="mirror://sourceforge/courier/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 ppc ~sparc x86"
+IUSE="crypt fam gnutls idn ipv6 ldap spell"
+
+RDEPEND=">=dev-libs/openssl-0.9.6
+ dev-libs/libxml2
+ sys-libs/ncurses
+ crypt? ( >=app-crypt/gnupg-1.0.4 )
+ fam? ( virtual/fam )
+ gnutls? ( net-libs/gnutls )
+ idn? ( net-dns/libidn )
+ ipv6? ( net-dns/libidn )
+ ldap? ( net-nds/openldap )
+ spell? ( app-text/aspell )"
+DEPEND="${RDEPEND}
+ dev-lang/perl"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-0.84.20100819-aspell-automagic.patch
+ epatch "${FILESDIR}"/${PN}-0.86-skip-rfc2045-test.patch
+ epatch "${FILESDIR}"/${P}-gnutls3.patch
+
+ # move local macro to m4 and run eautoreconf
+ mkdir "${S}/m4"
+ sed -n -e '/# AC_PROG_SYSCONFTOOL/,+33 p' "${S}"/aclocal.m4 > \
+ m4/sysconftool.m4 || die
+ sed -i -e '/^SUBDIRS/i ACLOCAL_AMFLAGS = -I m4' "${S}"/Makefile.am || die
+ sed -e "s/AM_CONFIG_HEADER/AC_CONFIG_HEADERS/" -i configure.in */configure.in || die
+ eautoreconf
+ # TODO: Find and fix the bug - #514048
+ cd cone && eautoreconf
+}
+
+src_configure() {
+ local myconf
+ if use spell ; then
+ myconf="--with-spellcheck=aspell"
+ else
+ myconf="--with-spellcheck=none"
+ fi
+
+ econf \
+ ${myconf} \
+ $(use_with ldap ldapaddressbook) \
+ $(use_with gnutls) \
+ $(use_with idn libidn) \
+ $(use_with ipv6)
+}
+
+src_install() {
+ default
+ emake DESTDIR="${D}" install-configure
+}
diff --git a/mail-client/cone/cone-0.90.ebuild b/mail-client/cone/cone-0.90.ebuild
new file mode 100644
index 000000000000..dba487ad4377
--- /dev/null
+++ b/mail-client/cone/cone-0.90.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit eutils autotools
+
+DESCRIPTION="CONE: COnsole News reader and Emailer"
+HOMEPAGE="http://www.courier-mta.org/cone/"
+SRC_URI="mirror://sourceforge/courier/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 ppc ~sparc x86"
+IUSE="crypt fam gnutls idn ipv6 ldap spell"
+
+RDEPEND=">=dev-libs/openssl-0.9.6
+ dev-libs/libxml2
+ sys-libs/ncurses
+ crypt? ( >=app-crypt/gnupg-1.0.4 )
+ fam? ( virtual/fam )
+ gnutls? ( net-libs/gnutls )
+ idn? ( net-dns/libidn )
+ ipv6? ( net-dns/libidn )
+ ldap? ( net-nds/openldap )
+ spell? ( app-text/aspell )"
+DEPEND="${RDEPEND}
+ dev-lang/perl"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-0.84.20100819-aspell-automagic.patch \
+ "${FILESDIR}"/${PN}-0.86-skip-rfc2045-test.patch
+
+ # move local macro to m4 and run eautoreconf
+ mkdir "${S}/m4"
+ sed -n -e '/# AC_PROG_SYSCONFTOOL/,+33 p' "${S}"/aclocal.m4 > \
+ m4/sysconftool.m4 || die
+ sed -i -e '/^SUBDIRS/i ACLOCAL_AMFLAGS = -I m4' "${S}"/Makefile.am || die
+ eautoreconf
+}
+
+src_configure() {
+ local myconf
+ if use spell ; then
+ myconf="--with-spellcheck=aspell"
+ else
+ myconf="--with-spellcheck=none"
+ fi
+
+ econf \
+ ${myconf} \
+ $(use_with ldap ldapaddressbook) \
+ $(use_with gnutls) \
+ $(use_with idn libidn) \
+ $(use_with ipv6)
+}
+
+src_install() {
+ default
+ emake DESTDIR="${D}" install-configure
+}
diff --git a/mail-client/cone/files/cone-0.84.20100819-aspell-automagic.patch b/mail-client/cone/files/cone-0.84.20100819-aspell-automagic.patch
new file mode 100644
index 000000000000..d6b4d09b5f23
--- /dev/null
+++ b/mail-client/cone/files/cone-0.84.20100819-aspell-automagic.patch
@@ -0,0 +1,84 @@
+--- cone-0.84.20100819/cone/configure.in.orig 2010-11-11 22:08:37.279191265 -0800
++++ cone-0.84.20100819/cone/configure.in 2010-11-11 23:26:22.685898387 -0800
+@@ -168,19 +168,9 @@
+ LIBS="$save_LIBS"
+ AC_MSG_RESULT($PSPELL)
+
+-ALLSPELLOBJ='spellcheckerNone.$(OBJEXT)'
+-if test "$ASPELL" = "yes"
+-then
+- ALLSPELLOBJ='spellcheckerAspell.$(OBJEXT)'" $ALLSPELLOBJ"
+-fi
+-
+-if test "$PSPELL" = "yes"
+-then
+- ALLSPELLOBJ='spellcheckerPspell.$(OBJEXT)'" $ALLSPELLOBJ"
+-fi
+-
+ AC_ARG_WITH(spellcheck, [ --with-spellcheck=pspell Use pspell for spell checking
+- --with-spellcheck=aspell Use aspell for spell checking], [
++ --with-spellcheck=aspell Use aspell for spell checking
++ --with-spellcheck=none Disable spell checking], [
+
+ case "$withval" in
+ pspell)
+@@ -196,6 +186,10 @@
+ AC_MSG_ERROR(aspell library not found)
+ fi
+ ;;
++none)
++ SPELL="no"
++ # Spellchecking is not enabled
++ ;;
+ *)
+ AC_MSG_ERROR(Invalid --with-spellcheck option)
+ ;;
+@@ -216,24 +210,34 @@
+ AC_MSG_RESULT(yes)
+ ], AC_MSG_RESULT(no))
+
+-if test "$ASPELL" = "yes"
++if test "$SPELL" = "no"
+ then
+- SPELL_OBJ='spellcheckerAspell.$(OBJEXT)'
+- AC_DEFINE_UNQUOTED(USE_ASPELL, 1, [ Use aspell library for spell checking ])
+- SPELL_LIB='-laspell'
++ ALLSPELLOBJ='spellcheckerNone.$(OBJEXT)'
++ SPELL_OBJ='spellcheckerNone.$(OBJEXT)'
++ SPELL_LIB=''
++ AC_MSG_WARN(Disabling spell checking)
+ else
+- if test "$PSPELL" = "yes"
++ if test "$ASPELL" = "yes"
+ then
+- AC_DEFINE_UNQUOTED(USE_PSPELL, 1, [ Use aspell library for spell checking ])
+- SPELL_OBJ='spellcheckerPspell.$(OBJEXT)'
+- SPELL_LIB='-lpspell'
++ ALLSPELLOBJ='spellcheckerAspell.$(OBJEXT)'" $ALLSPELLOBJ"
++ SPELL_OBJ='spellcheckerAspell.$(OBJEXT)'
++ AC_DEFINE_UNQUOTED(USE_ASPELL, 1, [ Use aspell library for spell checking ])
++ SPELL_LIB='-laspell'
+ else
+- AC_MSG_WARN(---------------------------------------------------------------)
+- AC_MSG_WARN(Neither pspell nor aspell was found -- disabling spell checking)
+- AC_MSG_WARN(---------------------------------------------------------------)
+- sleep 5
+- SPELL_OBJ='spellcheckerNone.$(OBJEXT)'
+- SPELL_LIB=''
++ if test "$PSPELL" = "yes"
++ then
++ ALLSPELLOBJ='spellcheckerPspell.$(OBJEXT)'" $ALLSPELLOBJ"
++ AC_DEFINE_UNQUOTED(USE_PSPELL, 1, [ Use aspell library for spell checking ])
++ SPELL_OBJ='spellcheckerPspell.$(OBJEXT)'
++ SPELL_LIB='-lpspell'
++ else
++ AC_MSG_WARN(---------------------------------------------------------------)
++ AC_MSG_WARN(Neither pspell nor aspell was found -- disabling spell checking)
++ AC_MSG_WARN(---------------------------------------------------------------)
++ sleep 5
++ SPELL_OBJ='spellcheckerNone.$(OBJEXT)'
++ SPELL_LIB=''
++ fi
+ fi
+ fi
+
diff --git a/mail-client/cone/files/cone-0.86-skip-rfc2045-test.patch b/mail-client/cone/files/cone-0.86-skip-rfc2045-test.patch
new file mode 100644
index 000000000000..4cd5206a145f
--- /dev/null
+++ b/mail-client/cone/files/cone-0.86-skip-rfc2045-test.patch
@@ -0,0 +1,11 @@
+--- cone-0.86/rfc2045/Makefile.am.orig
++++ cone-0.86/rfc2045/Makefile.am
+@@ -77,6 +77,6 @@
+ endif
+
+ check-am:
+- @SHELL@ $(srcdir)/testsuite | cmp -s - $(srcdir)/$(TESTSUITE)
+- @SHELL@ $(srcdir)/testsuitemm | cmp -s - $(srcdir)/testsuitemm.txt
++# @SHELL@ $(srcdir)/testsuite | cmp -s - $(srcdir)/$(TESTSUITE)
++# @SHELL@ $(srcdir)/testsuitemm | cmp -s - $(srcdir)/testsuitemm.txt
+ @SHELL@ $(srcdir)/testrfc3676parsersuite | diff -U 3 $(srcdir)/testrfc3676parsersuite.txt -
diff --git a/mail-client/cone/files/cone-0.90-gnutls3.patch b/mail-client/cone/files/cone-0.90-gnutls3.patch
new file mode 100644
index 000000000000..23f187bb0182
--- /dev/null
+++ b/mail-client/cone/files/cone-0.90-gnutls3.patch
@@ -0,0 +1,72 @@
+diff --git a/tcpd/configure.in b/tcpd/configure.in
+index 7261515..406914e 100644
+--- a/tcpd/configure.in
++++ b/tcpd/configure.in
+@@ -356,7 +356,7 @@ then
+
+ CPPFLAGS="$save_CPPFLAGS"
+ else
+- have_gnutls="no: pkgconfig --modeversion gnutls failed"
++ have_gnutls="no: pkgconfig --modversion gnutls failed"
+ fi
+ else
+ have_gnutls="no: pkg-config not found"
+@@ -368,7 +368,15 @@ if test "$have_gnutls" = "yes"
+ then
+ LIBCOURIERTLSGNUTLS="libcouriertlsgnutls.la"
+ CPPFLAGS="$CPPFLAGS `$PKGCONFIG --cflags gnutls`"
+- gnutlsdep="`$PKGCONFIG --libs gnutls` -lgnutls-extra"
++ have_gnutls3=no
++ PKG_CHECK_EXISTS([gnutls >= 3.0], [have_gnutls3=yes])
++ if test "x$have_gnutls3" = "xno"
++ then
++ gnutlsdep="`$PKGCONFIG --libs gnutls` -lgnutls-extra"
++ else
++ gnutlsdep="`$PKGCONFIG --libs gnutls`"
++ AC_DEFINE([HAVE_GNUTLS3], [1], [Use GnuTLS3])
++ fi
+ fi
+
+ AC_CHECK_SIZEOF(gnutls_transport_ptr_t,0, [
+diff --git a/tcpd/libcouriergnutls.c b/tcpd/libcouriergnutls.c
+index 4aa4996..ef8cb70 100644
+--- a/tcpd/libcouriergnutls.c
++++ b/tcpd/libcouriergnutls.c
+@@ -9,7 +9,9 @@
+ #include "tlscache.h"
+ #include "soxwrap/soxwrap.h"
+ #include <gnutls/gnutls.h>
++#ifndef HAVE_GNUTLS3
+ #include <gnutls/extra.h>
++#endif
+ #include <gnutls/x509.h>
+ #include <gnutls/openpgp.h>
+ #include <stdio.h>
+@@ -146,7 +148,11 @@ static const struct intmap {
+ { NULL, 0}
+ }, all_comps[]={
+ { "DEFLATE", GNUTLS_COMP_DEFLATE},
++#ifndef HAVE_GNUTLS3
+ { "LZO", GNUTLS_COMP_LZO},
++#else
++ { "ZLIB", GNUTLS_COMP_ZLIB},
++#endif
+ { "NULL", GNUTLS_COMP_NULL},
+ { NULL, 0}
+ }, all_certs[]={
+@@ -408,6 +414,7 @@ ssl_context tls_create(int isserver, const struct tls_info *info)
+ return (NULL);
+ }
+
++#ifndef HAVE_GNUTLS3
+ if (gnutls_global_init_extra() < 0)
+ {
+ gnutls_global_deinit();
+@@ -416,6 +423,7 @@ ssl_context tls_create(int isserver, const struct tls_info *info)
+ errno=EINVAL;
+ return (NULL);
+ }
++#endif
+ }
+
+ if (!(words=splitwords(safe_getenv(p, "TLS_PROTOCOL",
diff --git a/mail-client/cone/metadata.xml b/mail-client/cone/metadata.xml
new file mode 100644
index 000000000000..5c974e7d457b
--- /dev/null
+++ b/mail-client/cone/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>net-mail</herd>
+ <upstream>
+ <remote-id type="sourceforge">courier</remote-id>
+ </upstream>
+</pkgmetadata>