summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'mail-client/neomutt/neomutt-9999.ebuild')
-rw-r--r--mail-client/neomutt/neomutt-9999.ebuild46
1 files changed, 30 insertions, 16 deletions
diff --git a/mail-client/neomutt/neomutt-9999.ebuild b/mail-client/neomutt/neomutt-9999.ebuild
index 8496d18ad8c9..7b36a57de365 100644
--- a/mail-client/neomutt/neomutt-9999.ebuild
+++ b/mail-client/neomutt/neomutt-9999.ebuild
@@ -64,23 +64,29 @@ S="${WORKDIR}/${PN}-${P}"
src_configure() {
local myconf=(
"$(use_enable doc)"
- "$(use_enable gpg gpgme)"
- "$(use_enable gpgme)"
"$(use_enable nls)"
"$(use_enable notmuch)"
- "$(use_enable crypt pgp)"
- "$(use_enable pgp_classic pgp)"
- "$(use_enable smime)"
- "$(use_enable smime_classic smime)"
+
+ # During the transition of the crypto USE flags we need to support
+ # both sets of flags. We do not want to emit a configuration setting
+ # twice, since the second flag overrides the first, potentially
+ # leading to unwanted settings. See https://bugs.gentoo.org/640824 for
+ # details.
+ "$(if use gpg || use gpgme; then echo "--enable"; else echo "--disable"; fi)-gpgme"
+ "$(if use crypt || use pgp_classic; then echo "--enable"; else echo "--disable"; fi)-pgp"
+ "$(if use smime || use smime_classic; then echo "--enable"; else echo "--disable"; fi)-smime"
+
+ # Database backends.
"$(use_enable berkdb bdb)"
"$(use_enable gdbm)"
+ "$(use_enable kyotocabinet)"
+ "$(use_enable qdbm)"
+ "$(use_enable tokyocabinet)"
+
"$(use_enable idn)"
"$(use_enable kerberos gss)"
- "$(use_enable kyotocabinet)"
"$(use_enable lmdb)"
- "$(use_enable qdbm)"
"$(use_enable sasl)"
- "$(use_enable tokyocabinet)"
"--with-ui=$(usex slang slang ncurses)"
"--sysconfdir=${EPREFIX}/etc/${PN}"
"$(use_enable ssl)"
@@ -110,11 +116,19 @@ src_install() {
}
pkg_postinst() {
- ewarn "Pleae note that the crypto related USE flags of neomutt have changed."
- ewarn "(https://bugs.gentoo.org/637176)"
- ewarn "crypt -> pgp_classic"
- ewarn "gpg -> gpgme"
- ewarn "smime -> smime_classic"
- ewarn "The old USE flags still work but their use is deprecated and will"
- ewarn "be removed in a future release."
+ if use crypt || use gpg || use smime; then
+ ewarn "Pleae note that the crypto related USE flags of neomutt have changed."
+ ewarn "(https://bugs.gentoo.org/637176)"
+ ewarn "crypt -> pgp_classic"
+ ewarn "gpg -> gpgme"
+ ewarn "smime -> smime_classic"
+ ewarn "The old USE flags still work but their use is deprecated and will"
+ ewarn "be removed in a future release."
+ if use gpg && ( use crypt || use smime ); then
+ ewarn " Note that gpgme (old gpg) includes both pgp and smime"
+ ewarn " support. You can probably remove pgp_classic (old crypt)"
+ ewarn " and smime_classic (old smime) from your USE-flags and"
+ ewarn " only enable gpgme."
+ fi
+ fi
}