summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'mail-client/sylpheed')
-rw-r--r--mail-client/sylpheed/sylpheed-3.4.2.ebuild9
-rw-r--r--mail-client/sylpheed/sylpheed-3.4.3-r1.ebuild7
-rw-r--r--mail-client/sylpheed/sylpheed-3.4.3.ebuild7
3 files changed, 13 insertions, 10 deletions
diff --git a/mail-client/sylpheed/sylpheed-3.4.2.ebuild b/mail-client/sylpheed/sylpheed-3.4.2.ebuild
index fb700aa08d2d..1e2f537f4577 100644
--- a/mail-client/sylpheed/sylpheed-3.4.2.ebuild
+++ b/mail-client/sylpheed/sylpheed-3.4.2.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI="5"
-inherit eutils
+inherit eutils multilib
DESCRIPTION="A lightweight email client and newsreader"
HOMEPAGE="http://sylpheed.sraoss.jp/"
@@ -22,7 +22,7 @@ CDEPEND="x11-libs/gtk+:2
oniguruma? ( dev-libs/oniguruma )
pda? ( app-pda/jpilot )
spell? ( app-text/gtkspell:2 )
- ssl? ( dev-libs/openssl )"
+ ssl? ( dev-libs/openssl:0 )"
RDEPEND="${CDEPEND}
app-misc/mime-types
net-misc/curl"
@@ -41,6 +41,7 @@ src_configure() {
$(use_enable spell gtkspell) \
$(use_enable ssl) \
$(use_enable xface compface) \
+ --with-plugindir=/usr/$(get_libdir)/${PN}/plugins \
--with-manualdir=${htmldir}/manual \
--with-faqdir=${htmldir}/faq \
--disable-updatecheck
@@ -54,7 +55,7 @@ src_install() {
domenu *.desktop
cd plugin/attachment_tool
- docinto plugin/attachment_tool
emake DESTDIR="${D}" install-plugin
+ docinto plugin/attachment_tool
dodoc README
}
diff --git a/mail-client/sylpheed/sylpheed-3.4.3-r1.ebuild b/mail-client/sylpheed/sylpheed-3.4.3-r1.ebuild
index febe5932947c..ee8c88fb1090 100644
--- a/mail-client/sylpheed/sylpheed-3.4.3-r1.ebuild
+++ b/mail-client/sylpheed/sylpheed-3.4.3-r1.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI="5"
-inherit eutils
+inherit eutils multilib
DESCRIPTION="A lightweight email client and newsreader"
HOMEPAGE="http://sylpheed.sraoss.jp/"
@@ -44,6 +44,7 @@ src_configure() {
$(use_enable spell gtkspell) \
$(use_enable ssl) \
$(use_enable xface compface) \
+ --with-plugindir=/usr/$(get_libdir)/${PN}/plugins \
--with-manualdir=${htmldir}/manual \
--with-faqdir=${htmldir}/faq \
--disable-updatecheck
@@ -57,7 +58,7 @@ src_install() {
domenu *.desktop
cd plugin/attachment_tool
- docinto plugin/attachment_tool
emake DESTDIR="${D}" install-plugin
+ docinto plugin/attachment_tool
dodoc README
}
diff --git a/mail-client/sylpheed/sylpheed-3.4.3.ebuild b/mail-client/sylpheed/sylpheed-3.4.3.ebuild
index 1b53b30d7e68..41684e15dee0 100644
--- a/mail-client/sylpheed/sylpheed-3.4.3.ebuild
+++ b/mail-client/sylpheed/sylpheed-3.4.3.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI="5"
-inherit eutils
+inherit eutils multilib
DESCRIPTION="A lightweight email client and newsreader"
HOMEPAGE="http://sylpheed.sraoss.jp/"
@@ -41,6 +41,7 @@ src_configure() {
$(use_enable spell gtkspell) \
$(use_enable ssl) \
$(use_enable xface compface) \
+ --with-plugindir=/usr/$(get_libdir)/${PN}/plugins \
--with-manualdir=${htmldir}/manual \
--with-faqdir=${htmldir}/faq \
--disable-updatecheck
@@ -54,7 +55,7 @@ src_install() {
domenu *.desktop
cd plugin/attachment_tool
- docinto plugin/attachment_tool
emake DESTDIR="${D}" install-plugin
+ docinto plugin/attachment_tool
dodoc README
}